Question about Kenmore 53509 Dehumidifier

1 Answer

Circuit breaker My dehumidifier trips the circuit breaker as soon as I plug it in. I have tried it on numerous outlets in my basement with the same result. Also, I have plugged in other appliances in the same outlets and they work fine

Posted by on

  • begonia Sep 17, 2008

    we have the exact same problem with Kenmore 53509.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 26 Answers

SOUNDS LIKE TO ME THAT YOUR DEHUMIDIFER HAS A SHORT. SOME TIMES ITS THE PLUG OR THE CORD BUT MOST TIMES IT GETS OXIDATION FROM MOISTURE INSIDE.

Posted on Jan 23, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Starting tripping circuit breaker


Good Afternoon Dennis - Often when this occurs, it is because there are too many appliances on the circuit or something may have a weak or poor breaker. Try plugging the unit in a different location or on its own circuit. If the issue continues, then it could also be possible that something shorted within the unit. So in this case, because it is a smaller appliance, repairs are often more costly than the actual unit replacement. You may want to check and see if your dehumidifier is still under warranty and if so, reach out to the manufacturer to determine the exact warranty coverage. Thanks for allowing me to help you.

Jul 28, 2013 | Frigidaire FAD504TDD Dehumidifier

1 Answer

When I plug it in and turn it on it trips the breaker. I have tried other outlets but it does the same thing.


Hi, The compressor is locked up and is bad... that is what trips the breaker...

There are many reasons why a dehumidifier willnot work or collect water.
Here is a tip that I wrote to help people to figure out what is going wrongwith their dehumidifier

Dehumidifier is running but no water is in bucket

heatman101

Jul 31, 2011 | Whirlpool Gold AD70USS 70 Pint Per Day...

1 Answer

Demudifier worked great, all a sudden it just stopped. No power. Now it won't start up. What should I try?


First, check the outlet that it's plugged into, to make sure that there's still power to the outlet. If there isn't, then the circuit breaker for that outlet has been tripped, in your home's circuit breaker panel. Leave the dehumidifier unplugged and reset the circuit breaker. If it trips again, without the dehumidifier unplugged, then the outlet is at fault. Perhaps there's a loose wire connection or the interior of the outlet is cracked.

If it didn't trip without the dehumidifier plugged in, plug the unit it in,. But, before you do, make sure the dehumidifier's Master ON/OFF Switch is OFF. Once it's plugged in, turn the Master ON/OFF Switch to ON and set your controls. If it runs now, GREAT! If it trips the circuit breaker again, there's either a short in the power cord or an internal electrical short. Which will require extensive troubleshooting to find.

Hope this helps you solve the problem. Please let me know. Thanks.

May 05, 2011 | Fedders A7DH45B2A Dehumidifier

1 Answer

I have two Haier HDN655E dehumidifier's. One works fine and the other wont come on. I have tried unplugging and plugged back in, hit the start button and nothing happens. Is there a reset switch or a...


Have you tested the outlet it's plugged into, to make sure it still has power? If it doesn't, check the circuit breaker panel in you home for a tripped circuit breaker. If there is one, unplug the dehumidifier, before resetting it. Then plug the dehumidifier back in. If the circuit breaker trips again, the problem is within the dehumidifier or the outlet is faulty (i.e. Loose wire, burned wire, broken outlet). If the outlet is not faulty, you should contact Haier America Parts and Repair 877-337-3639.

Hope this helped you to troubleshoot and solve the problem. Please let me know. Thanks.

Apr 28, 2011 | Dehumidifiers

1 Answer

Unit will start and run for 5 seconds, then will blow a circut breaker on 20A. circut. This is a model AD75USTO Serial # QU2660438 AKA Whirlpool gold energy star


Hopefully, it's not a problem inside the unit that's causing the circuit breaker to trip. Is there another electrical appliance plugged into the same outlet or on that circuit that is ON and draws 15 amps of power? If so, that's the problem. If that's not the case, turn the circuit breaker OFF and remove the outlet cover, so you can inspect the receptacle and it's wiring. A loose wiring connection or a broken or cracked receptacle could be the issue. If you don't find any damage reassemble the outlet and turn the circuit breaker back ON. Instead of plugging in the dehumidifier, plug in a lamp or something similar and turn it ON. Leave it on for more than 5 minutes to see if the circuit breaker trips again. If it does, you'll know the problem is either with the outlet receptacle or the circuit breaker. If doesn't, plug in the dehumidifier (Make sure the Master ON/OFF Switch on the unit is in the OFF position, before plugging it in. Then turn the Master ON/OFF Switch to ON and set your controls. If the circuit breaker trips again, the problem is in the dehumidifier. You will need to call Whirlpool Customer Care, as it's an internal electrical issue.

In case you have misplaced your Owners Manual, I have included a link to it, that you can download and print for future reference. http://www.kitchenaid.ca/assets/pdfs/literature/Use%20and%20Care%20Guide%20-%201188927.pdf

I hope what information I have provided to you, will help you trouble shoot and solve the problem.

Apr 16, 2011 | Whirlpool 75-Pint Dehumidifier

1 Answer

Circuit breaker trips when unit is plugged in


you have a dead short in the compressor.........SORRY

May 20, 2010 | Whirlpool Gold AD70USS 70 Pint Per Day...

1 Answer

Dehumidifier is tripping circuit breaker.


Hi,
The compressor is bad and is causing the circuits to trip....

Here is a tip that I wrote about that problem...

http://www.fixya.com/support/r4662409-dehumidifier_running_but_no_water_in

heatman101

Apr 16, 2010 | DeLonghi DE500P Dehumidifier

3 Answers

Ground fault as soon as I plug it in.


You more than likely have a dead short in the compressor

Nov 15, 2006 | Maytag M7DH65B2A Dehumidifier

2 Answers

Ground fault interrupt (GFI)


I have a Whirlpool Model AD$)DSR1 Dehumidifier, with similar issues. When plugged in where it was operating for three years with no problems, it would trip the gfci within 10 minutes. I have it out in the garage right now with all the covers off, and I've had it running on a heavy duty outlet for about a half hour now. The compressor is too hot to touch (ouch!), and the condenser coils are only cool, when they should be quite cold. I am ready to judge that one of two things has happened: Either the compressor is bad, or the refrigerant has leaked out of the system.

Sep 07, 2006 | Whirlpool AD50USL Dehumidifier

Not finding what you are looking for?
Kenmore 53509 Dehumidifier Logo

Related Topics:

228 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Dehumidifiers Experts

Bill Long

Level 3 Expert

577 Answers

Cindy Wells

Level 3 Expert

4753 Answers

kakima

Level 3 Expert

96372 Answers

Are you a Kenmore Dehumidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...