Question about InFocus ScreenPlay 4800 Multimedia Projector

1 Answer

New lamp installation-light doesnt always come on

We own a screenplay 4800 by infocus. We just recently installed a new lamp and housing. The first time we turned in on afterwards, it came right on. It has been about 2 weeks since new installation and occasionally, the light will not come on when the projector is turned on. Usually, after several tries, it will come on. We don't understand the problem. Can you explain?

Posted by on

  • voiculs Jul 28, 2008

    Ok my lamp went out on me now i have no image. i get a red blink 3 times on my led so i tryed to restart my projector but it did not solve my problem, bought a new lamp and installed it but i still get the same thing any suggestions on what i should do about it?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

I think your projector has power problem or check the menu if there is a function for the power setup..or could be u didnt reset lamp to 0 hrs if u changed new lamp at that time.

Posted on Jun 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to tell if your bulb is broken


put the new lamp into another projector ,you can check the lamp whether if is OK

Feb 09, 2014 | InFocus ScreenPlay 4800 Multimedia...

1 Answer

High pitched 'screaming' sound


try checking the fan could be it needs a bit of oil or reolacing.

May 25, 2010 | InFocus ScreenPlay 4800 Multimedia...

1 Answer

Lamp comes on, fan running at a very high speed


if the lamp is on and no image, you have a main board issue. you'll need to replace it.

Mar 18, 2010 | InFocus ScreenPlay 4800 Multimedia...

1 Answer

New lamp, no power!


if there are no leds lit, i'm surprised that it powers up. but if there is no light when the fans are running, it may be the ballast that needs replacing.

Oct 14, 2009 | InFocus ScreenPlay 5000 Multimedia...

1 Answer

Red light blinking


it was the color wheel, does any one know where to get one

Feb 03, 2009 | InFocus ScreenPlay 4800 Multimedia...

1 Answer

Screenplay 5700


Because these units have dangerous high voltages inside, there are a number of safety interlocks throughout. Take out the lamp and reseat it. Also, make sure that the access door is installed correctly and securely. Both have interlocks that will prevent a poiwer up is not installed correctly.

If this is not the case for you, please update this and we'll look for other causes.

Thanks,
Dan

Jan 05, 2009 | InFocus ScreenPlay 5700 Multimedia...

1 Answer

Screenplay 4800


Go to main menu press select on the remote, select settings, select service, then select factory reset and all settings and hour reading will return to zero hours.

Jun 24, 2008 | InFocus ScreenPlay 4800 Multimedia...

1 Answer

No picture new lamp


try turning the projector on and wait for one minute. On the projector keypad, press and hold the Volume + and Volume - keys for ten seconds.

Apr 08, 2008 | InFocus ScreenPlay 4800 Multimedia...

Not finding what you are looking for?
InFocus ScreenPlay 4800 Multimedia Projector Logo

Related Topics:

137 people viewed this question

Ask a Question

Usually answered in minutes!

Top InFocus Multimedia Projectors Experts

Juan Carlos Pacheco

Level 1 Expert

36 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5653 Answers

Are you an InFocus Multimedia Projector Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...