Question about Sony KP-57WS500 57" Rear Projection Television

1 Answer

KP-57WS500 Very grateful for your help. I checked every resistor and 6 fuses under teh fin. Each one is good. Could there be something else? Thanks.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Sony Master
  • 8,617 Answers

Did you check the huge resistors in front of the heat sinks? If so the next items to check would be the velocity boards that are attached to the convergence yokes on each tube the resistors on those boards could be open as well.

Posted on Jun 22, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My TV is showing convergence symptoms: the screen looks like 3D effects and as if someone is pusing in the middle of the screen. I've replaced my STK's, 2 pico fuses on the G board, and tested each...


One of two things:
Either:
a) The STK chips you put in are no good (not uncommon)

or

If you weren't careful you may have removed a surface mount resistor accidently while desoldering the orignal STKs. I had a customer do that to me once and figured it out by comparing the board to the schematic for that board location.

Feb 19, 2011 | Sony KP-57WS500 57" Rear Projection...

1 Answer

I've replaced my STK's, 2 pico fuses on the G boards, and tested each convergence resistor along with the pico fuses on the D board--albeit they were still soldered in place. I desoldered two pico fuses...


I believe there is a power board on the left side when looking from the back. It will be vertical, right next to the board you worked on. Take that board out. I believe there are about four pico fuses on that board. One or two of them will be open. Replace the fuses and you should be good to go.

Feb 19, 2011 | Sony KP-57WS500 57" Rear Projection...

1 Answer

Convergence issue with kp-57ws500


You have to remove one leg of each pico fuse to test them properly. Same goes for the resistors. Other options is you have a bad soldering joint or a faulty STK chip still.

Jan 31, 2009 | Sony KP-57WS500 57" Rear Projection...

1 Answer

IC Convergence replacement


you will no doubt need two STK392-560 ICs and quite possibly two 3.5 amp pico fuses, and its a good idea to get two 4.7 ohm 1/2 watt resistors as well. You can get all the parts you need at the following link and they will provide free installation instructions with pictures and free online tech support while you do the actual repair if you need it. Heres the link.
http://servicemanuals.vstore.ca/

Sep 30, 2008 | Sony KP-57WS500 57" Rear Projection...

2 Answers

Six (6) blinks on the Timer/Standby led


6 blinks means lamp thermal fuse blowing, replace thermal fuse.

See here

Aug 30, 2008 | Sony KP-57WS500 57" Rear Projection...

1 Answer

Convergence


there are a series of 4.7 ohm 1/2 watt resistors all in a row under the fins of the ICs. Check them they have to have one side unsolderd to check them. There are also 6 yellow pico fuses in that line of resistors that need to be checked as well.

Jul 05, 2008 | Sony KP-57WS510 57" Rear Projection HDTV

1 Answer

KP-57WS500


3.5 amp picos. You can get resistors and picos at the following link and they have free shipping if you cant find them locally.
http://servicemanuals.vstore.ca/

Jun 21, 2008 | Sony KP-57WS500 57" Rear Projection...

1 Answer

KP 57WS500


You have to check each one, but you need to lift one side of each resistor out of circuit to test by unsoldering one leg, as a open resistor can pick up resistance from the circuit and test good when its actually open.

Jun 21, 2008 | Sony KP-57WS500 57" Rear Projection...

1 Answer

KP-57WS500


If you look at the Convergence ICs you will notice a row of resistors under the fins of the heat sink. Those are the 4.7 ohm resistors. Also in that same row of resistors you will notice the 6 yellow picos they are all lined up the picos have 4 grouped together then 1 more on each end of that row or resistors.

Jun 21, 2008 | Sony KP-57WS500 57" Rear Projection...

1 Answer

Sony KP-57WS500


did you replace or check the 4.7 ohm 1/2 watt resistors or the 6 pico fuses when you changed ICs? If not thats most likely your problem.

Jun 21, 2008 | Sony KP-57WS500 57" Rear Projection...

Not finding what you are looking for?
Sony KP-57WS500 57" Rear Projection Television Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Projection Televisions Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Ap12
Ap12

Level 2 Expert

103 Answers

Jason Harris
Jason Harris

Level 2 Expert

256 Answers

Are you a Sony Projection Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...