Question about Mitsubishi VS-60603 60" Rear Projection Television

3 Answers

Mitsubishi VS-60603 60

Hello,

I recently had a power outage. My tv will now only allow me to switch inputs from Ant -A to Ant - B. None of the other inputs are accessible. Normally Ant-A is where i view my cable, but now i only get audio and the screen is black.

OH, also the tv just shut itself of after 5-10 minutes of being on with audio but no visual. All of these problems from a storm??? UGHHHHH!!!!!!

Thank you in advance for sharing your time and knowledge.



Best Regards,
Nigel

Posted by on

  • 4 more comments 
  • wielandjo Jul 04, 2008

    I also have a Mitsubishi VS-60603, exact same problem.  After a power fail, (yes I have a surge protector), I can only get antenna-a/antenna-b on the input mode.  Screen is black and only audio.  If I go into the menu, I see the (small) picture fine and color is fine..

    Changing the input/mode makes a 'click' in the back of the unit.  Initial guess is that a mechanical device is used to switch between input signals and this device has worn out.  just a guess....

    Nigel, since we have the same  problem, have you found a solution?

    Thanks.
    JohnW

  • Anonymous Jul 15, 2008

    please turn off and unplug it for 24 hours then plug it back in and do not try to turn it on at that moment.let it set while it resits it self.give it a few hours then tyr it.it should work.

  • cjc8 Mar 03, 2009

    Had the same problem, Mitsub. didn't know how to fix it nor did they have an owners manual. The solution that "guest" provides was a MIRACLE! It worked!!!!! After 2 weeks of messing with it and endless hours unplugging and reconecting everything and letting it sit unplugged and so on and so on the Menu, Setup, Enter, AV Conn, Enter, AV Net, Basic, Lock Inp. 1, No, Menu was simple and it worked!!!! Thank You! You have made me a very happy person! You ROCK!!!!!!!!!!!!!!!!!!!!!!!!!

  • angela_137 Apr 21, 2009

    Thank you so much...this did the trick after weeks of weeks of not being able to watch the tv.

  • kristi1508 May 11, 2010

    We could kiss you!!!! After months of not being able to get the picture in picture off this fixed the problem. Thanks so much!!

  • wielandjo May 11, 2010

    I have tried the recommended soution to 'reset' my VS-60603 by pulling the plug for 24 hours, then waiting 5 hours after plugging it in before turning it on.  STILL THE SAME PROBLEM...

    Has anyone else come up with a solution that works?  I have a copy of the scam's if anyone wants to contact me..  As soon as I get some time on my hands, I will dig into my set and track this thing down but that may not be till next month..

    jw

×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

This was the perfect solution..my whole family thanks you for this information. It worked in two seconds!!

Posted on Apr 21, 2009

  • lmahlstede May 01, 2011

    Thanks my son stole our extention cord that all of our equipment was plugged into. My husband saw it and flipped! After an hour of his ranting I decided to google it. It was fixed in seconds. Thank you!

×

After waiting 90 days for an answer, I found it on another web site.  (what does that say for the 'experts' here?)  Nigel, if you still have the TV, here is the SOLUTION.  (and it works!!!) - The problem has to do with a memory chip that goes flakey...  Each time you lose power from now on, you will have to do the following:  (not that bad, tape it to the TV)

Using the remote that came with the television.

Press “Menu”

Scroll yellow to “Setup”

Press “Enter”

Scroll yellow to “AV Connection”

Press “enter”

Scroll yellow to right side of “AV Network”

Select “Basic”

Scroll yellow to right side of “Locked to Input 1”

Select “No”

Press “Menu” over and over to exit

Now press “Input” for your input selections.

ENJOY....

Posted on Oct 10, 2008

  • Dean Stewart
    Dean Stewart May 23, 2011

    Dear Guest,

    Our VS-60603 had the same issue.

    Your solution worked perfectly!!
    Go to Menu > Setup > AV Connections (Select Home Theater) > "Locked to Input 1", select "No" or "Off".

    TYVM!!!
    Dean

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

YOU are THE MAN !!!!! this solution worked !!! I have repaired the motherboard twice form bad FETS and this I had no idea how to fix, I almost dropped $2K on a new HD but this saved me for a while. my familly and especially my wife thank you !!!.
awesome.
Dave C

Posted on Jun 25, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mitsubishi VS-45603 had power outage and when it came back on it says TV is locked. How do I unlock it?


Go into the 'Menu' -> then 'Setup' -> then 'A/V Connections'.

You should see an option called 'Locked to Input' switch it to 'No' and your problem should be solved!

May 05, 2011 | Mitsubishi VS-45603 45" Rear Projection...

5 Answers

Mitsubishi VS-45603


You will need to go into the menu, setup, a/v connection, then make sure the locked to input is selected to no..


Good luck..

Sep 17, 2008 | Mitsubishi VS-45603 45" Rear Projection...

1 Answer

I have a Mitsubishi VS-50705. It's a 50inch rear projection TV. The TV only allows me to switch between the ANT A and ANT B inputs, none of the others. When I plug in cable to either ANT A or ANT B nothing...


Hi con,
Welcome to FixYa.
My name is John.
I will be assisting you with your issue.
Go to SET-UP in the MENU.
Then do a CHANNEL SCAN or AUTO PROGRAM SCAN.
You should be good to go..
Thanks for choosing FixYa.
John

Jan 06, 2011 | Mitsubishi VS-50705 50" Rear Projection...

2 Answers

My Ant A Input Not Working


Good Day, babt;
TRY THIS:

MAY ONLY BE ABLE TO SELECT ANTENNA A AND B. WITH THE REMOTE CONTROL PRESS MENU, SELECT "SET UP" AND THEN "AV CONNECTION HOME THEATER" SET "AV NETWORK" TO "OFF" AND "TV LOCKED TO INPUT 1" TO "NO" THEN EXIT THE CUSTOMER''S MENU, TURN THE UNIT OFF UNPLUG IT AND THEN PLUG IT BACK IN, IF THE PROBLEM RETURNS AN E2 RESET IS NEEDED. ACCESS THE OPTION MENU BY PRESSING "MENU 1, 3, 7, 0", USE THE ADJUST BUTTON TO SELECT "E2 RESET" AND PRESS "QV". IF THIS IS NOT RESOLVED BY THE E2 RESET REPLACE THE EEPROM, IC701 PART # 275P163010. THE E2 RESET IS ALSO NECESSARY AFTER REPLACEMENT OF IC701.
Good Luck, big IRISH.

Aug 06, 2008 | Mitsubishi VS-50603 50" Rear Projection...

1 Answer

"ant A" and "ant B" inputs go black when the tv is first turned on.


Try opening that "Ant A, B" device and apply some fresh solder to all the components inside. Also you can try to by-pass that device using the connector below. One end connects the cable in and the other end connects to the circuitry inside the TV.

b7e27de.jpg

Jan 24, 2008 | Mitsubishi VS-60609 60" Rear Projection...

4 Answers

Mitsubishi VS-50603, input is gone


happened to me also. Go to the menu, select setting, thrn av (home theater) and see if "locked to input 1" is "on". Mine was. then I set it to "off" and everyting works great

Dec 06, 2007 | Mitsubishi VS-50603 50" Rear Projection...

Not finding what you are looking for?
Projection Televisions Logo

918 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Projection Televisions Experts

matt martin
matt martin

Level 3 Expert

1191 Answers

Jaime Hernandez

Level 3 Expert

2267 Answers

The Knight
The Knight

Level 3 Expert

68223 Answers

Are you a Mitsubishi Projection Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...