Question about Digidesign Mbox External Sound System

2 Answers

Digidesign Mbox on Vista

My mbox hardware cannot be found when I try and open protool LE 7.4 on my Vista OS. All the lights are lit up on my mbox. How do I fix it?

Posted by on

  • 6 more comments 
  • glgray Jun 28, 2008

    I have the same problem, but with a Mac. When I plug the Mbox in, all the lights come on, and then Pro Tools 7.4.2 never sees the Mbox. I'm using OS X Leopard 10.5.3


    Thanks, Gary

  • Anonymous Nov 20, 2008

    similarly, i want to run the mbox with ableton live.

    ive looked and balked at changing OS to xp, but i hear there is a compatability mode with vista. thats all i got.

  • payupproduct Feb 12, 2009

    same problem here .stuck on vista

  • Anonymous Feb 17, 2009

    same issue for me cannot get mbox to work with shitty vista

  • Anonymous Feb 22, 2009

    "unable to locate digidesign hardware. make sure your hardware is connected and turned on . click o.k. when hardware is read"

  • mart453 Feb 26, 2009

    I have the same problem.I was advised to upload xp along side Vista to solve the problem but the new PC I bought wont let me rum xp and if it did it void the waranty.

  • Anonymous Mar 20, 2014

    windows 7 can not recognize my mbox digidesign

  • Anonymous Apr 01, 2014

    Is there a way to get around the fact that you need a Digidesign exterenal harware to run protools?

×

2 Answers

SOLUTION: Buy a product and/or use an OS that encourages open-source and standards-based development. E.g., sell the mBox on eBay to some idiot using OS X:Leper or whatever clever name Apple hides its BSD-based clone of its own System 9 behind and reformat yr harddrive.

SOLUTION FOR MAC USERS THAT SOMEHOW 'ME TOO'd A WINDOWS VISTA DRIVER INSTALL ISSUE WHEN REALLY THEY SPILLED CHOCOLATE MILK INTO THE MBOX: I recommend System 6.0.8 and Microsoft Works 2.0e.

Seriously, though, Vista (past the initial release; RC1 was problem-free, well, mBox-wise) will not work with an mBox and Digidesign "does not expect to release" repaired drivers. Therefore, Vista SP1 blocks the drivers from even loading, without your consent. No trouble installing or for the installer to communicate w/the mBox, though.

So the only and substantiated official solution is to buy a new mBox-series product.

Pretty lame.

Posted on Sep 25, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Same here but when i pull up protools the mbox does not power on !!I have the imac g5

Posted on Aug 07, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My mbox mini stopped working


Have you tried it plugged into another computer, just to see if it gets power? If it quit working and it hasn't been too long, you may be able to get it replaced for free where you bought it or from digidesign (digidesign.com)

Mar 29, 2009 | Digidesign MBox 2 Mini (USB, includes...

1 Answer

Can't get my mini mbox usb working for protools 8 after inserting


You were supposed to install the software first (which holds the drivers for the hardware) before you plugged in the MBox. I had the same problem, but I had to use drastic measures and reinstall my OS.

Mar 29, 2009 | Digidesign Command 8 USB Control Surface...

1 Answer

Mbox


This means that your firmware on the Mbox and the drivers need to be updated. I had the same problem afte updating my protools from version 6.7, Did you recently do any protools upgrades? You can go to Digidesign>My Digi>downloads>Mbox>firmware updates or>driver updates

Oct 17, 2008 | Digidesign Mbox External Sound System

1 Answer

Mbox problem (no input,output)


i'm running os 10.5.6 w/ protools 8.0 and the original mbox. i had the same problem. protools opened and seemed to work except there was no sound from either analog outputs or headphones. this worked for me:
1. shut down computer
2. unplugged all usb cables except keyboard/mouse
3. restarted computer
4. re-plugged usb cable from computer to mbox
5. opened protools session
6. hit play and now i'm hearing sound and everything seems normal.

i hope this helps everyone else

Oct 03, 2008 | Digidesign Mbox External Sound System

1 Answer

Mbox 2 and new macbook pro


my Mbox isnt being found by my mac. when i try and install protools it tells me the mbox carnt be found. i have tried different usb cables ect but nothing seems to work.

Jul 22, 2008 | Digidesign Mbox 2 Barebone

2 Answers

Mbox 2


dkjkjd jheuj'y je

Jun 13, 2008 | Digidesign Mbox 2 Barebone

3 Answers

All the lights are on on my Mbox. it wont be recognized by pro tools. help!!


un plug it uninstall the mbox and all the asio drivers. update protools. then reinstall the mbox and all the asio drivers you should be fine.

Feb 12, 2008 | Digidesign Mbox 2 Barebone

Not finding what you are looking for?
Digidesign Mbox External Sound System Logo

12,531 people viewed this question

Ask a Question

Usually answered in minutes!

Top Digi Computers & Internet Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yoyoyugo

Level 1 Expert

11 Answers

Are you a Digi Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...