Question about Electrolux Vacuums

1 Answer

Suction not working - Electrolux Vacuums

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Check your hose for a clog,also there could be a clog at thr dirt inlet by the brush roll.

Posted on Jun 21, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

MY WRLD VAC BRAVO II DOES NOT HAVE SUCTION


There could be something clogging the suction path.

Nov 30, 2016 | Vacuums

1 Answer

SPOT BOT NO SUCTION


Hey Courtney! Sorry to hear about the suction problem on your SpotBot. Here's a quick link to troubleshooting steps to assist you.

http://www.bissell.com/FAQDetail.aspx?id=1040&cid=ccsocial

Jan 04, 2013 | Bissell SpotBot Robotic Wet/Dry Vacuum

1 Answer

Hand held vacum suction stopped after 1st use. Was working fine, suction does work if onfloor but won't once turned to tool


go to the web page and see instructional video and maintenance help

http://www.bissell.com/how-to-videos/

God bless you

Jul 19, 2012 | Bissell 2X Proheat 9200 rug cleaner

1 Answer

Extreme vaccum has no suction.


Make sure you put the dirt cone back in the bucket to create the tight seal. You will have no suction without the dirt cone.

Bob
http://evacuumstore.com/

Dec 10, 2009 | Electrolux Centralux Vacuum

1 Answer

My DC17 suction hose doesn't have any suction occasionally.


check the seal on the filter is not broken,And check for any blockage at the bottom of the pickup pipe.

Nov 18, 2009 | Dyson DC17 Animal Bagless Upright Cyclonic...

3 Answers

The machine will not suction - it will spray and spin the brushes but will not suction - the power is going to the machine, but it will not suction.


Disconnect the suction hose. While running, check the suction port if it works, by putting a piece of paper. If the paper is taken in, then it is oK. Now, check the suction Hose for breaks or opening before the suction head. Breaks or opening breaks the suction power at the suction head. Loose connection between the suction pipe and the suction port also must be check as this will also cause the same
problem. You may need to replace the suction hose
to correct this problem,
Send us the e-mail and your vote if this solves your problem.

Sep 27, 2009 | Eureka Atlantis 2590A Wet/Dry Vacuum

1 Answer

I have a u3450 1500w hoover, suction on hose works fine, but carpet suction has never worked, how can i fix this?


There must be a restriction or blockage in the carpet suction pipe. Look at the port where the hose connects to the machine and check for any accumulation of debris or blockage. The same motor drives both suction inlets so it can only be that there is an obstruction.

Nov 02, 2008 | Hoover Vacuums

1 Answer

Suction only works using the hand held mode, there is no suction when try to use on carpet mode,


There must be a clog in either the hose, dirt inland by the brush roll, or bad filters. If you have suction at the end of the hose, then look lower all the way to the brush roll.

Mar 25, 2008 | Vacuums

Not finding what you are looking for?
Vacuums Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Roger Potts

Level 3 Expert

694 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18297 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...