Question about Car Amplifiers

1 Answer

Audiobahn A6004T No power or protection light but the fan and led effects work. Where would you start first and then second, third, ect.?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 48 Answers

Test for good 12v, ground and remote power to amp. make sure ur chassis ground is clean tight. if thats all good u have an internal problem

Posted on Jun 20, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When i connect battery wires to the amplifier it just blows the fuse, i have tried putting the fuse in last and it does the same thing? please help


First - disconnect ALL wires.... Power, Ground, Remote, RCA, Speakers.

Reconnect only power, and ground, and remote wire - being extra careful there are no wire strands sticking out of the terminal.

Now power on the amplifier.
If the fuse on the amplifier blows - the problem is internal and should be repaired by an electrical repair shop familiar with Car Audio Amplifiers - as Audiobahn is no longer in business - repair schematics are hard to come acros, and parts must be sourced elsewhere.

Thanks for using FixYa - a 4 THUMBS rating is appreciated for answering your FREE question.

Jan 29, 2010 | AudioBahn A6004T Car Audio Amplifier

1 Answer

I accidentlty made the positive and negative wires touch while connected to the amp what do i do


Check the unit for a blown fuse and replace it. Or reset the circuit breaker if it is equipped with one,

Oct 03, 2009 | AudioBahn A6004T Car Audio Amplifier

2 Answers

No sound protection light on.


Either blown subs, or bad amp.. Disconnect the subs, and try turning the amp on, if the amp is still in protect then your amp is bad, if the protect light goes off, then your subs are bad, or possibly wired at to low of an impedance, but I don't think that will trigger the protect on an Audiobahn amp.

Aug 21, 2009 | AudioBahn A2002T Car Audio Amplifier

1 Answer

Audiobahn a8000t problem


If the protect LED is lit, the amp probably has shortedoutput transistors. To eliminate other possible causes, read throughthe following page:

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Nov 23, 2008 | AudioBahn A8000T Car Audio Amplifier

3 Answers

My amp is on but the protection light stay's on!!


Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If the protect light remains on, the amp likely has blown output transistors.

Feb 28, 2008 | AudioBahn A2801Q Car Audio Amplifier

1 Answer

Audiobahn A2502DP amp is alive but wont talk to me


Your "bumpin" may have killed the amps "bumpin" Was the amp secure when you were sliding? So wires are ok, and lights and finas running. You have power but no output..Check the settings on the amp, also the fuse. Something might be earthing itself to the amp as well.

Feb 14, 2008 | AudioBahn A2502DP Car Audio Amplifier

2 Answers

Protect light stays on


It's likely that the output transistors have failed. If you measure the resistance between the second and third legs of the large transistors adjacent to the large (green?) resistors, you'll find several that read ~0 ohms. Its likely that only one of several that read 0 ohms is defective but all that read 0 ohms in the board are operating in parallel and must be replaced together so they match (electrically).

Disconnect the amp from the power source BEFORE trying to measure the resistance across the resistors.

Nov 25, 2007 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

Power & protect


my amp says Lo on the digital circle on top of the amp i have a mtx 9500 bridged to the amp and it cuts out at high volumes and suddenly please help



Dec 21, 2006 | AudioBahn A8000V 400W x 1 Car Amplifier...

1 Answer

My amp quit working


ok I thought I anwered this one but first thing to try is disconnect all your speakers and see if the light goes out if it doesnt then your gonna need a schematic and a working know how on solid state amplifiers. first check al the outputs for the speakers for dc If theres dc on an output then that output device is shorted or leaky. Ive have open drivers as well as current control transistors leaky or shorted to that made the protection come on.. Good Luck

Apr 07, 2006 | AudioBahn A6004T Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

118 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...