Question about Vacuums

1 Answer

Hoover wind tunnel

We have a wind tunnel "mach 4.7", I can't seem to find a model number. The unit turns off by itself, CONSTANTLY, after about 2 or 3 minutes of use. I keep it clean and clog free, but nothing seems to work. we even took it to a repairman who "fixed" it, which lasted about a month. The amount of dog hair it sucks up is incredible, but we run it on a pretty regular basis. We can only vacuum one room at a time because we need to let the damn thing "cool off". And we usually have to vacuum the rooms twice to get it all, so its takes all day to vacuum our house. any suggestions? Windtunnel Ultra U6425-900 vacuum shuts off after less than a minute of vacuuming; restarts after a cooling off period.  This only happens when using the floor brushes - not with attachments.  Recently had switch replaced, have replaced filters and bags with Hoover brand, all to no avail.  Any ideas?
Wandaq

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Did you check down by the brush roll for a clog in the dirt inlet. And is the brush roll turning freely, if it is being lugged down, it can cause the motor to overheat and the thermo protector will caught it off, until the motor cools down. But if both are ok, then maybe the motor protector needs to replaced, it is prematurely tripping.

Posted on Jun 19, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My hoover wind tunnel just quit while vacuuming. It is dead??? Two years old used about every other week? Any suggestions?


Some Wind Tunnels by Hoover have a poor design in the switch on the handle. Sometimes the switch does not turn on all the way and will stop running. Other times you can't turn the unit off.

Feb 28, 2015 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

How do you change the Hoover wind tunnel belts?


If you turn the vacuum over there will be (4) screws that hold on the base cover for the roller brush. Remove the screws and the cover and you can get to the belt(s). You can get replacement belts here:

Hoover Windtunnel Belts

Nov 18, 2009 | Hoover Company Wind Tunnel U53019 Upright...

1 Answer

Where is reset button on Hoover Wind Tunnel vacuum?


Hello my good friend, this cleaner doesn't have a reset button or anything, it resets by itself after cooling down, it takes about 30 minutes to cools down.

Nov 07, 2009 | Hoover Company Wind Tunnel U53019 Upright...

1 Answer

I have a Hoover Wind Tunnel Supreme mach 3.9. It


Check the filter above the dirt tank. If you take out the dirt cup and look where in slides into the machine, there is a filter that is probably dirty. It can be cleaned or replaced

Oct 08, 2009 | Hoover Vacuums

1 Answer

Hoover Wind Tunnel does not turn on


that is a pretty good lifespan for a hoover, but its probably the power switch that's bad. Hoover uses a very poor quality switch. It shouldn't cost to much to have it replaced

Jul 05, 2009 | Kenmore 33721 Upright Vacuum

1 Answer

Changing belts on Hoover wind tunnel U6401


Take off the bottom plate covering the brush roll, 4 screws. There are 2 belts, if you replace both, put the V belt on 1st, then stretch the flat belt over the motor shaft, then over the bigger pulley along side the V belt.

b9b512d.jpg

May 20, 2008 | Vacuums

1 Answer

Poor suction-need to know how to remove & clean filter under canister of Hoover Wind Tunnel Mach 4.7 Twin Chamber System.


I assume this is a Hoover Bagless, if poor suction, the hose or dirt inlet by the brush roll may have a clog. The filter inside the dirt container may need replacement. Some had a screw to take out to remove the cover for the filter, the one under where hte dirt container sits. Alos the belt may be stretch and won't turn the brush roll under load. Having the model number would help.

Apr 19, 2008 | Vacuums

2 Answers

Hoover wind tunnel


A clog or partial clog is what causes the motor to overheat, then a thermo protector will cut off and the motor will stop until it cools down. So either you do have a clog, in the hose or down by the brush roll. If they are clear, and the filters are clean, then maybe the thermo protector is bad and needs to be replaced.

Mar 08, 2008 | Hoover 5416-900 WindTunnel Bagged Upright...

2 Answers

Hoover doesn't suck well


Did you check the inlet from the bottom? Take the bottom plate off, make sure that the tube(inlet)is free of any clogs. Also if the belt is stretched, then it won't drive the brush roll like it should, replace it part #38528033.

Feb 04, 2008 | Hoover U5444-900 5100 Wind Tunnel 15 Inch...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

307 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18299 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...