Question about Technics Audio & Video Receivers

Open Question

Technics SE-A2000 Amp VU meter bulbs blown/not working. What bulbs are needed? Where can i buy them from? and how easy is it to take appart and replace?

Posted by on

1 Suggested Answer

  • 1 Answer

SOURCE: Technics SH-AC300 Connection to Power Amp & Pre-Amp

Hi!
The problem is, that your SH-AC300 needs an amp with 5.1 input (but no decoder). For this purpose technics delivered SA-AX710.
So if you'd like to use your current equipment it would be impossible.
The only option is for you to buy 2 more Power Amps (SE-A900S), so that each of 3 amps would take care for one part of music. (one for FL, FR; one for RL, RR; and one for sub and center).
Another option is for you to buy SA-AX710. Then all the problems would be solved with it.

Posted on Feb 24, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a Technics SA - DX750 Amp Everytime I turn it on I get an error message F70 and then it requests that I turn the power off. This is all it does now, so sound. How do I solve this issue I have...


Hi!

The F70 error certainly indicates a blown fuse inside.
The real problem is why the fuse is blown: there are only two possible reasons
1. there is a short circuit on the output (lines or speakers)
2. you have a blown output transistor (and that means some work and skills to replace).


To be sure, please change the fuse with a same rated fuse (buy more than one because it can blow again). Disconnect the speakers and turn the amp on. If the fuse blows again, it is sure something wrong with the output transistors. If the fuse remains ok, then please check all the wiring to the speakers.

Hope it helped.

Regards,

Bogdan

Aug 21, 2011 | Technics SA-DX950 Receiver

1 Answer

My technics sa-ex 300 wont power up it keeps saying over load can i fix it?


Unplug the speakers and try it again. If it still does it then one amp channel is probably blown

If it stops then the speaker is faulty or wire may be shorting

Sep 03, 2010 | Technics Audio & Video Receivers

1 Answer

Have se-ch515dp-k reciever want to know how to set time on clock


my 812 amp is not working stand by is blinking please help me

Nov 19, 2009 | Technics SA-AX720 Receiver

3 Answers

I have a technics sa-ax7 receiver and have sudenly lost sound on the right hand speakers.can they still be repaired. What could be the problem. Thanks


1). Look for a blown fuse on back - or inside. I had this similar problem with a Technics SA 5060 (vintage) receiver, and there were 2 separate fuses for left and right channels. One may be blown.
2). Try switching speakers (physically switch the left and right input plugs in their jacks - or wires if no jacks. If the left speaker doesn't work now, there is an issue with the speaker that has no sound. Run an ohm meter on these speakers as well to check them. There should be 8 ohms approximately. If no reading, then your apeaker is probably blown. If you can see a short on ohm meter 0 ohms) then you have a short circuit in your speaker.
Fred

Sep 21, 2009 | Technics SA-AX7

1 Answer

Technics SA GX910 ... powers up fine, meters and displays fine ... no sound (already checked jumpers, tape moniter, mute) light on volume control not on and headphones don't work


there is a problem in the low voltage power supply internally,or the speaker protection has kicked in.
unplug all speaker wires,and if the amp comes on,there is a shorted speaker wire somewhere.

Aug 15, 2009 | Technics Audio & Video Receivers

1 Answer

Technics SA-AX540 Receiver


It is unlikely that the display itself is faulty although it can happen. The typical problem is either the backlight is defective or the suply to the unit has a bad connection. If you can solder, try resoldering the pins on the display itself. The pins on the ends are the power and ground. I don't recall whether or not your model has a separate back light bulb or not. That too could be burned. Chack for that too.

Keep us posted,
Dan

Mar 02, 2009 | Technics SA-AX540 Receiver

1 Answer

I have a technics amp that has hf lf speaker output I'm trying to connect them to speakers with only 2 wire red black


pa ti si car ... izgubio si se sa dve zice ... prijarelju uzmi nesto bezicno ili nikada neces slusati muziku. Gde ima tri zice ... mozes da umres ... cuvaj se. Pozz

Sep 09, 2008 | Technics Audio & Video Receivers

1 Answer

HELLO I HAVE 670ZX WITH OLD STYLE VU METERS. EVERYTHING WORKS GREAT EXCEPT THE VU METERS ARE SLOWING TO A STOP ALMOST. THERE IS OUTPUT ON BOTH CHANNELS AND IT SOUNDS GREAT BUT...........METERS ARE FAILING.


hi, a vu meters is a coil with a magnetic field, if it is slowing to stop, probably the coil is to old and you have to calibrate it (specialist) the best for you: replace the vu meter.

Apr 22, 2008 | Audio & Video Receivers

1 Answer

Technics SH-AC300 Connection to Power Amp & Pre-Amp


Hi!
The problem is, that your SH-AC300 needs an amp with 5.1 input (but no decoder). For this purpose technics delivered SA-AX710.
So if you'd like to use your current equipment it would be impossible.
The only option is for you to buy 2 more Power Amps (SE-A900S), so that each of 3 amps would take care for one part of music. (one for FL, FR; one for RL, RR; and one for sub and center).
Another option is for you to buy SA-AX710. Then all the problems would be solved with it.

Jan 15, 2008 | Technics SA-DX950 Receiver

Not finding what you are looking for?
Audio & Video Receivers Logo

Related Topics:

901 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio & Video Receivers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

yadayada
yadayada

Level 3 Expert

60667 Answers

 Grubhead
Grubhead

Level 3 Expert

4576 Answers

Are you a Technics Audio and Video Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...