Question about RCA D52W20 52" Rear Projection HDTV-Ready Television

1 Answer

HD52W140 No picture or sound

We moved the tv from 1 house to another. It was working fine prior to us moving it. The green light is the only thing that comes on whenit's plugged in to the wall. The remote won't work nor the on off button on the TV. We were careful while moving and drove extremely slow. Do you have any ideas on what we might need to do, because we left it unplugged all night but still the same thing happens

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • RCA Master
  • 8,617 Answers

Possibly a solder connection, that model is famous for bad solder joints moving it could have caused it develope a bad solder joint. I would check the fuse then inspect the solder joints .

Posted on Jun 18, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Yesterday my 46" dlp samsung


you can not solve this by your self you must have technication to open the set,,,thir must be some thing wrong,may be deg plug had moved from its place

Dec 23, 2010 | Samsung DLP HL-P5663W 56" TV

1 Answer

My Loewe Spheros plasma worked fine prior to a move to a new house. Upon powering it up about 2 mos. later.....the green light will come on and the usual "click" is heard, but no sound or image...


Can you confirm that you get no sound and picture? Apparently, these units, along with Panasonic & Hitachi units which are similar in design and use the ALiS panel from Hitachi/Fujitsu have a weakness in power supply. If yours has this problem, you should at least get sound.
My Spheros started acting up (no picture) after a move as well. If yours has the same problem as mine, you could opt to replace the power supply by a Loewe rep and pay $1500. I just use a hair dryer to get the picture going. Let me know if you need the details.
Good luck.

Nov 29, 2010 | Loewe Spheros 42HD 42 in. HD-Ready Plasma...

1 Answer

I have sound but no video..(there is no RROD)


I had a friend with the same problem. No video, just audio, used different cables and such like you did. Ended up being the GPU just as you mentioned. Called in they said it wasn't under warranty.

My friend tried the Xclamp, but it didn't work. He ended up calling MS and found that if you told them you were troubleshooting a Red ring error on the phone with them, and then the video error happened they would grandfather in the replacement because it was a red ring error initially. Might try that.

Jul 29, 2009 | Microsoft Xbox 360 Console

1 Answer

No picture, no sound, power light stays on


this is a tricky one but i would say it could be a pannel inside that has gone with all the moving of the tv about you could hav just moved something inside that shouldent hv moved ( its easley done ) best thing to do is take it to a phillips dealer.

Mar 10, 2009 | Philips 60P8341 60" Rear Projection...

1 Answer

Tv with power but no picture or sound...


you have no deflection and don't leave the dot on to long it will burn the crt's.

Aug 11, 2007 | Mitsubishi VS-5043/44 50" Rear Projection...

1 Answer

Dopped tv, worked fine, now not picture but has sound


Most drop damage is in/around the area of the flyback xformer.My Motto==PVAT! With magnifier examine PCB for crack(s).May still be fixable.

Jul 31, 2007 | Sony KV-36FS100 36" TV

1 Answer

Mitsubishi CS-35505


Had the same issue. Try hitting the input button on the remote. Then chose aux. 1 option. Worked for ours.

Dec 28, 2006 | Mitsubishi CS-35505 35" TV

Not finding what you are looking for?
RCA D52W20 52" Rear Projection HDTV-Ready Television Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top RCA Televison & Video Experts

The Knight
The Knight

Level 3 Expert

72256 Answers

matt martin
matt martin

Level 3 Expert

1207 Answers

Jaime Hernandez

Level 3 Expert

2296 Answers

Are you a RCA Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...