Question about Electrolux Central Vacuum

1 Answer

Was turning on then off then back on now can not get to start at all even if i jump the low voltage line

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 694 Answers

Ensure filter is clean. Check switch near filter.
Try reset switch.
It could very likely be the circuit board/power module in the machine near the motor. It could also be a worn out motor. It's best to take to the nearest Aerus Electrolux store and let a service tech check it out.

For the store nearest you, follow instructions on below site.
http://www.aerushome.com/storelocator/

Posted on Nov 13, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Unit will not turn off. Have to unplug it.


You probably have a stuck relay or wires are touching. Pull the low voltage wires off the vacuum, if it keeps running it's the relay. You can try tapping with medium force next to where the low voltage wires are attached to the unit using the handle end of a hammer. Even if this works it's time to replace the circuit board. Check with a local vacuum cleaner repair center. You can disconnect the pipe and low voltage wires and it should just lift straight up. Take it to the repair center so you can save service call fee, because after all it's just a large canister vacuum.

Jul 01, 2010 | M&S Systems ZX-6000 Bagged Central System...

1 Answer

Our Easy-Flo built in vacuum system will not turn off, even when the hose is disconnected. We have to turn it off manually. Could it be a short in one of the wall outlets causing this?


Some models have an on/off switch on the power unit itself. This switch is used to turn your power unit on when you are right at the machine.
If there is no switch on the power unit, unplug your power unit from the wall socket, look for two low voltage wires coming out of the power unit. These two low voltage wires are usually either attached with terminals or are tied to two wires coming out with plastic screw on wire caps. Disconnect the 2 low voltage wires. Plug your power unit back in. If the power unit does not come back on then yes, the problem is most likely a short in the outlet wiring. If the power unit still comes on with the 2 low voltage wires unattached, then the problem is in the internal circuitry of the power unit, usually a relay or some units have a circuit board with relay, circuit breaker and other components on it. The relay or circuit board will have to be replaced.
It's a little difficult to check for a short if you have multiple outlets, but if you've recently done some renovations you might start checking in that area.

May 19, 2010 | Easy Flo EF1400 Central System Vacuum

1 Answer

Nutone Scovill 350 will only turn off if unplugged


Some units have an on/off switch on the power unit itself. Check to make sure that is not turned on. Unplug your power unit and remove the 2 low voltage wires (not the power cord itself) . The low voltage wires start at the unit and run throught your home and attach to each hose inlet. They are usually attached to the unit by simple wire terminals or wire capped to small wires coming out. Just unlug the terminals or unscrew the wire caps and pull the connections apart. Plug your machine back in. If it still comes on the problem is the relay or circuit board/switch/ relay assembly inside the unit. If it doesn't come on with the low voltage wires unattached then you may have two wires touching somewhere in the low voltage wiring.

May 14, 2010 | Broan-NuTone CV353 Central Vacuum

1 Answer

Will not turn off when hose is pulled out of wall


Some units have an on/off switch on the power unit itself. Check to make sure that is not turned on. Unplug your power unit and remove the 2 low voltage wires (not the power cord itself) . The low voltage wires start at the unit and run throught your home and attach to each hose inlet. They are usually attached to the unit by simple wire terminals or wire capped to small wires coming out. Just unlug the terminals or unscrew the wire caps and pull the connections apart. Plug your machine back in. If it still comes on the problem is the relay or circuit board/switch/ relay assembly inside the unit. If it doesn't come on with the low voltage wires unattached then you may have two wires touching somewhere in the low voltage wiring.

Jan 26, 2010 | Broan-NuTone CV450 Central Bagged Central...

1 Answer

The wall outlets do not turn on. The motor runs at the unit. I have reset and it blows/sucks at the unit. The canister is empty. Thanks, Je


You main low voltage line from the vac to the house is likely disconnected. Start by looking at the connection where the small wires enter the vac. Touch across those two wire terminals with a screwdriver or needle nose pliers and the vac should start.If it does, inside the home those same wires run along your pie to each inlet. Somewhere along the pipe path the wires have been disconnected or broken.. Think back to any area where work has been performed or face plates removed for painting, etc. Remove each inlet one at a time and look for a loose connection on the screw terminal at the back of the inlets. When reinstalling be certain each wire is tidy and connected to only one screw terminal at the back of the inlet. Once all inlets are connected in line you will have a complete circuit back to the vac. Post back with results

Oct 28, 2009 | Broan-NuTone CV450 Central Bagged Central...

1 Answer

Central vac won't turn off unless we unplug


Some units have an on/off switch on the power unit itself. Check to make sure that is not turned on. Unplug your power unit and remove the 2 low voltage wires (not the power cord itself) . The low voltage wires start at the unit and run throught your home and attach to each hose inlet. They are usually attached to the unit by simple wire terminals or wire capped to small wires coming out. Just unlug the terminals or unscrew the wire caps and pull the connections apart. Plug your machine back in. If it still comes on the problem is the relay or circuit board/switch/ relay assembly inside the unit. If it doesn't come on with the low voltage wires unattached then you may have two wires touching somewhere in the low voltage wiring.

Jul 18, 2009 | Broan-NuTone CV350 Central Vacuum

2 Answers

NuTone Central vac won't turn off


If the central vacuum tank will not turn OFF even with the switch in the “OFF” position, then the low-voltage wires should be disconnected from the tank. If the tank continues to run and still will not turn off, then most likely the relay inside is defective (but it could be a defective and/or shorted ON/OFF switch). If with the low-voltage wires disconnected the tank is able to then be turned off with the switch, then there is a short in the low-voltage wires or a hose is plugged into an inlet somewhere. ~ TTURAMBAR

Mar 11, 2009 | Broan-NuTone VX475 Bagged Central System...

1 Answer

I have a central vacuum system. When I disconnect the hose from a wall outlet the central canister does not shut down dispite my turning off the vacuum at the handle of the hose. The only way I can get...


What I'm hearing is the canister(Not the Powerhead) portion of the unit is running all the time unless you unplug it. this problem could be caused by a short in one of your low voltage lines running through the house. To determine that just unplug one/both low voltage lines from the canister, and plug it back into the recepticle. If it doesn't start up then you figured out that it is in the house somewhere and not the unit. If it is in the house I would check for water in the valves, or you're just gonna have to chase down the short. If the unit is still running with the low voltage wires disconnected then it is probably the relay on the board, which means you will need a new board unless you're expereinced at soldering and want give it a try replacing just the relay. Which you'll probably need a new board by the time you're done anyhow. LOL

Good Luck

Nov 21, 2008 | Vacuums

1 Answer

Nu-tone 475 keeps running even without hose plugged in.


If the central vacuum tank will not turn OFF even with the switch in the “OFF” position, then the low-voltage wires should be disconnected from the tank. Once this is done, if the tank continues to run and cannot be turned off with the switch, then most likely the relay inside is defective and needs to be replaced (but it could be a defective and/or shorted ON/OFF switch). If with the low-voltage wires disconnected at the vacuum tank, it can be turned off with the internal switch, then either there is a short in the low-voltage wires, or else there is a hose still plugged into an inlet somewhere. ~ TTURAMBAR

Nov 11, 2008 | Broan-NuTone VX475 Bagged Central System...

1 Answer

Low voltage wiring


Probably just didn't wire the l/v side of the relay properly. Or forgot to plug the leads from the outlets back in to the vac after you got it all hooked back up. Folks do it to me all the time and then make like it's my fault! Ha ha.

Jump the l/v contacts inside the CV. If it goes: trace outward toward the outlets to see if something shook loose while it was apart. If you can't jump the l/v with a plier/screwdriver at the CV or even inside it, you have an issue on the board (either how you've connected to it or it's defective itself). The prob is that there's dozens of diff board configs, plus the relays and transformers weren't together on the same board in the old days. If you've got one of these models with a massive transformer separate from the relays get out the test leads and make sure you've got adequate voltage coming out of her to power the relay coil.

Aug 26, 2007 | Broan-NuTone CV750 Central Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

26 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18387 Answers

yadayada
yadayada

Level 3 Expert

74896 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...