Question about Fender Hot Rod Deluxe Guitar Combo Amplifier

1 Answer

My 410 deville's channel switching doent work and is stuck on the clean channel. This really isn't a problem as I always use the clean channel and I only mention this in the event it helps diagnose the issue with the clean channel getting an apparent power cut periodically. when powering on it is loud and but after warming up a few minutes of playing the volume go down and periodically will go back up again but for very brief moments. I play out and this issue is totally. Annoying!! Checked the fuse and its not fried, all tubes light up and are seated firmly. Suggestions, solutions, fixes?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

You may have a switch that may be bad. For the sound level high and low may need new tubes or possibly may not be seated fully into position. These tubes due get quite hot and do get loose over a period of time.Hope this helps.

Posted on Jan 21, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Peavey bandit 112


have you tried using a foot pedal? Are you sure it is switching (green light turns red, etc?). On the lead channel are you turning up the gain all the way and the volume down?

Oct 12, 2013 | Music

1 Answer

My 412Hot Rod Deville has terrible humming/white noise when distortion channel is on


It doesn't happen often but I suspect that the high gain input jack is defective. With nothing plugged into either input jack part of the signal is grounded and there should not be any noise. It might be that plus a noisy preamp tube. Try swapping the first two tubes to see if there is less noise. Carefully bang your fist or use an insulated tool's handle to hear if the noise changes. It might be an intermittent solder connection as well.

Jul 15, 2017 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Hi, I have a Deville 410 and my drive chanel is loosing volume but my clean chanel isn't. Are my preamp tubes going bad? Thanks, Aaron


The tube at V2 position, the "B" section provides additional gain for the drive channel over the clean.
It would be uncommon for this tube to go bad in this way so try this: Swap V1 with V2 and see if anything changes... if it does, replace the tube that was in V2... else there is something else wrong. Possible problems might be with the control pot for the drive gain or other components. The switching is done with relays and it might be that one or more contacts are not working in the relays. The job of troubleshooting gets deeper beyond this and if you are not adept at electronics best to take it in to a shop. There are lethal voltages in this so one has to be familiar with working on high voltage tube stuff...

Sep 11, 2011 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

FENDER HOT ROD DEVILLE 410 POPPING SOUND


I have answered some of this before, however I have reveiwed the schematic and as an electrical engineer I want you to do a couple tests.

First, plug in a set of headphones into the preamp out jack. Note that due to the impedance mismatch what you hear will not be very loud. Now change the state of the clean OD. Did you hear a faint pop?

Next plug a LOW impedance device OR even an instrument cable into the power amp "input" jack. Do this with the power off then warm amp up.
Now, change the state of the clean OD. Did you hear a faint pop?

Now for the analysis. If you did hear one in the first test and NOT in the second, the pop you are hearing is the "NATURE OF THE BEAST".

I can tell you from the design that the pop you hear is from coupling within the clean and OD relays within the unit. There is no cure for this within the unit other than find another brand...

I would recommend that you use an EXTERNAL pedal for the effects you want rather than trying to use the clean OD in this amp. I suspect it was never intended to be shifted during playing as I can guarantee it will pop when you shift while having anything other than dead silence (not even a bit of hum from your guitar). There is also statistical noise in the preamp that the laws of physics will not let us get around that may be enough to create a bit of a pop.

You could also use a volume pedal between the preamp output and the power amp in to throttle the volume to zero before shifting to OD.

In general I think you will find that what you are hearing is the nature of this beast.

Mar 18, 2010 | Peavey Music

1 Answer

Deville 212 overdrive channel making Loud humming noise


It sounds like a filter capacitor(s) has failed. The electrolytic caps dry out and cease to perform allowing unfiltered power to reach the preamp sections and get amplified.

Being this is tube with high voltages, an experienced person should work on it due to shock danger.

I assume you checked the tubes for shorts as well as emission since a heater to cathode short could cause this as well.

Sep 30, 2009 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

Fender Hor Rod deville footswitch


If the footswitch is not switching correctly, open it up and check for any shorts or a defective switch. Sounds like it's a problem with the switch.

Aug 14, 2009 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

Guitar amp channel switch repair


Replace the switch. You gave no make/model number for your amp but if it has a jack for foot pedal operation of clean/dist function then try that. (on most amps) it will switch in spite of a bad front panel switch.

Dec 21, 2008 | Music

Not finding what you are looking for?
Fender Hot Rod Deluxe Guitar Combo Amplifier  Logo

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fender Music Experts

dave nyman

Level 1 Expert

17 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Fender Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...