Question about Sony STR-DE475 Receiver

Open Question

How can I fix the time delay on my sony str-de475 receiver?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: Sony STR DG 510 receiver manual

Hey there, found it on the sony site...

 

http://esupport.sony.com/CA/perl/model-documents.pl?mdl=STRDG510

 

Hope that helps.

Posted on Oct 19, 2007

  • 3 Answers

SOURCE: code for sony receiver model str d565 protect mode

If you need support you can log into:
http://esupport.sony.com/US/perl/support-contacts.pl?mdl=STRDG510

for free tech support on sony chat line

Posted on Jun 02, 2008

  • 1 Answer

SOURCE: left channel is out sony STR-D511

Had the same problem but found simple solution. I just reconnected the speakers which were on "A" connections to the "B" set of connectors immediately below - problem solved!

Hope this works for you.

Stuart

Posted on Jan 22, 2009

  • 2 Answers

SOURCE: No sound from rear speakers during test tone usng Sony STR-DE475

I had this problem last night.

To solve it, you can reset the amp by:

1) Put the receiver on stand-by
2) Hold down "MODE" button and press on button
3) "S.F. CLR" appears in the display and surround is back on.


Good luck

Dr Gardner

Posted on Feb 10, 2009

dunnbiker
  • 8546 Answers

SOURCE: STR-DE475 receiver flashes "PROTECT" when turned on

Protection is usually a sign of overheating or something is wrong at the power amplifier's output.

Theory: Protection is a delay and sometimes an internal test to allow the electronics to stabilize during power up before they are allowed to interact with the speakers. The most common cause of it remaining ON is that a speaker cable pair is shorted. Some isolation is required...

1. Turn the Power OFF.
2. Disconnect each set of the speaker wires that are directly attached to the receiver. Mark them so you remember where each one went. pay special attention to which conductor is on "+" or "POS" and which is on "-", "COM" or "Ground". You may elect to disconnect them one pair at a time if your sytem is complex and you don't want to lose track of where things were.

Turn the Power ON. Is the "Protect" indication gone from the display?
--------------------
If YES, you have a shorted speaker wire or speaker. To isolate the specific cause:

1. Turn the Power OFF.
2. Attach ONE speaker wire pair at a time and test it by turning the Receiver ON. When the "Protect" light returns you have isolated at least one of the cause(s). Disconnect the defective speaker cable and continue isolation of all speaker cables. Visually examine the cable at both ends for frayed wires that could touch each other or contact metal on the receiver or other objects.

To isolate further within the cable/speaker pair - disconnect the speaker end of the cable on the failing path. Try another cable that you know works, or at least one that doesn't cause Protection to stay on.

If you're electrically savvy and have a Digital Volt/Ohm Meter you can troubleshoot the short(s) with it.
-------------------------

If NO, there is probably an internal problem.

Is it solid or does it come on after the Receiver has been ON awhile.
It could be overheating.
Is the unit hot to the touch?
Is there a cooling device (fan)?
Is it stopped or clogged with dust?
Is there adequate ventilation around the unit for air to flow?
Clean any ventilation slots on the top and bottom of the unit.
Avoid stacking components that produce heat under an amplifier or receiver. Their heat rises. Also keep them away from other heat sources like like home heating vents and radiators.

Problem solid and NOT related to the speakers or heat: internal malfunction.

Let me know.

Posted on Apr 02, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Helo ! I need to know why the subwoofer is silent when I connect it to my receiver-STR DE 475 . Plus , the sorround does not work . When I push the bottons , I either get the centre with the front...


Have you looked at the manual? There are procedures for adding a sub (which is NOT necessarily assumed to be there) and assigning bass to it.

http://www.retrevo.com/support/Sony-STR-DE475-Receivers-manual/id/387bh949/t/2/

Then there's the unidentified sub's manual and requirements to consider.

Sep 01, 2011 | Sony STR-DE475 Receiver

2 Answers

Right front channel not working


try to check balance adjustment if working.

Apr 16, 2010 | Sony STR-DE475 Receiver

1 Answer

No sound from rear speakers during test tone usng Sony STR-DE475


That didnt help rsgardener! Maybe some other tips please?

Jul 14, 2009 | Sony STR-DE475 Receiver

1 Answer

I have a sony STR-DE475 and the surround speakers have stopped working.


have you checked ur cables and connectors? check them with the multimeter and confirm

Jul 08, 2009 | Sony STR-DE475 Receiver

1 Answer

Working the Sony STR-DE475 5.1 Channels Receiver


It has a dedicated sub out. you need a phono connection on one end for the amp and the other end must have a compatable connection to your sub.

You will need a phono connection to the amp from your TV. You can utilise a scart lead that has phono outputs however a TV with audio outs (the red and white leads) is the default option.

Mar 31, 2009 | Sony STR-DE475 Receiver

1 Answer

No sound from rear speakers during test tone usng Sony STR-DE475


I had this problem last night.

To solve it, you can reset the amp by:

1) Put the receiver on stand-by
2) Hold down "MODE" button and press on button
3) "S.F. CLR" appears in the display and surround is back on.


Good luck

Dr Gardner

Jan 21, 2009 | Sony STR-DE475 Receiver

Not finding what you are looking for?
Sony STR-DE475 Receiver Logo

Related Topics:

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5011 Answers

The Knight
The Knight

Level 3 Expert

73619 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...