Question about Panasonic AG-1980 S-VHS VCR

1 Answer

Input fuse blows on power turn-on - Panasonic AG-1980 S-VHS VCR

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 221 Answers

Most likely problem is a shorted filter capacitor in the power supply.

Posted on Nov 15, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When i connect my inverter to dc power supply all fuses blow


DC input is polarity sensitive. This means that the positive input to the inverter must connect to the positive (+) side of the battery. Likewise the negative lead must connect to the (-) side of the battery.
An inverter does not work backwards. Attempting to put AC into an inverter will blow fuses at least.

Nov 23, 2012 | Stanley PC809 Inverter

1 Answer

No power or light, plus power supply keeps blowing fuse


you have a short most likely on the power supply but could be on the mainboard, inverter board, av/input board. The T-con board is fused and should blow its fuse before blowing the fuse on the power supply. I'm going with a faulty power supply, most likely a shorted Mosfet.

Sep 24, 2011 | Philips Magnavox 42MF521D/37 Television

2 Answers

Power input problem. Keeps blowing fuses, checked cord and it is good, have continuity across positive and return pins of the receptacle...pulled the covers and did not see anything that was obviously...


There should a small diode located near the power input line, "black in color with band on the one end" chances are it is shorted, blowing the fuse. This is a protection diode preventing a positive/negative mix up, if this turns out to be the problem check to make sure the audio is working, if not! you must replace the ic chip.

May 20, 2011 | Cobra 148 GTL 120-Channels Base CB Radio

1 Answer

When I turn microwave on it blows 60 amp fuse


60 amps times12 volts = 720 watts times 80% effic of conv. = 576 watts available for microwave...

You must have a very tiny microwave as most require at least 1000 watts input power. That might have something to do with blowing the fuse. Since the microwave has a very reactive inout, you need a goodly safety margin above the rated watts input.

Jan 10, 2010 | Cobra Electronics - Others

1 Answer

Blows 15 amp car fuse as soon as switch is turned on nothing plugged into inverter


If the fuse doesn't blow until you turn the inverter on, the problem is in the input circuit. First, be sure the polarity is correct when you're connecting the inverter. If you manage to get the 12 volts hooked up backwards this will blow the fuse. If the input polarity is correct, the diode inside that protects against reverse polarity may be shorted. Beyond that, it's difficult to make any suggestions about what parts to check. You would need to use an ohmmeter to check the parts in the input for very low readings from the 12 volt input to ground. If you can do this yourself or know someone who can, it might be worth a try. But if you try to take this somewhere for service - if you can find a shop willing to look at it - it may be more economical just to replace it.

Good luck with the inverter, and thanks for using Fixya!

Nov 24, 2009 | Powerline 0900-73 Slimline Inverter

1 Answer

I have an spl gorilla series 1250watt amp that blows fuses


REMOVE THE RCA INPUTS AND DISCONNECT THE SPEAKERS, THEN POWER THE AMPLIFIER UP WITH THIS NO INPUT, NO SPEAKER LOAD CONDITION. IF IT STILL BLOWS THE FUSE, THEN IT WILL NEED TO BE SERVICED. IF IT BLOWS THE FUSE BEFORE TURNING IT ON, THEN YOUR PROBLEM IS IN THE POWER SUPPLY SECTION. IF IT BLOWS THE FUSE AFTER ATTEMPTING TO TURN IT ON, THEN YOUR PROBLEM IS PROBABLY IN THE OUTPUT SECTION. ALSO KEEP IN MIND THAT THE P1'S ARE REALLY NOT RATED FOR THAT MUCH POWER AND YOU MAY HAVE DAMAGED THE VOICECOILS. BEFORE REINSTALLING THE AMPLIFIER, MAKE SURE TO CHECK THE SPEAKERS FOR SHORTED VOICECOILS OR YOU WILL POSSIBLY DAMAGE THE AMPLIFIER AGAIN. LET ME KNOW IF YOU NEED FURTHER ASSISTANCE.....V

Nov 19, 2009 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

Blowing fuses on the Vosonik VB101PK


ok, always use ground and positive from speakers to the amps +/- . Make sure the amp is not grounded. Some amps are made of metal and will ground itself. When ever any fuses pop, this means that something somewhere got grounded. If using metal srews to mount amp that has a metal casing, chances are you will pop a fuse or two. Be careful ajusting the speaker wires with a metal srewdriver, I've done that alot. "POP"

Jun 21, 2009 | Visonik V117SX Car Audio Amplifier

1 Answer

Subwoofer blows the internal fuse when receiver is turned on


possible solution - this can be caused by a fault in the receiver unit. the sub has a triac 'high side switch' circuit that can cause the fuse to blow if it doesn't get a good switching signal e.g. if the receiver power supply is not running at the full voltage. check the plug pack wire for damage, check the 12v input area on the receiver board for dry joints, particularly the power input socket. hope this helps.-pj

Dec 11, 2008 | Bose Acoustimass 16 Speaker

1 Answer

Gemsound power speaker pxa105


First,
Disconnect any input cables from the amp. Turn down the volume controls and disconnect the speakers. Power back on. If you still blow fuses with nothing hooked up, have the amp fixed.
If the fuse holds, shut down and connect the speakers, leaving the volume controls down. Power up and see if your fuse holds. If you have hum, an output transistor is most likely shorted. If you have no noise, SLOWLY turn up the volume controls and listen for the hum. If all is quiet, turn down the volume controls and connect your input cables and turn the volume back up. Noise? check your cables!
Mister Phil

Apr 07, 2008 | NAD C350 2-Channel Amplifier

Not finding what you are looking for?

Open Questions:

0 Answers

I'm hoping to get some clarification as to whether the below is correct or whether I have been taken for a ride. My LG was picked up by a repair service because it started displaying horizonal lines with the picture hazily in the background. I undertook some research and learned that in most cases of the boards needed replacing and it wasn't a panel issue (usually panel issues are associated with vertical lines). After having my TV for 5 days the repair service advised that it required a new power board and a small repair required on another board. They repaired the small repair and I was going to purchase a new power board however the TV has been returned to me dead. It now doesn't even turn on. The power/channel/indicator lights at the bottom flash on then switch off automatically. After getting consumer affairs involved, I finally received a call from the sub contractor and aside from a number of different excuses given based on my questioning of each explanation, all were contrary to the initial diagnosis discussed with me in early June. I documented the conversation which I summarise as follows: - he contacted numerous times however I never received any voicemail. I asked why - after "numerous phone calls" he didn't send a txt msg to which he replied that he's not allowed to send messages. - he initially alleged that the power board was repaired and video board needed replacing which I was quoted for. I corrected him advising that I was told and quoted for a new power board ($530) and the video board was to be repaired. He then changed his story agreeing with me and alleged that found and apparently quoted me $445 for a generic power board but I declined....Just to clarify, I never received this 2nd quote which is evidenced within the emails and messages I sent after receiving no response over a number of weeks. - he continued to claim that the TV now has panel problems and is now not repairable. - I recited the discussion the owner had with me which was consistent with the information when he provided me with the original quote of $530. He then altered his story replying that "this is a rare case... The owner doesn't know what he's saying". - When I challenged why I was quoted for a power board when he is now claiming there are panel issues, his response was that a new power board was to test if the panel was cracked!! - I replied saying that the TV was delivered to them with horizontal lines and even after testing should've been returned with horizonal lines however is now dead. - his excuse changed again advising that during testing he short circuited the TV and replacing the power board would continue to short circuit the video board..When I again questioned WHY then was i quoted for a new power board (as per the owners conversation with me) he returned back to stating that it was a rare case! - I told him about the screws missing in the back panel to which he commented that "they" wouldn't have put them back in because "they" assumed I would just dispose of the TV. What I find interesting is that this was his understanding whilst I was led to believe the TV was repaired (pending a new power board). It now makes sense as to why the driver who delivered the TV literally dropped it off and ran advising that he didn't know anything. I never received a service report and asked for it again however am yet to see it. Based on this information, can anybody shed light on what they've done to the TV? Prior to them taking the TV the horizontal lines were consistent with had a faint picture in the background and didn't alter at all. They're claiming that they did nothing and the TV - claiming that the reason why the panel doesn't turn on is because it was kept on while they were testing.

Sep 25, 2017 | LG Televison & Video

See all Panasonic AG-1980 S-VHS VCR Questions

Panasonic AG-1980 S-VHS VCR Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Panasonic Televison & Video Experts

 Grubhead
Grubhead

Level 3 Expert

5056 Answers

The Knight
The Knight

Level 3 Expert

74136 Answers

Jaime Hernandez

Level 3 Expert

2318 Answers

Are you a Panasonic Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...