Question about Directed D800 Car Audio Amplifier

Open Question

My d800 directed amp is in my car & isn't working. i checked the 2 fuses on the side of the amp & they aren't blown from what i can see. the amp is also connected to my kicker box. when i turn the battery on in my car my amp & kicker box usually come on & the kicker box & amp work but it doesn't. & i looked on the other side of the amp & noticed that the power light doesn't even come on when i turn the battery on. can you assist me or give me an idea of what the problem is.?

Posted by on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1348 Answers

SOURCE: the fuse in the red wire that connects to the battery blows

there must be a short. hook the power amp up to a power supply or another battery,fused of course...if it works,it is ok.
then the problem is in the car
high power amplifiers should be run off a secondary battery.
a 480 watt amplifier will pull 40 amps of current. enough to run 8 headlights.the real problem is surge currents,which the spikes can damage the alternator/regulator.these can top 100 amps.
some high end installs use a second alternator and battery.

Posted on May 13, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Horn not working


Check appropriate fuse isn't broken and from fuse work back along wire checking connections and insulation until you reach the horn. If you've not found a fault download user manual (for free). Ask advice at a Honda dealers or e-mail Honda directly.
Auto-electricians aren't cheap.
I'm not certain but I think youv'e gotta have working horn to pass MOT.
Good luck. Hope this helped.

Dec 14, 2011 | 2000 Suzuki Vitara

1 Answer

Dash board lights not working


Locate the knob or dial that controls the brightness of the dashboard lights. If the control is not immediately evident, check your owner's manual.

  • 2 Make sure the brightness control is turned on. If it is and the lights aren't working, the problem may be a bad fuse.
  • 3 Check the fuse that controls the dashboard lights (see How to Fix a Faulty Car Fuse). Replace the fuse if necessary.
    Find the fuse box (see A). It is usually located under the dashboard to the left of the steering wheel, at about knee level. Many cars have additional fuse boxes in the engine compartment. Check your owner's manual or call the dealer for the exact location(s)


  • Open the fuse box cover and locate the blown fuse. There are two ways to find the bad fuse: Look for a fuse with a melted center strip (see B, which shows two types of broken fuses). Or, if you know which device isn't working--for example, the radio--look for the fuse that handles that device. The fuse panel may have labels for each device, or the information may be in your owner's manual.
  • 3 Remove the bad fuse with a fuse puller (a small pair of plastic tweezers that should come with the fuse box). Or use a pair of needle-nose pliers.
  • 4 Check the number on the bottom or side of the bad fuse. This indicates the amperage.
  • 5 Buy a new fuse with the same amperage and push it into the slot in the fuse box with your fingers.
  • Oct 09, 2011 | 1999 GMC Yukon

    1 Answer

    I was playing my kicker l7's and aall of the sudden they just stopped working. I checked all of the wiring and it seems to be fine. The amp turns on and works still but the subs dont work at all. Do...


    Check your RCA cables to make sure you are getting signal. The amp isn't in protection is it? Also, if you have a multimeter, you can check to see if you are getting any power out to the speakers. Also, check to make sure your subs aren't blown. Keep me posted.

    Aug 26, 2011 | Kicker Solo-Baric L7 12'' Car Speaker

    1 Answer

    Got a 4 channel amp but can only use 2 channels, dont know why//


    Did you check the fuses on the amp. If one of them has blown, this will shut it down. You will also need to check to make sure your RCA cables from the unit aren't crimped. This could kill the signal. Have you swaped the RCA cables to see if the other side works. If so and it still doesn't, check thos fuses. If this still doesn't help, you may have internal problems with your amp. Hope this helps

    Aug 19, 2011 | Car Audio & Video

    2 Answers

    Im looking for the fuse for the right tail light


    You do not have a separate fuse for each side, if the left side works, replace the bulb in the right side that isn't working.

    Jun 26, 2011 | 2002 Jaguar X-Type

    1 Answer

    So after getting my car back for the garage my subwoofer isn't working I checked to make sure all of the connections are correct and the settings are there why won't it work


    Check to see if your amp is on. You may have blown a fuse somewhere maybe on your amp. Check for proper voltages and make sure the sub isn't blown by pushing on it. If you feel unequal resistance, you probably blew it. Also check the ohms on the woofer.

    Jun 06, 2011 | Car Audio & Video

    1 Answer

    I Have an spl audio amp 520 watt and when it turns on it automatically goes to red which is protect. what could be causing this problem


    It could be 3 things. There could be a short somewhere, your ground isn't strong enough, or you accidently switched up the ground line and the power line on the amp. Since the fuses aren't blown I would say that your ground isn't strong enough.

    May 01, 2011 | SPL Car Audio & Video

    1 Answer

    Amp is off wont turn on..


    check all connections and fuses make sure u have great connection on ground also check for short in remote wire

    May 14, 2010 | Directed D800 Car Audio Amplifier

    1 Answer

    Amp is off wont turn on..


    Check fuses 1 should be on amp other is near battery on the new wire that goes to amp. If both are good check power at main and check remote with system on. If you have power and fuses good, your amp has an internal problem and needs to go to manufacturer for repair.

    Mar 24, 2010 | Directed D800 Car Audio Amplifier

    1 Answer

    I have a 91 mazda 626. directionals and4 ways dont work properly


    check all of your wires with wire tester. maybe they are being shorted out somewhere. Check your fuses to make sure none are blown/bad. Check the light bulbs to make sure they aren;t blown.

    Mar 11, 2010 | 1995 Mazda 626

    Not finding what you are looking for?
    Directed D800 Car Audio Amplifier Logo

    Related Topics:

    31 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Directed Car Audio & Video Experts

    yadayada
    yadayada

    Level 3 Expert

    75077 Answers

    Colin Stickland
    Colin Stickland

    Level 3 Expert

    22095 Answers

    Tygh Duval
    Tygh Duval

    Level 2 Expert

    300 Answers

    Are you a Directed Car Audio and Video Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...