Question about Hoover Elite Rewind Bagless Upright VacuumVacuum

1 Answer

What color is the air flow indicator supposed to be? Mine is yellow but I have no suction. I have read that some people have red, others yellow. I have cleared out all hoses and cleaned the filters with a shop vac, still cannot get it to pick up. Just keeps blowing the dirt out the back at me :(

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 147 Answers

Hi there,

the unit may be experiencing something other than a blockage. Perhaps the dirt canister is not put back into place properly and the unit is sucking through there instead of through the hose.Check to see if the lid and the canister are both on the unit correctly and see what happens. I do not think that the unit is blocked up on you.

Normal air flow indicator color by the way is the same as when the unit is in the off position. The indicator is generally like a pen spring and stretches when the hose or suction is blocked off.

Good luck.
Mark

Posted on Nov 11, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No Suction


i about to say that's always a clog of some sort that causes that

Jan 31, 2013 | Miele S7210 Bagged Upright Vacuum

1 Answer

Red light on then cuts out how do i unblock please? lost the manual.


Hi There,.

So when this light is displaying, it's says "Bag Full or Clog" on the indicator. If you have changed the bag, and it's still showing this light, it means that you either have a clog in the vacuum, or your filters are dirty, which is reducing the suction and making the machine think that your bag is full. If your machine is actually cutting off, this indicates that your machine is definitely clogged, or something is stuck inside which is causing the motor to not get air flow, and cauing the machine to over heat. When it shuts off like this, it's a protection system that prevents any damage from happening to the motor when it can't breathe and starts to overheat.

My guess is that there is probably a clog in the machine somewhere, or the filters are dirty. Here's what you may do to diagnosis the machine, and try to isolate the clog to find out where it is in the vacuum.

Step 1. Remove the hose and wand assembly from the vacuum cleaner completely. You may do this by pressing the two tabs on the end of the hose that plugs into the vacuum cleaner:


cca2760.jpg
With the hose and the wand removed from the vacuum, it should look like this:

b7c34c5.jpg
Step 2. Now turn the vacuum cleaner on and check to see if the red light comes on while the hose and the wand have been removed. If the light comes on, then this indicates that your filter is dirty (or the PCB electric board is bad if the filter is clean) and needs to be replaced.

Step 2. Re-attach the hose and wand back on the vacuum, but just the end of the hose that goes into the vacuum cleaner, leave the wand out of the vacuum cleaner so it looks like this:


db25806.jpg
Turn the machine on now as if you were using the attachment hose to clean corners or above the floor and see if the red light comes on here. Also listen to the noise the motor makes and see if the noise changes when you put the hose back on the vacuum cleaner. If the red light appears, or if the motor makes a higher pitched noise now, then this indicates that you have a clog in your hose or wand. You may verify this by remove the hose again from the vacuum, and also removing the wand from the hose by pressing the hose release button on the wand and pulling the hose out of the wand. Look down both of the parts and see if you can see thru both sides. If you're not able to see light through the hose, or the wand, this indicates this is where the clog is. You may take a metal clothes hanger, and try removing the clog this way.

Step 3. If the red light did not display with the wand not inserted into the vacuum, put the wand back into the vacuum cleaner as if you were vacuuming the floors:


1a089d0.jpg
Turn the machine on, and see if the red light comes on in this position. If the light does come on, then this indicates that you have a clog in the bottom of the vacuum cleaner. To check and see the clog in the bottom of the machine, I find it easiest to remove the upper bag housing from the vacuum cleaner completely so you're just looking at the bottom power nozzle of the vacuum cleaner. There's a button at the bottom of the machine that is either a grey, or yellow color depending on what color your vacuum is. Simply press this button in, and lift upwards on the handle or the bag housing at the same time:


2b91587.jpg
Step 4. After the bag housing has been removed, turn the lower part of the vacuum upside down so the brushes are facing upwards. There's a little orange flap on the bottom of the machine that is actually a clog port. Almost every time there is a clog in a Sebo, this is where I typically find the clog. Open up this orange colored trap door, and look to see if you can see any obstruction or clog underneath of here:


08da832.jpg
Step 5. You may rotate the neck of the power nozzle part towards you so that you may look inside to see if you see any obstructions inside:

c034305.jpg
Step 5. You may also remove the brushes from the vacuum and look behind the brushes at the suction port, or the area where the suction goes through the vacuum to see if you see anything obstructing the suction here.

These are really the only places that the Sebo can get clogged. If you checked all of these areas, and the red light is still displaying, this means that your PC Board that controls this indicator has gone bad, and needs to be replaced. If this is the case, please just reply to this repair using the comment field, and I'll be more then happy to help you through the replacement of replacing the PCB Board.

I hope this answer was helpful to you, and you were able to find the clog and fix the problem. If you found my repair helpful, please be sure to rate the repair

Aug 09, 2012 | Sebo X4 Bagged Upright Vacuum

1 Answer

My miracle Mate vacuum doesn't have suction.


you might have to take the hose off and blow through it, mine had the same problem and it was full of trash, it works fine now.

Jun 11, 2012 | Vacuums

3 Answers

My machine has suction at the port where the canister fits on the base, but immediately sounds clogged with no (or very little) suction going to wand or floor. All filters cleaned (accesible) and no clogs...


I will list the spots to check this vacuum for clogs. First see the first diagram I uploaded.

ironfist109_17.png

  1. First thing is to remove the canister.
  2. Then you will see in the diagram "A." Press that button and pull the hose up and check for blockages. Make sure to check for light through the hose to guarantee no blockages.
  3. Now tilt the vacuum forward and pull out the U Bend Airway and inspect it as well (3rd pic in diagram)
  4. Now squeeze the valve release catches to remove the airway and inspect the valve for blockages. (4th pic in diagram)

ironfist109_18.png

  1. The diagram above is the pre motor filter many forget to check.
  2. Press the filter release catch and pull the filter housing out.
  3. Remove the filter.
  4. Wash real good and let dry completely.

  • Now the one thing that tends to go bad on these vacuums is the automatic air flow adjuster. When the vacuum is upright the pathway for suction is automatically on the wand. After some good use the little disk in there snaps and the air flow stays restricted in what ever position the vacuum is in. I have contacted Dyson a few other time and they do not sell this part. It is a factory fix only or I would give you the instructions to do it yourself.

  • Hope this helps and thank you for using FixYa.

Regards, Tony

Jul 21, 2011 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

The performance indicator light is red and I have no suction.


If the motor runs, then the problem is usually plugged air passages near the bag/canister or the sweeper head/hose. Remove any hoses/bags/canisters so that you are dealing with only the vacuum producing parts. If it has a sweeper head, remove the bottom plate and clean any visible clogs in the air passages--the same with the area where the debris collects normally. Turn on the motor to see if you are getting air flow through the machine. If nothing, dig deeper into those air passages. Hope this helps!

Mar 17, 2010 | Vacuums

1 Answer

No suction on the bissell lift-off revolution


I had the same problem. In the water resevoir, there is a red flap that allows the dirty water to flow back into the water tank. Lift that flap up and there is a small red screen. Pop that screen out with a butter knife and rinse it out. I have dogs in my house and that screen was blocked by dog hair. I cleaned the screen, popped it back in and it works like a new machine. You would think Bissell would address this roblem on their web site but they don't.

Mar 09, 2009 | Bissell Lift-Off(R) Revolution(R) Turbo...

1 Answer

Kenmore vacuum model 37105 no suction


are the brushes moving?if so , it is clogged somewhere, that is my guess

Jan 26, 2009 | Kenmore Vacuums

1 Answer

Buzzing sound


You ether have an air restriction, or your bypass valve is broken. If it is an air restriction: The motor requires more air flow to stay cool, the noise you hear is an emergency air inlet made to prevent overheating. You may need to use the hepa bag to help increase the air flow. Some hose attachments will cause this to happen, your performance indicator light (if you have one) should also be illuminated if it is an air flow issue. Check your hose for a blockage.

Jan 24, 2009 | Kenmore 35912 / 35913 Progressive Upright...

4 Answers

Samsung Quiet Storm 9048R hose break


OK ART THE FITTING THAT CONNECTS TO THE HOSE SHOULD HAVE TWO SMALL SQUARE HOLES OPPOSITE EACH OTHER YOU NEED TO PUSH TWO FLAT HEAD SCREW DRIVERS IN AT SAME TIME TO RELEASE THE SECTION THAT THE HOSE SCREWS INTO POP THIS APART THEN REMOVE THE SMALL PIECE OF BROKEN HOSE AND SCEW HOSE BACK ON REPLACE INTO FITTING SO THE SQUARES POP BACK INTO PLACE AND START VACUUMING HOPE THIS HELPS GLENN PS ANY VACUUM SPECIALIST WOULD BE ABLE TO HELP WITH THIS SMALL PROBLEM IF YOU WANT TO MEET ONLINE ABOUT THIS I WOULD BE MORE THAN HAPPY TO ASSIST

Nov 14, 2008 | Samsung 5528R Vacuum

Not finding what you are looking for?
Hoover Elite Rewind Bagless Upright VacuumVacuum Logo

290 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1466 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...