Question about Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum

Open Question

I have lost the suction and cannot get it to **** up the water.

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does it leave a lot of water on the floor


Clean out the filters, It has lost some suction and suck up the water.

Mar 28, 2015 | Vacuums

1 Answer

It has lost suction


Have you got suction just before the motor? How about air coming out the exhaust?

Mar 14, 2015 | Vacuums

3 Answers

MY RAINBOW VACUUM HAS LOST SUCTION POWER AND i DON'T KNOW WHY


Your Rainbow E series has lost suction power, because you need a new hepa filter, ot your water basin gasket is messed up, or the center motor gasket is messed up or out of position.

Make sure your water basin is not cracked or broken, also.

If you have any more questions let me know. I am a Rainbow seller, and a Rainbow expert also.

Thank you,
Ralph

May 19, 2010 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

My Rainbow has no suction


Your Rainbow E series has lost suction power, because you need a new hepa filter, or your water basin gasket is messed up, or the center motor gasket is messed up or out of position.

Make sure your water basin is not cracked or broken, also.
If it is an earlier model, everything applies, except for the filter. They do not have filters, on any of the earlier models.

If you have any more questions let me know. I am a Rainbow seller, and a Rainbow expert also.

Thank you,
Ralph

Jan 27, 2010 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

Halo main suction motor will not come on


Used my Steam Vac twice and now there is no suction where the unit should be picking up the water layed down from the sprayer. I've readjusted the collection tank, took the lid off and made sure the side clips were snug and cliped against the tank, but still no suction. I don't hear any unusual noises, the handle lays down, water spits out, it just has lost suction. Any suggestions? With Appreciation, -kb

Sep 30, 2009 | Vacuums

1 Answer

Lost suction


there is a screen by the brush that may be clogged. Make sure the water tank is on tight

Feb 19, 2009 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

Won't extract water from carpet.


Seems the 1950W is now obsolete, cna't even bring up a drawing of it. Usually when the vac. motor is running, then there has to be suction. But if a seal or gaske is missing, then the suction will be lost. So you might check the dirty water tank to make sure there isn't a part missing or out of place. Check this out, it is for a 1950-3:
http://bissell.com/images/schematics/1950.pdf

Jan 29, 2008 | Bissell Powersteamer 1694 Upright Vacuum

Not finding what you are looking for?
Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum Logo

Related Topics:

269 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

Brad Brown

Level 3 Expert

15557 Answers

Jim Thurston

Level 3 Expert

670 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...