Question about Fender Hot Rod Deluxe Guitar Combo Amplifier

2 Answers

Fender Hot Rod Deluxe has very little sound, stuck and need help! Turn it on and all of tubes light up. Has a horrible muffled sound with volume at 5. Master volume can be put to any level, and it doesn't effect volume levels which is odd. I checked for any bad soldering connections and didn't find anything. I don't know what else to do. Any help would be appreciated, thanks! -John

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

  • Expert
  • 93 Answers

Could the speaker output connector be in the wrong 1/4 inch jack?

Posted on Mar 29, 2015

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Fender Master
  • 5,603 Answers

Just because tubes light up does NOT mean they are good or working... While heaters not lit are an indication of failure, teh reverse is not necessarily true.
Time to troubleshoot this... Plug a set of headphones into teh preamp out. See if audio there is clean... it will be low level using headphones and ONLY from one side as the output is mono and your headphones are stereo usually... If audio is clean here and not muffled, then problem is in power amp section else in the early stages of the unit.
Report back the results of this test...

Posted on Nov 09, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a Fender 2x12 Hot Rod Deville. The clean channel seems to be working fine but the overdrive channel is not. I have to turn it up all the way in oder to get just a little bit of sound. So that...


For the Drive channel you need to use the Drive control AND the MASTER volume control. When the Drive channel is active, the Channel Indicator lamp should be RED indicating the Drive Channel is active. The Drive control knob is used to adjust the preamp volume and distortion level of the Drive Channel. This gives you a clue as to what to check if adjusting the controls doesn't work -- the preamp tubes. Having said that, ONLY try to check these tubes with the amp OFF! Never stick your hand up into the chassis of a live amp. It could be lethal. Your preamp tubes are the ones farthest from where the power cord enters the chassis. They have a rubber like stabilizer on them. They have a tendency to wiggle loose, which is part of the reason for the stabilizer. Again, if you're not familiar with the insides...stay out and get an amp tech to help you.

The Normal Channel only uses the Volume Control to adjust volume.

Feb 01, 2011 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

Fender Hot Rod Deluxe Volume Fluctuations. My amp (fender hot rod deluxe) will occasionally have volume fluctuations when I'm playing. The changes usually occur when I've moved my setup from one place...


First thing would be try another guitar with the amp. This will eliminate if it's a problem with the guitar or the amp itself. If the guitar is working properly then check all the tubes to be sure they are all seated into there slots completely. Depending on how much use they have been played it may be a good suggestion to then replace your tube's. Occationally the tubes will start loosing power, making sound fluctuate up and down or distortion sounding static in background noise. You will notice a big difference with newer tube. But remember the bias must be set correctly to match the new tubes so they won't over heat. You can check out youtube for setting the bias. Anyway this is my suggestion and I wish you good luck.

Jan 18, 2011 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Hi, I recently bought a fender hot rod deluxe which gives a very noticeable static sound. On the clean channel with the volume up to 4 it will be very audible. Is this normal or should it be brought to a...


Hello. You might have a "Tube rattle" problem. This is very common in these amps.
google "tube rattle" and you will find alot of people having the same issue.
There is some rubber tube dampers that you can buy to stop the rattling.
Hope this will help

/Daniel

Sep 23, 2010 | Fender Hot Rod Deluxe Guitar Combo...

3 Answers

Fender hot rod deluxe tube rattle.


Fender hot rod´s have an common problem on the plate resistors of the preamp and phase inverter tubes.

Check if the 100K and 82K resistors on the tube socket board are not brown. Those resistors usually need to be changed to bigger ones 1/2W.

this guy made a good document about this fix:

http://home.comcast.net/~fredholz/Justin-Holton/Fixing%20Loud%20and%20Intermittent%20Crackle%20or%20Static.pdf

Apr 01, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Fender Hot Rod Deluxe. Turns on, sounds very good for a little while between 2 to 10 minutes. Then the volume fades out. I replaced the power tubes and still does the same thing! PLEASE HELP!


More than likely a bad solder joint. Where is the next question. How confident are you with voltage measurments? The rails in tube amps are high and can kill you so if you are not inclined to do so please don't. The reason I suspect a solder joint is that it is a failure over time, cold solder joints expand and contract with heat. When they heat up they break connection. Not saying 100% that is your problem but it is very likley.

Dec 13, 2009 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

No volume.


Are the tubes bad? Do they light up? Check the tubes and install replacements if necessary. If it's a preamp tube that went bad, just replace that one tube. If a power tube went bad then replace the set of power tubes. Be sure to get a matched set when replacing power tubes, and to bias them.

Aug 08, 2009 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

I have a Fender Hot Rod Deluxe. It has very few


First try turning the volume control down before turning switch to operate.

IF this seems to fix it, IF the unit has a tank reverb, the vibration of the reverb springs MAY be causing the problem. The solution then is to reduce the volume before applying power WHICH is a good idea anyway... from an electrical engineer.

Jul 24, 2009 | Fender Hot Rod Deluxe Guitar Combo...

Not finding what you are looking for?
Fender Hot Rod Deluxe Guitar Combo Amplifier  Logo

223 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fender Music Experts

dave nyman

Level 1 Expert

17 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Fender Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...