Question about Raymarine C80 GPS Receiver

1 Answer

Raymarine G series radar

New install of G series radar. Radar and 15 " monitor work fine while under sail with motor off. Once I switch to the diesel motor, the radar operates fine for about 5 minutes and then the radar and the monitor shut down. I've tested the voltage while the engine is running and it is between 13.2 and 13.8 volts. Any suggestions? Sorry there is no category for this unit so I'm putting it in with GPS

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 132 Answers

Your problem is likely noise from the motor. Modern diesels use high speed networks, so it could be interference. Next likelihood would be a software issue. Is the diesel set up to display info on the G display?
Solution could be re routing cables, grounding or un grounding devices. First step is to send your processor to Raymarine, sorry, necessary step to eliminate hardware failure. This is a tough symptom, so do the easy stuff first.

Posted on Jan 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can't get radar on the screen


do you have the radar receiver or you just clicking on radar and wondering why you cant see it

Sep 01, 2013 | Raymarine C80 Multifunction Display

1 Answer

Even after double checks on settings Iam still getting weak echos on Raymarine E120 radar. On higher ranges picture is non existant. Where could my problem be?


How old is the radar antenna? When the echos are weak that is a sign of a failing or weak magnetron. Have you gone into the system diagnostics page to read what the signal strength of the radar is?

Jun 11, 2010 | Raymarine C120 System Pack C120 Raystar...

1 Answer

I Have a Raymarine Radar RL70CRC HSB2 the


If both plotter works but they have no comunikation
RESET the RL 70 AND L760
This is how it works
press the powerbutton when you have picture press the menu bottom
than systemsetup and than four seconds the menu bottom.
Do this on both plotter normaly after this it works again

Jun 11, 2009 | Raymarine RL70CRC GPS Receiver

1 Answer

Antenna not rotating


It sounds like voltage loss could be your issue. You need to find the "Y" cable under the dashboard and measure the voltage at the point where it connects to the main 12V supply. Keep the meter on and then spin up the radar. If there is a fuse (there should be) make sure you are measuring on the radar side of the fuse. If the voltage drops off as the radar slows, you have found your problem. If the voltage stays constant and the connections are sound at the terminations in the radar pedestal, I would recommend you send the pedestal in to Raymarine.

May 11, 2009 | Boating

1 Answer

Plotter Rl70c no image


sounds like it died...i happen to have one for sail with 4k dome

Sep 19, 2008 | Raymarine RL70CRC GPS Receiver

1 Answer

Raymarine 41xx - Message "bearing pulse error"


More than likely your motor is going bad. Inside the motor is your bearing pulse generator. Replace the motor and you should be ok.

Apr 28, 2008 | JRC 1500 MKII Radar

2 Answers

Raymarine SL70 Radar; Unit switches on normally, but there is no radar image appearing. The cable is ok, the scanner is rotating...


I have the same problem. All functions and settings appear to be working OK but no image. After startup time about 3.5 amps are drawm When I turn on power [transmit] amps goes up to 4.5 approx.

I have the scanner head spinning but no target images

Ian

Apr 07, 2008 | Raymarine RL70CRC GPS Receiver

1 Answer

Ray Marine c120


Send unit back to Raymarine. Two year warranty. I just talked to the factory about a communication error between the E series and the radar. Radar just stopped communication between radome and E unit.

Jan 31, 2008 | Raymarine E120 GPS Receiver

Not finding what you are looking for?
Raymarine C80 GPS Receiver Logo

Related Topics:

135 people viewed this question

Ask a Question

Usually answered in minutes!

Top Raymarine GPS Experts

Shehu Pro
Shehu Pro

Level 3 Expert

1284 Answers

Steve
Steve

Level 3 Expert

691 Answers

The Knight
The Knight

Level 3 Expert

73118 Answers

Are you a Raymarine GPS Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...