Question about Aprilaire 600 Humidifier

1 Answer

I have a aprilaire 600A I have hooked it all up but for some reason the number display doesnt show anything. The controls all light up, but no display. Also for some reason no water is coming out.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

Thank you for contacting us. Does your humidistat have a blower activation switch on the lower left hand side of the humidistat? If you do it is our #60 humidistat, and if it is not there you have a #58 humidistat. The R & C are the two connections that supply power to the humidistat to give you the numbers on the digital display. The 60 you wire right into the R & C off the furnace panel. The 58 you need a constant 24 volt and 10 VA power source which you could get by using the transformer off a constant 120 volt power source to power the humidstat. If you are doing this correctly and you still do not get the numbers to show up, then you have a bad humidistat and you need to go back to where you purchased it from and exchange it under warranty provided you used a certified HVAC contractor to do the installation. Our warranty is only valid if you used a certified HVAC contractor to do the installation. If you have any additional questions please contact us at 800-334-6011.

Thank you

www.aprilaire.com

Kevin Engen
Customer Service
Research Products Corporation

Posted on Nov 16, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Humidifier control: red light is on. getting 24


the red light is lit because either you didnt install the manual mode resistor or your not using a out door thermostat but you have to hook somthing to the two terminals just to the right of the HH terminals

Dec 23, 2009 | Aprilaire 600 Humidifier

1 Answer

Aprilaire 760 humidifier. no power to humidastat


the 760 send power out the humidistat is just a switch if you touch the two brown wire coming outof the 760 the humidifier should come on if it doesnt and you had appiled power to those wire you probably shorted the 760 control board

Jan 15, 2009 | Aprilaire Humidifiers

2 Answers

Humidity too low


I corrected the problem...RH is rising nicely!! Installed by "professionals" on my Trane XV90....I redid their wiring and now have the following setup...

600A water supply coming from hot water line.
Removed orifice inside incoming feed tube.
control incoming water flow from saddlevalve on hot water supply ( make sure its a nice solid flow, no drips, but no "force" too it either)..enough to insure entire evaporator unit is wet and water is slightly flowing out of bottom to drain.

I also have it wired to run when ever the furnace blower is on. Heat or no heat. XV90 is variable speed, and by doing this the 600a is always adding moisture, until it reaches correct RH%

Also, I disconnected the outdoor temp sensor. I went to Radio Shack and bought a 47K ohm resistor ( 1/2 watt....4 pack for 99 cents). Installed that in place of outdoor sensor...now runs in manual mode. Have unit currently set to number 5.



Jan 14, 2009 | Aprilaire 600 Humidifier

1 Answer

The water flow valve doesn't seem to be letting water through to


http://www.aprilaire.com/themes/aa/en/manuals/600a.pdf Read page thirteen and there is a inlet water filter that may be cloggeed. Let me know if you need anything else.

Jan 11, 2009 | Aprilaire 600 Humidifier

1 Answer

Aprilaire 600 will not turn on


http://www.aprilaire.com/themes/aa/en/manuals/600a.pdf here's the link fo the manual. read page thirteen about the inline screen that the unit has. it may be clogged up.

Jan 10, 2009 | Aprilaire 600 Humidifier

2 Answers

Orifice clogs to Aprilaire 600


http://www.aprilaire.com/themes/aa/en/manuals/600a.pdf look at page thirteen in this manual there is allready a inline filter on the unit. hope this helps

Jan 06, 2009 | Aprilaire 600 Humidifier

1 Answer

Aprilaire 600 valve won't open?? help


hook one wire to the hum screw on the board if there is not a hum screw hook it to the green screw,go up to the humidifier then back down to the common screw on the board that should make the unit only come on when the fan is running. it sounds like the humidistat is not working correctly

Oct 14, 2008 | Aprilaire 600 Humidifier

3 Answers

Aprilaire 600 only operates in test mode...


Call Aprilaire and tell them, this is happining everywhere

Dec 05, 2007 | Aprilaire 600 Humidifier

Not finding what you are looking for?
Aprilaire 600 Humidifier Logo

233 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aprilaire Humidifiers Experts

paulcarew

Level 3 Expert

2461 Answers

jdthefixer

Level 3 Expert

744 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Aprilaire Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...