Question about Sharper Image Vacuums

Open Question

I have the Sharper Image EV-HD15 Cool Mist Humidier Ultrasonic 1.6 gal humidifier. I purchased it last year. Yesterday I took it apart to clean as per instructions. I feel that I may not have place the round housing (which is secured with 4 screws) back correctly. When I turned the machine on it made a whirring sound. I took the unit apart again and rotated that round piece moving the opening away from the opening on the tower. The whirring sound was reduced but there was still a sound. I don't remember any sound at all before. I am unable to locate my manuel.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
Noggin
  • 944 Answers

SOURCE: need manuel

Here's the link to the manual; http://www.bissell.com/images/UserGuides/9200-605web.pdf Hope this helps, if not please ask again with a bit more detail of the specific problem :)

Posted on Jun 18, 2007

Ad
  • 1 Answer

SOURCE: Retractable power cord

Those trim pieces SLIDE off by opening the front where the bag goes, Take a pair of pliers and slide them out. You might have to use a screwdriver to help initiate the grabbing of the slide.

Posted on Jan 28, 2008

jmeredith
  • 417 Answers

SOURCE: Bissell 9400 Carpet Cleaner

Hi,
I have a Bissell 9200 Proheat 2x with same issue.
theres a circuit board in the handle that controls the DC brush motor and a handle release switch near the back wheel. Its either the motor, circuit board or release switch, Ive isolated my brush stoppage to the circuit board by testing. If your handy at all you can test to see what it is. Begin by disassembling the handle by removing several screws, be careful as there will be two different lenghts of screws, inside the handle is the dreaded circuit board brain screwed to the back handle attached with four wires via connector. the grey and black wires go down to the motor and handle release switch (theres a switch that stops the brush motor when you put the handle up in the bottom by the wheel), yellow and red wires are 120 volts form main switch, use a circuit tester to check for voltage from yellow and red and switch to continuity to check if the motor has an open circuit or busted handle switch. I suggest using a digi cam and take pics of disassembly and masking tape to mark hoses if your going to disassemble the bottom. FYI Bissel will not let you order that circuit board but will let you order the motor, I dont know about the switch. Looks like Im going to build my own circuit board from radio shack parts , Im not sending my Bissel back to Bissell, I could go on and on about that LOL.

J Meredith

Posted on Jul 09, 2008

  • 1 Answer

SOURCE: my bissell powerbrush won't **** up the water

had same problem - carpet soaked with dirty water and very little, if any, cleaning fluid used. Easily remedied. Removed water resevoir and found that the rectangular shaped washer at the top of the front cover (the bit you had unscrewed to give a good clean) had become dislodged. It has small lugs on either size which lock on to the plastic opening when pushed down firmly. Resevoir then sits on top and makes full connection, also ensure that grey locking handle is fully pushed down.

Seemed to me that the water wasn't being sucked up as there was air getting in and this has down the trick. Sorry if this is difficult to follow but all will become clear when you look for the black washer! Good luck

Posted on May 04, 2009

b0sslady2001
  • 357 Answers

SOURCE: It's been awhile since I have used my shampoo

Hello,
The littlew round screen goes in the hole where the hose attaches to the tank. The round foam filter goes up in the hole underneath the on/off valve for the foam. Here is a guide if you need any more help...

http://reviews.ebay.com/KIRBY-CARPET-SHAMPOOER-INSTRUCTIONS-MANUAL-DIRECTIONS_W0QQugidZ10000000004594992

Marci

Posted on Jun 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

O-Cedar Pro-Mist trigger doesn't work


This person is asking about an O'Cedar Pro Mist Mop. Not a vacuum or steam mop...

I too have problems with the pro mist handle not working... I called the customer care line at 1800-543-8105 and they are replacing my mop for free. You can also try to take it apart and fix it yourself, but I did that and I cant remember how it goes back together! lol Basically a spring comes loose from the pole inside of the mop handle, and that is why there is no tension in the trigger.

Feb 19, 2012 | Vacuums

1 Answer

I have a very old Soundesign Ultrasonic Humidifier. Model 1866. I need a water tank cap. This cap has a plastic pin in the middle of it as well as a rubber gasket type thing, this helps control the flow...


just realize its an old post. just throwing mine out i would have sent u the cap. mine stopped shooting mist out cap is good oh well. linda c

Jan 01, 2011 | Vacuums

1 Answer

I misplaced my manual for my sunbeam model 1128 warm mist humidifier and would like to know how to clean it....there is a white powdery stuff coming out of the base, how do i get rid of this....or could a...


the white powdery stuff is minerals, use a vinegar solution to warm water 1 part vinegar to 4 parts warm water. let it soak in the humidifier overnite or during the day and rinse with warm water. You could also use clr using bottle directions.

Dec 03, 2010 | Vacuums

1 Answer

My dyson dc18 loosing suction , took apart and didnt find any obstructions


Hi its Darran at Dyson.

A loss of performance is normally attributed to a blockage or a dirty filter. Please ensure you follow the full blockage procedure outlined in your user guide or in the Support sectino on our website at www.dyson.com.

You will also find information here on checking the cleaner head to ensure the brush bar is turning and instructions on how to wash the pre filter.

I hope that this information is useful to you and should you need any further help or advice, please contact our Helpline on 0800 298 0298 (UK) or 1866MYDYSON (US).

Kind regards
Darran
Dyson Customer Service


Apr 20, 2010 | Sharper Image Dyson Slim DC18 All Floors...

4 Answers

Electrical power down while vacuuming (not a reset)


Thank you JonahBegone!
My 4 years old Silver Moon has been power down off and on for a couple of months, but all of sudden it kept doing it. Then the power won't turn on when I plugged it in ( this turns out to be another problem, see my other posting). I took your advice on taking the hose and handle apart. I unscrewed the 5 screws, but can't pull the handle apart to look inside. I was able to see the 3 metal contact on the hose that you mentioned through a 1/4 inch gap when I forced the handle apart. I cleaned the black stuff off through the little gap by rotating the hose a few times. Then magically, my power down problem also went away. Thank you once again.

Mar 25, 2008 | Miele s558 Silver Moon Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

118 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sharper Image Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18407 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Are you a Sharper Image Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...