Question about Hoover Vacuums

1 Answer

Windtunnel 7600 has stopped suction through the tunnel. The hose has plenty of suction. The connection from the hose to the wind tunnel is not obstructed.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 132 Answers

Poss.the top filter.it's not venting properly.

Posted on Nov 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wind tunnel t series vacuum won't turn on


I had the same problem and used a tool to clean out the suction tube on my Windtunnel Series T. It was full of junk packed in tight. After cleaning it out there's no more turning off or overheating. It actually works better than when I first got it (used from a friend).
wind-tunnel-t-series-vacuum-turn-z0fb4p0zfxquqkotqdqr0yh5-2-0.jpg

wind-tunnel-t-series-vacuum-turn-z0fb4p0zfxquqkotqdqr0yh5-2-2.jpg

Nov 20, 2010 | Hoover WindTunnel TSeries Bagless Upright...

2 Answers

I have a Hoover Wind Tunnel Self propelled 12amp. There seems to be very little suction. I have cleaned the hoses and filters but still not much suction. any ideas? thanks.


Make sure all filters are cleaned out and entry ways are clear of all debris. Remove hose and check for blockage. Usually the low suction can be remedied when all filters are cleaned. Hope this works for you.

Jul 17, 2010 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

How to change the V belt on hoover wind tunnel U6435-900 ?


Below I have listed a link to the manual which has instructions and a link to the V belt you need.

Windtunnel Manual

Windtunnel Replacement Belts

Nov 03, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

No suction on Hoover Wind Tunnel.


Greetings from GoVacuum.com,

First this is a common problem on ALL bagless vacuum cleaners. Usually it takes longer then 1 day however.

Is there no suction in the suction hose, or is it not suctioning from the floor?

Most people buy a bagless vacuum once, then return to a bagged one after their bad experience, you are not alone!

Please give me the model number to your Hoover, (found on the bottom or the back of the vacuum on a foil label).

Thanks,

Chris Jones
GoVacuum.com
1-866-468-2288
chris.jones@govacuum.com

Aug 18, 2008 | Vacuums

1 Answer

Hoover Wind tunnel supreme, loss of suction


http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=40600&thid=562967
Hoover Wind tunnel supreme, loss of suction
posted by bazballfan on May 01, 2008
Hello, I purchased two of these models in late 2007 and after changing the bags on each of them I have little to no suction with the vacuum. The hose is fine and I have taken them apart and there is no obstruction in the hose or in the base.
These worked so well and now they don't do anything. The bag isn't filling much and the simplest things can’t be vacuumed up
Please help me to fix this



Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
Hoover U5450-900 Windtunnel Supreme Vacuum
Sorry you are having a problem, it sounds lie you have done almost everything, but just in review it could be some of these problems:
Belt change – every 4 to 6 months
Are the brushes in good shape
Where does your suction drop off
Is the bottom plate securely on the bottom
Are there any gaskets that are broken or leaking
Is the bag installed securely
Did you check for any clogs or obstructions
Is the filter clean
Feel free to contact your local vac dealer in your area.
So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Thanks, Don – The Vac Man
Go Ahead. Use Us.

May 01, 2008 | Hoover U5450-900 Windtunnel Supreme Bagged...

1 Answer

Hoover Windtunnel


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is a filter at the bottom where the dirt cup (and bag) is, check it also.

Dec 28, 2007 | Vacuums

1 Answer

Hoover wind tunnel


Check the hose to make sure it isn't clogged. But if the model number is different then the one above your post, U6437-900, then let me know.

Dec 05, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Wind tunnel hoover


Do you have suction at the hose end, if you do then it may be clogged at the inlet by the brush roll. Is the filter cartridge clean? If it is clogged and air can't pass thru it, then you will have no or low suction. Might also check the belt to make sure it is turning.

Nov 30, 2007 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover Self Propelled Wind Tunnel Turbo Powered 7600 The thin belt too loose


If this is a "V" belt, make sure the small roller that tightens the belt is ok and not jammed up. It may have to be replaced. Also if the flat belt is stretched at all, it won't work either.

Nov 18, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

107 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1466 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...