Question about Tappan Ovens

1 Answer

The top element of the over was not heating (turning red), the over stayed at preheat. I took the element out and took it to a local repair store. They tested the element and said it was good. They suggested I put the element back in and make sure it had a good connection. When I went to put the element back in the left side connector went inwards and I can't make the connection. How can I get it out? One more question, is there anyway to take the door off and make it easier to reach the back. Tappan electric stove/oven four burner 30 inch Thank you, Cathy Armstrong mcavelvet@yahoo.com

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,891 Answers

You can try to snag the wire using a clothes hanger with a u bent in end . if you can see it with a light you may get it back . other wise pull the oven and remove the back to install wire . . some oven do have lifo off doors but they also may have a screw in the hinge . so ck .. and if element was good then look at function or thermo as having the problem..

Posted on Nov 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Whirlpool wgp30801


It is common to have the broil element pulse on or they will send 120 volts to the broil element to even the heat in the oven. Some ovens have a preheat function that will power the broil and bake simultaneously until the oven reaches temperature then the broil element will shut down. If they both stay on red continuously through the entire bake process then something is wrong. Probably a stuck contact on the control.

Feb 12, 2014 | Ovens

1 Answer

Not sure which model my oven its but it takes a long time to preheat then does get warm enough. I put an oven thermometer in it and if you set it for 400 it beeps that it is up to temperature at 300 then...


I have a kenmore electric range/ultra bake, after using the self-cleaning mode on the oven, I cannot get the oven to heat up when I put it in the preheat mode. What should I do?

Apr 06, 2011 | Kenmore 40494 / 40495 / 40499 Electric...

1 Answer

Preheat not working in oven


Hi,
When the element went it also took out the contactor..

Check out this tip...

http://www.fixya.com/support/r4404788-electric_oven_problem_oven_will_not_shut

heatman101

Apr 10, 2010 | Ovens

1 Answer

Model GBS307PDQ5: Oven preheated to 425 degrees.


F3 usually means, that the oven temp. sensor is bad and one need to replace it.
The fact, that it's not heating tells me, the fuse in the back also needs to be replaced (requires pulling out).

Whirlpool oven repair orange county, ca

Feb 06, 2010 | Ovens

1 Answer

I have a whirlpool range. During preheating the


sounds like you may have a bad bake element. try to see if the unit will get hot when set to broil. if it does then try the bake again. if you get no red hot heat from the bake element then you may need to replace it.
when an element is working properly it will heat to a red hot glow.

Jan 12, 2010 | Ovens

1 Answer

Preheat takes too long


does the oven bake properly when it does reach temps?
if this is a newer oven, with a hidden bake element, they do take longer to preheat so may not have any problems, just give it about 15 minutes to preheat.
if it is older and doesnt bake right, then you may have a bad bake element.
the unit will heat but wont bake right.
unplug the oven and take the bake element to your local parts house, they can check it and sell you a new one if needed.

Jan 10, 2010 | Frigidaire Ovens

1 Answer

Kenmore oven - will not heat on bake / will heat on broil


its your temp sensor. replace it and it should fix ur prob
F2=overheat
is your bottom element connected?

Mar 23, 2009 | Kenmore Ovens

1 Answer

Viking oven broil keeps on


it is designed to preheat this way. after the unit cycles the red indicator light off the first time than both elements turn off. when it calls for heat again only the bake elements comes on. makes the preheating work faster.

May 05, 2008 | Viking 30" Professional Select Built-in...

1 Answer

Kenmore oven - Not heating up


Check the BACK of your temperature knob for an adjustment. I was ready to replace my heating elements when I accidently discovered the adjustment. Made the adjustment and no more problems. My oven now stays within 4 degrees of settings.

Aug 25, 2007 | Equipex PZ-330 Electric Single Oven

Not finding what you are looking for?
Ovens Logo

Related Topics:

57 people viewed this question

Ask a Question

Usually answered in minutes!

Top Tappan Ovens Experts

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

ashburton

Level 3 Expert

417 Answers

Ezewudo Onyekachi
Ezewudo Onyekachi

Level 3 Expert

406 Answers

Are you a Tappan Oven Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...