Question about Onkyo SKS-HT240 System

Open Question

My sub is not powered and it's plugged in no red or green display light SKW240

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Subwoofer not recognized and no sound from tuner


do a test tone which will test all speakers connected to the receiver.

Apr 19, 2014 | Yamaha Audio Players & Recorders

1 Answer

Cadence 400 watt active sub green light on, no sound from the sub. whats wrong?




proceed according and fix it. However yi\ou must read the diode LED for diagnose. God bless you

Mar 26, 2013 | Exercise & Fitness

2 Answers

Hey i dont know to much about amps, but me and my friend (he knows a decent amount about amps) would plug the power into the amp and the green light would come on. Though when we plug it into the subs, the...


Are you connecting positive to positive and negative to negative from the sub to the amp? If so, try positive to positve (+) in the far left channel and then the negative to negative (-) on the far left channel to. If no luck do the same in the other channel with one sub at a time. Try one sub at a time, Dont try an connect 2 or more subs to one channel as this would cause the amp to go into protect mode (red light you describe). Usually the positive wire has either a line down the wire, writting on it or has a red seperate wire with it when wire end stripped to connect it. Hope this helps and please rate...

Mar 11, 2011 | Bazooka EL1500 Car Audio Amplifier

1 Answer

Hello. My Kicker kx200.4 is acting funny. The red display light on front/top of the amp is turning on for a second and then turning off, repeatedly. The light on the side (power) is also turning on, red...


the amp is a 200 Watt by 4 im guessing and its doing that because its going into protection mode unhook the subs if it stops then 1 you have a bad sub or 2 the subs are too much for the amp if an amp is rated 200w per chanel its 200 max about 75 rms or 75 normal constant power

Feb 05, 2010 | Kicker KX200.4 Car Audio Amplifier

1 Answer

Pyle dryver amp light protection stays on not green light stays red i have tried to disconnect everything and plug it back up but light stays red


check your subs disconnect them the try to power the amp up if it powers up the the subs have died and it could be a problem with that amp i suggest you get a better amp

Jul 09, 2009 | Pyle Dryver PLAD213 Car Audio Amplifier

4 Answers

Red light


something is shorted in the circuit, or your subs. unhook the subs first and try it again, if it is still in protect then it is most likely the output transistors.

Feb 22, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

PLTV-26


WHEN I TURN ON MY TV THE LED IS RED THEN GREEN AND GOES BACK TO RED AND NO IMAGE. WHAT COULD IT BE, i ALSO DID A HARD RESET BY REMOVING THE WIRES AS THE TECH HAD SAID AND NOTHING.

Dec 11, 2007 | Protron PLTV-32 Television

1 Answer

Power light


This could be a DC offset condition. Check you manual for what this means. Or other condition. First Disconnect the Subs and try it. If it still goes red then disconnect the RCA's and try it again. If the Led continues to go red after the click then the Amp is hosed. The Click you hear is an internal relay that cuts the subs in after a dely so you do not get the turn on THUMP of the radio at your subs.

Jul 08, 2007 | Hifonics Titan TX 8805 Multi-Channel Amp...

Not finding what you are looking for?
Onkyo SKS-HT240 System Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Onkyo Audio Players & Recorders Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

 Grubhead
Grubhead

Level 3 Expert

5309 Answers

The Knight
The Knight

Level 3 Expert

74887 Answers

Are you an Onkyo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...