Question about Rainbow E series Canister Wet/Dry Vacuum

1 Answer

Plugged vacuum in and no power - Rainbow E series Canister Wet/Dry Vacuum

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 157 Answers

Hook up your power head and see if it works. If it does, most likely the problem is in your main unit motor resistor. If it doesn't, then check another outlet. Still no function, switch or loose connection inside.

Posted on Nov 06, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why won't power nozzle attachment turn on?


you may not have power coming from the vacuum. those plugs are known to fail.

Sep 02, 2015 | Electrolux Vacuums

1 Answer

Power nozzle motor not working on my rainbow e2 vacuum?


Check plugin on the power nozzle and poles there may be some thing blocking connections

Dec 28, 2013 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

My home has a central vacuum system hook-up but no vacuum installed. My friend upgraded his central system and gave me his Eureka Mega Boss central vacuum system and the accessories, including the pow


The power head requires 120 Volts. Some hoses have a receptacle in the handle for the power head plug, and the hose has a cord at the wall inlet end that plugs into a receptacle. Some hoses have a plug at the wall inlet end that plugs into a 120Volt receptacle built into the inlet. The hose plugs into this receptacle when you push the hose into the inlet. The power for this built-in receptacle is wired with line voltage when the system is installed.

Apr 15, 2012 | Eureka 1810 Central System Vacuum

2 Answers

The brush is not working when I turn the power on and the belt appears to be on and intact. How do I fix it?



This is actually a bad design by Bissell. Remove the Lift-Off portion of your vacuum cleaner. Down at the bottom, where the Lift-Off portion was sitting, you should see a small electrical plug part. What usually happens is this plug arc's, which causes it to burn the plug, and stop the power nozzle from spinning. If you see any black, or burning around this plug, take your vacuum back into Bissell, they will fix this, or give you a new vacuum for free. They don't even sell us their warranty stations this plug piece, you can only exchange it for a new vacuum.

If this is not burned, check the reset button for the brush, it's either located near the plug, or on the side of the brush portion of the vacuum.

I hope this was helpful to you.

Chris Jones
goVacuum.com

Jan 08, 2011 | Bissell LiftOff Revolution Pet Vac 37602...

1 Answer

All of a sudden the vacuum started sounding different and the suction was only about 30% of what it normally is.


If the sound of the vacuum changed and it lost most of the power it sounds like you picked up something that plugged it.check your hose and intake to the machine. You can take the hose off and drop a coin through it to see if it is plugged. Check the power head to see if something is plugging it .

Oct 11, 2010 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

Pushing the power switch does not turn on the vacuum.


The only fuse is in the plug if this blow then it might trip the CB out

Aug 01, 2010 | Dyson DC14 Animal Bagless Upright Cyclonic...

1 Answer

Plug gets hot when using vacuum.Could it be the motor? My husband thinks it's because it is drawing to much power. That the vacuum is blocked somewhere.


Do you mean the plug in the wall gets hot if so this should never happen has the fuse in the plug been changed?
if not the vacum can not be pulling to much power as the fuse will blow to stop that
Yes the vacuum may be blocked some where but should be easy to find out where as these models come apart with ease

Jul 20, 2010 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

My Hoover vacuum model - U6317-930 lost power. I


Something is definitely loose in that area. Replacing the related parts is probably the best fix.

Jul 17, 2009 | Vacuums

1 Answer

My Eureka Whirlwind vacuum on-off switch won't turn off


the power switch is bad. go to your local hardware store and buy a new power switch and replace it.

Mar 23, 2009 | Eureka Whirlwind Litespeed 5740 Bagless...

1 Answer

My hoover power drive vacuum simply died. It just shut off. I checked the plug, etc...I just can't get any power...Can you help?


If no light or motor sound cord is probably bad. Look near AC plug or just replace the plug end. Check with ohmmeter for continuity with switch ON.

Jan 24, 2009 | Hoover U6311-930 Power Drive Bagged...

Not finding what you are looking for?
Rainbow E series Canister Wet/Dry Vacuum Logo

Related Topics:

120 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rainbow Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

Joseph Hoffmann

Level 3 Expert

1702 Answers

Robert McClure

Level 2 Expert

160 Answers

Are you a Rainbow Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...