Question about Car Audio & Video

Open Question

Everything is connected but cant get subs working throu my amp , its Rampage RMP 7455

Posted by on

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

vetteman3002
  • 2299 Answers

SOURCE: When i connect rear speakers

Either you have the back speakers hooked up to the sub woofer output channel on the head unit. Or your amp has a built in crossover. Not letting the higher frequencies get to the speakers.

Posted on Nov 05, 2010

  • 1139 Answers

SOURCE: When i connect rear speakers

Ok I am trying to understand what you are saying but it is a little difficult without seeing it :)

The fact that you have one amp to power 4 speakers and a sub is not ideal, you should have a seperate amp for the sub and then the 4 channel amp for the 4 speakers. They way they are connected is also very important. From what you are saying you are splitting the RCA cable so that you can connect it to the other 4 inputs, this seems a little strange. The RCA inputs (which should be just one red one white connector on the amp) are for low signal inputs and have a great amount of amplification. The other 4 inputs you are talking about should be high level inputs, for example a direct connection from the head unit speaker wire, NOT RCA. These high inputs are not amplified as much as the low. I am guessing that because you have split the RCA cable and put a low signal input into the high signal input, the signal is being amplified all wrong.

Can you confirm exactly what sort of input connectors there are on the amp, usually it is 1 RCA, 4 hi level inputs, power, ground, remote and then the outputs. Let me know and I will try and help you out some more.

Posted on Nov 07, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Subs and amp sat in my garage for a year. I just


check your subs by connecting them straight from the stereo. If they work then there is an issue with the signal comming from the stereo through the rca cables to your amp, check those. Try another amp if you can with those rca's or test the amp with a friends car, either way try to rule out everything until it points to the problem.

Apr 17, 2010 | PPI PCX-2200 Car Audio Amplifier

2 Answers

Pyle Academy 2300 watt amp not working =(


wrap a striped speaker wire around the back of the rca out put on your cd player and for the record that aint a 2300 watt amp its like a 300 watt amp

Mar 30, 2010 | Pyle PLAM2300 Car Amp

1 Answer

I just installed a kenwood dnx7140. Everything is


Have you checked to see if the sub amp is turning on. Check to make sure you have at least 12 volts on your power as well as your remote turn on (Blue/White on radio harness).
If everything is hooked up correctly, it is possible that the preout is turned off. Some headunits have selectable preouts. If so you should be able to turn the sub on and off in the menu.
Hope this helps
VOTE

Mar 08, 2010 | Kenwood DNX7140 Car GPS Receiver

1 Answer

I Have a Gem Sound EVA3955 amp an TR-150 subs sub stop wroking


Yes and Yes. If bypassing that noise filter, has no effect your subs could have blown.

Jan 05, 2010 | Car Audio & Video

2 Answers

Noise through car speakers when connected to amp


If the subs are making a humming or RPM sound check your ground on the amp , make sure its a good ground. Always run your power wire from battery by itself down one side of vehicle. Groun should be no longer than 2 feet. If that dont help you can buy a noise supresor that goes inbetween your head unit and amp through RCA's with a ground on it . Hope this helps.

Jul 25, 2009 | Alpine MRD-M1000 Car Audio Amplifier

1 Answer

No sound from the subs


If everything is connected correctly and the light on the amp is lite check the settings for the amp or sub in your head-unit. Consult the units manual. If you still have a problem give us more information I'm sure we can figure it out.

May 12, 2009 | Car Audio & Video

1 Answer

Subwoofer Output Not Working...


first check that the subwoofer function on the actual head unit is turned up,second check that the gain on the amp is at bout half way then check that it is on a lp (low pass setting)
then check that the boost on the amp is turned up.
please leave feedback.
cheers

Jul 02, 2008 | Eclipse CD5405

5 Answers

Rampage BA-100 200W amplified subwoofer


Actually. I don't think you have to wire a remote switch from the radio to the amp on this product. This powered subwoofer supposedly has automatic signal sensing turn-on circuitry. I have the same problem. So I think I'll try to just hook up the power (to the battery), ground and the + / - speaker wires to one of the back speakers in the car and see if that works.

Jan 22, 2008 | Audiovox BA100 Car Subwoofer

2 Answers

Rampage amplifier


The amp is supposed to turn on and off with the head unit. The remote wire on the amp should be connected t othe amp control/power antenna wire of the head unit.

The pop should go away when the remote is being switched on with the head unit.

If the amp is staying on with the key removed, it will drain your battery. You need to re-wire it so you don't get stranded.

Nov 29, 2007 | Audiovox Rampage 1200 Watt Amplifier Car...

1 Answer

Subwoofer Output Not Working...


The first thing to try is disconnecting ONE of the two subs. See if you get more bass with a single sub than with both. If you do, re-connect the second subwoofer, but reverse the (+) and (-) wires.

Jun 19, 2007 | Panasonic MXE CQ-C7401U CD Player

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

86 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

yadayada
yadayada

Level 3 Expert

74896 Answers

The Knight
The Knight

Level 3 Expert

73591 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...