Question about NAD C372 Amplifier

1 Answer

Sound through one channel

I recently bought a NAD 304 Stero Amp. I've plugged my turntable into it, but only get proper sound through the right hand channel. No matter how much i turn it up, the left channel stays the same volume. Even with all the balance shifted to the left it doesn't change volume. Any ideas?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,071 Answers

Only the right channel had a sound,the left channel is mute, whatever adjustment you did and whatever balancing you done nothigs happen,even you interchange the speakers. The problem is in the power amp. The STK IC there is busted already, it's better to change it with a new one so the performance become normal again.

Posted on Jun 17, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have vestax 05pro2. Left channel works but out of one speaker. The turntable input is good. Im thinking Its either the channel fader, or the rca inputs for that side. Has anyone had this problem?


Hi,
Here's a solution to see if you have a problem with either your receiver or turntable.
The turntable has 2 RCA's one red for right channel, and one white or black for left channel, which plug into the back of the amplifier.

  • Unplug both RCA from rear of amplifier.
  • Plug in a cd or dvd player into those inputs on the amplifier, the sound will be lower but it will give you an indication if the amplifier is ok or not.
  • If you have sound on both channels left and right then the amplifier is good
  • If you still only have sound on left channel, then there is a problem with the right channel input on the amp.
  • If your amp, is good, unplug the cd /dvd player.
  • Put a record on and start playing the record
  • Plug the white or black RCA from the turntable into the rear of the amplifier marked left, you should have sound.
  • now unplug it from the left and plug in into the right red RCA socket, if you have sound the amplifier is working fine.
  • if there is no sound there may be a problem with the stylus cartridge on the turntable
  • now lets reverse the test
  • unplug both RCA from amp.
  • Plug the red RCA into the left socket on amplifier, if there is sound, turntable is working fine, if no sound there is a problem with either the stylus cartridge or that red RCA cable.
  • now unplug the red RCA from the left side and plug it into the right side socket
  • if there is no sound there may be a problem with the stylus cartridge or RCA cable.
I hope this helps

MobileJB

Jul 15, 2011 | Audio Players & Recorders

2 Answers

I've connected my turntable to my stero system. When I try to play a lp the sound is terrible. I've replaced the needle. Did not help. Any ideas?


is the vinyl clean vinyl is supposed to sound weird thats what its all about. if the records not clean it could make it sound ****

May 21, 2011 | Numark ttUSB Turntable

1 Answer

My Pioneer PL-990 Turntable only outputs sound through the white wire. Only a quiet buzz comes through the red wire.


The red wire is the right channel, so going back to your amp, get a single phono plug with with the wire exposed, so you can touch the wire. Then remove the turntable connections. With the amp on plug the the lose wire plug into each channel and check if the sound on the right is still low. If it is then there's a problem with the magnetic cartridge pre-amp inside the amp. They are often located near the phono socket on a seperate PC board, but if not just follow the red wire to the main board. Chances are it will be an IC that's failed.
If it has a strong buzz at the back of the amp. Then I should replace the wire between the turntable and the amp. Or the right phono plug that connects to the amp.

Nov 13, 2010 | Pioneer PL-990 Turntable

1 Answer

My turntable connect to Carver Preamp, I bought a


If you can hear music with the volume up, but like it was turned down low (from the power amp), then yes there is something up with it. If it's the same on both left & right channels, then it's something common to both. For instance the power supply, or an IC that has both channels going in it.
If however the power amp does produce sound normally with another device, then either the turntable has a fault, or the pre-amp has, perhaps on the pre-amp inside it for the cartridge.

Dec 16, 2009 | Yamaha P-2500 Amplifier

3 Answers

Low volume through amp


you will probably need to buy a phono pre amp , i have a Dual 505 turntable that worked fine on my ROTEL amp but when i changed amps and went to NAD i had to buy a phono pre amp or else listen to really low sound . hope this helps

May 23, 2009 | Technics SL-1200MK2 Turntable

1 Answer

Sony PS-LX300USB Turntable, one channel not working


Have you tried swopping over the output leads from the turntable to the amp (normally one red and one white phono plug) so they are in each others socket? If you do this and you still get no sound from the right channel it is almost certain to be a faulty amp,or speaker.
If you swop and get no sound from the LEFT channel it is could be either a faulty lead or cartridge.

Apr 19, 2009 | Sony PS-LX250H Turntable

2 Answers

NAD 304 AMP...No Sound at all on both channels, Black marks on inner case.


This may be a silly question, but the pre-out/main-in jumpers are installed, yes?

Sep 25, 2008 | Audio Players & Recorders

1 Answer

Sound through one channel only.....NAD 310 Amplifier


If swapping of left and right input sources and left and right speakers does not help...you might have a bad channel in your amp.

Sep 24, 2008 | NAD Audio Players & Recorders

1 Answer

NAD T760


You should connect the RCA connectors from your turntable into the phono input of the preamp. Also, make sure you have the grounding wire from the TT connected to the grounding on the preamp (if you do not have a grounding point, then just connect it to one of the screws on the preamp). Then connect the output from the preamp to either the Tape or the CD points on the T760. On the front panel press tape monitor and you're done.

Check and let me know how it goes. My set up's working fine except for clarity, which still needs to be perfected. I'm using a normal step-up phono stage.

Regs/ Avinash

Mar 29, 2008 | NAD T760

Not finding what you are looking for?
NAD C372 Amplifier Logo

Related Topics:

366 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

The Knight
The Knight

Level 3 Expert

74459 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a NAD Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...