Question about Pioneer GM-X542 Car Audio Amplifier

1 Answer

SOUND CUTS OFF AT HIGH VOLUME AND POWER LIGHT FLASHED RED

HI...MY PROBLEM IS MY AMP WAS WORKING FINE AND STILL DOES AT VERY LOW VOLUME BUT WHEN YOU TURN IT UP THE SUBS CUT OFF AND THE POWER LIGHT FLASHES RED. PLEASE SOMEONE HELP ME AND TELL ME THE AMP ISN'T SHOT.

Posted by on

  • Anonymous Mar 30, 2009

    same as above

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

You need to check the DC voltage across the power and ground terminals of the amp. If the voltage drops below ~11v when the amp shuts off, you need to check the power/ground wiring and fuses.

If the voltage remains above 11 volts, you may have a problem with the load on the amp (incorrect ohm load, shorted speaker, shorted speaker wires...).

Posted on Jun 14, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When i turn my volume up to a certain point the power light on my amp will blink off and on and the subs will cut off...what could be some possible solutions? is the amp not suppose to be tuned up? it...


Sounds like you are showing too low of an impedance load to the amp. The E1200 is only stable as low as 2 ohms. If your subs are wired to show lower than a 2 ohm load then the amp will go into protection mode as the volume or gains are turned up

Dec 23, 2010 | Jl Audio E1200 Car Audio Amplifier

1 Answer

RED LIGHT FLASHING after local power cut in East London


I switched off the power, then I disconnected the lid from the base, put the power back on, the green light came on & then I reconnected the lid to the base & it has been working fine ever since

Aug 27, 2009 | Epson Perfection 4990 Flatbed Scanner

1 Answer

1000 w sony xplode works at low volume then red lights at volume5


Most likely one of your subs are blown, or the Ohm's are too low for the ampliphier. Try hooking up one speaker at a time to the amp and see if it does the same thing. If it shuts off on one of the two speakers, that speaker is most likely blown.

Apr 19, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Amp not functioning right


Check the wires for a lose connection or corrosion. You may need a capacitor.

Basically, at low power the amplifier is not asking for a lot of power from the electrical system to power your sub woofer. For lack of a better term and probably the best way to explain it is. It uses up all the power in the wires leading to it at a high volume, and has to wait for more. Kind of like when someone squeezes a garden hose2_bing.gif when your trying to use it. That would be the high volume, starving the amplifier. The capacitor stores power in it to power the amp at high volume. 2 farads would probably be bulletproof on a single amplifier system, but 1 farad should work well enough. Or seek help from an expert on exactly what size capacitor you should use. If you find yourself saying: My amp cuts out.

If this assisted in solving your problem, please take the time to rate it. Thank you.

Oct 08, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Speakers cut off when bass goes up...


sounds like you hava a load problem.if your'e running your woofers at 1ohm,make shure your amp is 1ohm stable.....

Jul 03, 2008 | Car Audio & Video

2 Answers

Sony xm-1652z 1000 watt amp


a loose or corroded connection can cause this problem...do not overlook possible loose fuse holder...also look into remote control line...also check speaker line for a loose or shorted connection...a loose connection in any of these locations can cause a spike in the current drawn from the power supply... a bad speaker can play at low volume but short at high volume; if the flex wires from frame to cone on the speaker start to fail, it happens at high volume first, and sounds like a crackle, and gradually becomes present at lower levels; a voice coil can warp at high signal levels, causing it to short intermittently, in addition, you might check the cooling capability of the amp...i don't recall whether you have a fan on this amp...

Jan 11, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

1200 watt legacy amp not working right


your amp its protect by releas of [powerout]one this releys is dead you mast chenche

Apr 14, 2007 | Pyle Dryver PLAD213 Car Audio Amplifier

6 Answers

Speakers cut off when bass goes up...


it might be that your wires from your amp to your subs are too thin. since they were relatively new the first three months, they were probably undamaged, but after pushing them too much, they probably have broken wires, and can't get enough power to the subs when turned up, i suggest getting thicker wires before investing in a capacitor, it could save you money.

Mar 21, 2007 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

279 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Audio & Video Experts

Michael Kovalik III
Michael Kovalik III

Level 2 Expert

117 Answers

The Knight
The Knight

Level 3 Expert

72650 Answers

yadayada
yadayada

Level 3 Expert

70374 Answers

Are you a Pioneer Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...