Question about Sony Grand WEGA KDF-60XBR950 60" Rear Projection HDTV

3 Answers

KDF-E60A20 I have a Sony Wega 60 Inch HDTV that I bought in 2005. Recently the screen started going blank while I am watching TV. The power green light in on but the TV looses the picture and sound. After about 20 seconds, it comes back on, and everything is fine. Any solutions? Thank you, blrodrigue@satx.rr.com

Posted by on

  • 4 more comments 
  • cynthiafesta Jul 07, 2008

    When starting to watch the t.v. The screen goes blank and in 30 seconds it comes back on? It goes off again moments later and the problem repeats itself?

  • tammymc Jul 16, 2008

    I have the same problem and this tv is less than a year old. I have already replaced a bulb at $200 ( although warranty probably would have covered that as it was within the first year.) I am very frustrated. I thought that the red light on the front was supposed to blink it if were the bulb. And how m any times do you have to replace a freakin bulb on a tv that originally cost over $3000? Dissappointed in Sony. I will be calling them tomorrow and maybe even going to Sam's to speak with management tomorrow.

  • Anonymous Sep 04, 2008

    I have the exact same problem. It goes off every few minutes, makes a buzzing sound and then comes back on. The green light never goes off.

  • Anonymous Sep 16, 2008

    I have the same exact problem. I have had this tv for about 15 months and the mother board went out two months after i bought it. Right now the picture and volume go off and on every soem odd seconds. I am desperate, please help! I wasn't clear on your solution how to do this?

  • Anonymous Oct 18, 2008

    Yes, I have the same problem! my TV is doing the same thing that everyone else is describing.

    allisonraiha@hotmail.com





  • Anonymous Oct 19, 2008

    this is allisonraiha@hotmail.com and I tried solution #2 AND THE RESULTS ARE IN----- IT WORKED!!!!!!!!!!!!!!!!!!!!!!!!!!!! $0.00 COST.

×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

My sony wega kdf-e60a20 had exactly the same problem 2mins on 2mins off no flashing red light just the normal green. I suspected a power supply problem. After some research I bought a new lamp for it (even though I was sceptical that this would work) It is extremely easy to change the only tool you need is an allen key wrench (for 1 of the 4 fasteners) Anyway it worked a charm and I realized my picture had been gradually dimming for some time. Haven't had a problem since and the picture is much brighter. Immediately before it started doing this it would just switch off briefly about once an hour. I bought a new lamp on ebay for $115.

Posted on Oct 23, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

It works!! First i took off the front panel. Just check your manual for instructions, very easy to do. If you do not have a manual just down load one from google.. The instruction are easy to follow. The screw they have you loosen with a alan wrench is attached to the plastic, so you do not have to worry about dropping it inside the tv. Removing the lamp was simple. once out you will notice on either side are two small mesh screens. One of mine was 80% blocked with dust, the other side was only 30-40% covered. I used a vacuum to remove the blockage, i did not want the dust and dirt to go inside the bulb. i then cleaned all around the lamp. Reinstalled, and we are go to go. The kids are happy and i am happier since my wife not be buying a new TV.
total cost of repair $.00
time required to fix, less than 15 minutes.

Also when my TV was loosing sound and picture and then return. I did turn off my TV, then turned on. I nothiced a red blinking light. Mine flashed 5 times. After some reserch, 5 times is video related, bulb or video board. google red flashing light with the model you have and you will find what all the codes mean.
So if yours is flashing 5 times try the above, it might work for you and it is well worth the time before you call a tech and drops hundreds of dollars.

hope this helps.

Posted on Oct 10, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 213 Answers

Do this for me turn off tv hit the follow hit this button display,5,vol down, power and till me the error code for this set this a have a
cpu in them ever time the led blink on front of set that mean thear is some pu with tv. so chech it and git back to me with code
thank you. bob..

Posted on Jun 12, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sony wega lcd tv blue dots


thats caused by the optical block which is very expensive to replace. Sony has had alot of issues with the blue dots on the screen its not worth repairing due to the high cost of the optical block

Feb 28, 2013 | Sony Grand WEGA KDF-60XS955 60" Rear...

1 Answer

I have a Sony WEGA KDF-E60A20 for 4-5 years. A few mintues after i turned it on, the screen goes blank with no sound. It comes back after 1-2 minutes. It goes blank again after 2-3 mintues. It just keeps...


It's the lamp. I do have an article on this in my Tips & Tricks regarding lamps, but replacing the lamp is a sure fix. I hope this was helpful, best wishes.

Apr 29, 2010 | Sony Grand WEGA KDF-60WF655 60" Rear...

2 Answers

My sony wega 60 inch tv will not turn on. The


I bought a new blub for it and the light still goes green then red.Anybody know?? mg

Sep 02, 2009 | Sony Grand WEGA KDF-60XS955 60" Rear...

2 Answers

Sony 60" Grand Wega has Picture go BLACK and NO SOUNDS!!!


My Sony Wega KDF-55XS955 55" was going on for 1-2 minutes then going black with no sound and after a few minutes would come back on. After reading all the posts and talking with a repair guy I replaced the bulb and that fixed the problem.

Aug 24, 2009 | Sony Grand WEGA KDF-55XS955 55" Rear...

1 Answer

50 inch Plasma problem


Most likely a capacitor in the power supply went out. otherwise it may be a bad relay if there happens to be one.
Most reason for a tv not turning on at all is bad power supply

Aug 01, 2009 | Sony Grand WEGA KDF-60WF655 60" Rear...

1 Answer

On off on off on off


possible cause is the thermal fuse for the light bulb which is the back of the tv, next to the cooling fan.

Dec 29, 2008 | Sony Grand WEGA KDF-60XBR950 60" Rear...

1 Answer

Sony 60 inch M.N. KDF -E60A20


the DIC board has gone bad. this is the exact symptom. it is expensive (200-400) and could be replaced by an technically apt person.

Aug 14, 2008 | Sony Grand WEGA KDF-60XS955 60" Rear...

1 Answer

60" Sony KDF-E60A20 - Red Light Blinks 6 times


The problem you have is a failed thermal sensor. Depending on how tech savvy you are you can replace it.They have changed the way the thermal sensor looks but it isnt too bad too put in. Any repair shop should also be able to do this for you.

Part number is 1-910-006-44 Themal Fuse Sony Part.

Feb 04, 2008 | Sony Grand WEGA KDF-60XBR950 60" Rear...

Not finding what you are looking for?
Sony Grand WEGA KDF-60XBR950 60" Rear Projection HDTV Logo

185 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Projection Televisions Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Ap12
Ap12

Level 2 Expert

103 Answers

Jason Harris
Jason Harris

Level 2 Expert

256 Answers

Are you a Sony Projection Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...