Question about Harley Davidson 426290 AM/FM Radio

1 Answer

Can you install a 2001 AM/FM Casett Deck off of a Classic onto a 2006 Electra Glide Standard

The plug seems to fit, the radio comes on all components work however no sound from speakers.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,224 Answers

Quite possible the speaker wires have gotten hot and melted make sure that speaker wires are connected properly and have not been scorched by the heat of engine

if the sollution can not be found the easiest thing to do is replace wiren for the speakers cause sometimes even in its sheath it can be bad wire

Posted on Jun 10, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What are the factory stereo specs for a 2007 electra glide classic?


Radio is a 4 channel 22 watts per channel 2 ohm stable unit. There are no pre-amp outputs, so be sure whatever amp you're using accepts high level inputs, or have pre-amps installed by Iron Cross Audio. When adding the amp, be sure the speakers used are impedance matched to the amp, not the radio.

Feb 02, 2013 | Harley Davidson 426290 AM/FM Radio

1 Answer

No sound from radio on 2001 electra glide classic


2001 was a Radio Sound unit.
Contact them at www.radiosound.com

Jun 27, 2012 | Harley Davidson 426290 AM/FM Radio

1 Answer

2007 electra glide classic blows the radio fuse replaced radio still blows fuse plays for a while


Most likely a 12v line to the radio is shorting either to the chassis or another line in the harness. Contact iron Cross Audio for pinout of the connector.

Aug 15, 2011 | Harley Davidson 426290 AM/FM Radio

1 Answer

I have a 2002 electra glide classic and the clutch side speaker stopped working. I purchased some hog tunes with an amp and it still does not work, but can hear music come out very softly when i disconnect...


The radio's internal amp is blown. You are still using the internal amp to supply the output to the Hog Tunes amp, so just installing an aftermarket amp will not solve the problem. The radio will need to be repaired.

Try these guys. www.radiosound.com

Dec 31, 2010 | Harley Davidson 426290 AM/FM Radio

1 Answer

Speakers cutting out


Vibration Damage to audio circuit. try Iron Cross Audio. www.ironcrossaudio.com

Apr 22, 2010 | Harley Davidson 426290 AM/FM Radio

Not finding what you are looking for?
Harley Davidson 426290 AM/FM Radio Logo

103 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Personal Radios Experts

Brian Mathews

Level 1 Expert

20 Answers

Jim Goldsmith
Jim Goldsmith

Level 3 Expert

1869 Answers

xxxxxx xxx

Level 3 Expert

4706 Answers

Are you a Harley Davidson Personal Radio Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...