Question about Electrolux Centralux Vacuum

2 Answers

Electrolux Centralux I have a Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor. If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times. Any suggestions?? Thanks, Bruce

Posted by on

  • Anonymous Mar 20, 2014

    Motor revs even tho unit turned off (but plugged into wall socket) whenever hose connection is swivelled to left or right.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

I dont know if you had your unit looked at yet but it sounds like the Power module is going. I repair the machines so I know some of the work.

Posted on Oct 03, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Legend:

    An expert who has written 200 answers of more than 400 characters.

  • Expert
  • 310 Answers

Http://geeksquad.fixya.com/ThreadView.aspx?prdid=113669&thid=657359
Electrolux Centralux
Posted by Brucebob on Jun 09, 2008
I have an Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor.
If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times.
Any suggestions? Thanks, Bruce


Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. You may have a bad inlet or household outlet; try all the inlets in the house too. But it sounds to me that your carbon brushes are dirty and need cleaning or replacing would be my 1st suggestion. Take a good wire brushes or pipe cleaner to clean the inside of the carbon brushes if they stick then replace them. So if the unit has only been used 20 to 30 times I would suggest some one to come and look @ it who did the install because it is still under a factory warranty and if you start messing with things you will void the factory warranty on the motor. And then if it is the motor for some reason then the factory or vendor will eat the cost of the repair. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://electrolux.com/ Customer Service 1-800-896-9756
Electrolux Home Care Products – North America
P.O. Box 3900 Peoria, IL 61612
Thanks, Don the Vac Man
Go Ahead. Use Us.

Posted on Jun 09, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When we plug in the hose the motor in garage runs but no air or suction comes out of the outlets. we cleared all the lines too.


Check to see if you have suction at the unit. If you have suction at the unit, your pipes are stopped up. If you don't have suction, you have a pipe loose under the house. Also you could just have a stopped up hose

Apr 29, 2010 | Electrolux Centralux Vacuum

1 Answer

Electrolux 1590 not turning on


TRY JUMPING THE CENTRAL VAC INLET WIRES AT WALL! IF COMES ON SOMETHING IS MISSING ON HOSE TO WALL CONNECTION. MOST HAVE A METAL RING TO ACTIVATE THE INLET DOOR WHEN HOSE IS CONNECTED.

Dec 12, 2009 | Electrolux Vacuums

1 Answer

My electrolux central vac clicks when I try to start but won't tu


It sounds like you have a bad motor. Motors can be replaced easily. You will need to know the model number. There are several companies online that sell replacement motors.

Aug 27, 2009 | Electrolux Centralux Vacuum

1 Answer

How to Reverse the hose at inlet on power unit on centralux E130A


That is the easiest way, just hold the attachment end of the hose into dirt inlet (preferably the one on the unit itself) and use your hands to try and seal the end as best you can.

Jun 25, 2009 | Electrolux Centralux Vacuum

1 Answer

Clogged Hose


Hi, this sounds like you have something stuck quite firmly in the hose!! If you use a good sturdy stick then you should be able to move the object without any damage to the hose. Check along the outside of the hose first just incase something has pushed its way out of the hose wall.
Get back to me.........

Jan 02, 2009 | Electrolux Centralux Vacuum

1 Answer

Non-working Electrolux Centralux vacuum system


Is there a small LED light illuminated where the low voltage wires connect to the main unit? There may be a small rubber boot covering the connection and the light. Just slide it back, and there should be a green LED light if the unit has power. If the LED is not on, there is no power to the unit (tripped breaker, plug came loose from electrical outlet, etc.) If LED is illuminated, short across the pins where the low voltage wires connect to the main unit. (These will be small 18-22 gauge wires, not the larger electrical cable!) You can do this with a coin. (Don't worry, it's just 24 volts and you won't even feel it) The unit should come on. If it doesn't, and you have light from the LED, then it's probably the relay on the board inside the unit, or the motor. Good Luck!

Nov 14, 2008 | Electrolux Centralux Vacuum

1 Answer

Electrolux Centralux Vacuum


If the light came on when you plugged it in, then you have power to the unit. You can take a coin and short across the two pins where the small, low voltage wires connect to the unit. Just remove the two wires, they should just pull off, and touch the two pins together with the coin. The unit should come on. If it doesn't, and the light is on, you may have a bad motor or a bad relay on the board inside the unit. Another thing to check is the filter. It has to be installed properly or the unit will not run. The top of the filter depresses a switch so that the unit cannot be operated without a filter in place. Good Luck!

Jul 20, 2008 | Electrolux Centralux Vacuum

Not finding what you are looking for?
Electrolux Centralux Vacuum Logo

Related Topics:

244 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Roger Potts

Level 3 Expert

694 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18304 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...