Question about Dual 2-Channel Bridgeable MOSFET Amplifier (XPA4100) Car Audio Amplifier

1 Answer

Dual xpa 4100 2/3/4 chanel amp

Turnes on but as soon as subs are conected led turnes red also turnes red when rca cabels are pluged

Posted by on

  • skippy591 Jan 04, 2009

    Xpa 4100 amp. Goes into protection mode as soon as powered up. If i turn the head unit on\off 5 or more times,sometimes it stays on,say for a 5 hour road trip and at 50% plus volume. Then when turned off it does the same. Goes back to protection mode. I tried every possible wiring . Full mode, LPF mode(sub) ,HPF mode, impedence is within range, etc...Even now with no speakers when powered up the led flashes back green/red then stays in protection mode. I even called the tech line and he said it sounded like a ground loop problem. I dont have a buzzing noise. I bought a kenwood amp wired it in to existing wiring and it works.Problem is Not my wiring. the techline guy said the amp could not be operated as powering a sub and full range speakers at the same time. I was mistaken I guess when I read the 2/3/4 on the box for operating modes. Other wise I would have not bought it. I may take it to a repair shop because when it worked it sounded great and had a good range of adjustment.

  • Anonymous May 12, 2009

    I too have the same problem, bought a brand new XPA 4100 amp and it blows fuses as soon as I turn it on. Was told the same, that there is a gound issue. Now I have a brand new $120 amp that's junk.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 3 Answers

Make sure power and ground are where they are suppose to be and speaker wires are not mixed up. but it sounds to me like the amp is junk

Posted on Jun 11, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi there, i have a orion cobalt 2105xp 400. i have hooked all up, but very little bass. i have 1 10" boston acoustic sub. i noticed that the led is constant red, is it supposed to be green, crossover...


amp is in protect mode. check your wiring and make sure your sub is wired properly for ohms. dual 4 ohm in parallel = 2ohm. dual 4 in series is 8 ohms. dual 2 ohm parallel= 0.5 ohms and in series 4 ohms. check ground and power wires. make sure sub isnt blown. a blown sub WILL cause this on any amp.

Sep 10, 2011 | Orion Cobalt 2105 XP Car Audio Amplifier

1 Answer

My mtx thunder 421d I just got has the red light staying on all the time, I have hooked up a rca converter and the amp wont play my sub, is that light supposed to be red all the time.


The LED should be red. If you are not getting power to the sub, make sure the speakers are connected properly to the amp. Also make sure that the gain control is turned up. If it is all the way down, you will not hear anything from the sub(s). If none of that works, it is possible that you have a blown sub. If you smell a burnt smell near the speaker magnet, there is damage to the voice coil in the sub.

Feb 25, 2011 | MTX Thunder 421D Car Audio Amplifier

2 Answers

I hooked my Hifonics BXi 1610 Brutus series amplifier up to my 2 12" Kicker Solo Baric L7 subs. Everything turns on on the amp but its barely pushing my subs. Ive tried tuning it and it still doesn't push...


wire the subs if thair dual 4 ohm . in parallel. red to red and black to black. giving it a 2ohm load. do the other sub the same. and conect it on the amp . turn your gain about 12oclock and db level less than 12oclock and your frequnecy around 80-100. and that should work

Feb 18, 2010 | Hifonics BXi1608D Car Amp

1 Answer

Amp turns on but no sound from subs? everything is connected to thier proper slots. What could it be?


Check to see if your deck has a sub on/off option in the menu or settings if it don't you may have blown amp chanells or bad RCA preouts on deck or bad RCA in on amp

Feb 18, 2010 | Kenwood KAC-7201 Car Audio Amplifier

1 Answer

Car system


if you have dual voice coils connect on each seporate sub negative left channel to possative right channel of the subwoofer same to other sub then conect the left possative and the right neggative to your box power terminal same to other sub then conect the two sub outs on your box left speaker positive to your positive left channel bridge then conect left speaker negative to the right speaker possative then connect your right speaker negative to your right channel negative brigdeg to your amp is single coil hook the box its self up the same way to your amp i have two dual voice cooil 12" hooked up to the same amp that way and it rocks without the power protecter turning on

Nov 09, 2008 | Pyle PLA2200 Car Audio Amplifier

1 Answer

Audiobahn A 18001DT


the remote of amp. is not a ground it is a pos.+ 12 vlts look the back of your car stereo red the remote and conect to remote of the amp. if no sign remote of the car stereo conect to the 12 vlts of your bat.

Sep 18, 2007 | MTX Thunder 8302 Car Audio Amplifier

1 Answer

Power light


This could be a DC offset condition. Check you manual for what this means. Or other condition. First Disconnect the Subs and try it. If it still goes red then disconnect the RCA's and try it again. If the Led continues to go red after the click then the Amp is hosed. The Click you hear is an internal relay that cuts the subs in after a dely so you do not get the turn on THUMP of the radio at your subs.

Jul 08, 2007 | Hifonics Titan TX 8805 Multi-Channel Amp...

2 Answers

Amplifier does not turn on anymore.


look fix of conection line blak of cabel ithes+

Apr 20, 2007 | Power Acoustik TS980-2 2 Channel 980W...

4 Answers

Amp Will Not Stop Overheating


You say you have 2 p312d2 subs. Ok so the d2 stands for dual 2homs (2 X 2homs voice coils per sub) , conecting in parallel the 2 voice coils of only one sub will create 1hom load to the amp, and if your amp is 2homs stable per chanel that means you are lowering too much your homs causing the overhwating to it.

Sep 25, 2006 | Ultra Linear UL-2200D Car Audio Amplifier

Not finding what you are looking for?
Dual 2-Channel Bridgeable MOSFET Amplifier (XPA4100) Car Audio Amplifier Logo

Related Topics:

944 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dual Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4724 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Dual Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...