Question about Dual 2-Channel Bridgeable MOSFET Amplifier (XPA4100) Car Audio Amplifier

1 Answer

Dual xpa 4100 2/3/4 chanel amp

Turnes on but as soon as subs are conected led turnes red also turnes red when rca cabels are pluged

Posted by on

  • skippy591 Jan 04, 2009

    Xpa 4100 amp. Goes into protection mode as soon as powered up. If i turn the head unit on\off 5 or more times,sometimes it stays on,say for a 5 hour road trip and at 50% plus volume. Then when turned off it does the same. Goes back to protection mode. I tried every possible wiring . Full mode, LPF mode(sub) ,HPF mode, impedence is within range, etc...Even now with no speakers when powered up the led flashes back green/red then stays in protection mode. I even called the tech line and he said it sounded like a ground loop problem. I dont have a buzzing noise. I bought a kenwood amp wired it in to existing wiring and it works.Problem is Not my wiring. the techline guy said the amp could not be operated as powering a sub and full range speakers at the same time. I was mistaken I guess when I read the 2/3/4 on the box for operating modes. Other wise I would have not bought it. I may take it to a repair shop because when it worked it sounded great and had a good range of adjustment.

  • Anonymous May 12, 2009

    I too have the same problem, bought a brand new XPA 4100 amp and it blows fuses as soon as I turn it on. Was told the same, that there is a gound issue. Now I have a brand new $120 amp that's junk.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 3 Answers

Make sure power and ground are where they are suppose to be and speaker wires are not mixed up. but it sounds to me like the amp is junk

Posted on Jun 11, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I conected my sub wrong and the unit shut down , I reconected my sub and everything seems to work fine , should I send it in for servicing?


If i'm right, the system powers down as a safety precaution. It prevented itself that it will breakdown. It's your choice but I recon you can just enjoy and listen to your favourite music.

Apr 26, 2014 | Harman Kardon AVR 7000

1 Answer

I have a ts-w307d4 pioneer sub woofer and its a 4 ohm sub that has 4 terminals on it 2 red and 2 black how do i wire this sub to my amp i have a sony 1200 watts stereo amp and my sub is a dual voice coil...


conect one of the positive terminal from the sub directli to one chanel of the amp, and do the same with the negative,and do the same with the others terminals from the sub conect to the other chanel

Aug 12, 2010 | Pioneer TS-W307D4 Car Subwoofer

2 Answers

I hooked my Hifonics BXi 1610 Brutus series amplifier up to my 2 12" Kicker Solo Baric L7 subs. Everything turns on on the amp but its barely pushing my subs. Ive tried tuning it and it still doesn't push...


wire the subs if thair dual 4 ohm . in parallel. red to red and black to black. giving it a 2ohm load. do the other sub the same. and conect it on the amp . turn your gain about 12oclock and db level less than 12oclock and your frequnecy around 80-100. and that should work

Feb 18, 2010 | Hifonics BXi1608D Car Amp

1 Answer

Amp turns on but no sound from subs? everything is connected to thier proper slots. What could it be?


Check to see if your deck has a sub on/off option in the menu or settings if it don't you may have blown amp chanells or bad RCA preouts on deck or bad RCA in on amp

Feb 18, 2010 | Kenwood KAC-7201 Car Audio Amplifier

1 Answer

THERE IS NOT 2 RCA HOOK UPS FOR THE SUBS HOW KAN I HOOK UP MY AMP SO MY 2 12S WILL HIT


If there's only a single sub-out RCA cable, you have two options. The amp may have a manual switch that puts it in Mono mode, in which case you only use 1 of the 2 RCA jacks. The other option is to go get an RCA splitter. This will take your single sub-out cable and feed the exact same signal to both left/right of your amp. Either way, you get the same result. If the 1200W amp is for your sub(s) only, you should set the high-pass filter and subsonic filters to help your bass "hit harder" and cleaner.

May 17, 2009 | Dual XDVD8182 Car DVD Player

1 Answer

Hook up my 2 sub and my 2 amp


wire the subs at 2 ohm each. red to red and black to black and then to the amp. if thay are a dual 4 ohm sub. dual 2 ohms will need to be wired red to black on one coil and the other conected to the amp.

Apr 09, 2009 | Danby DDR601 Dehumidifier

1 Answer

Dual SBX554


POWR TO BATTERY FOR WHAT?DOES THE SPEAKERS HAVE AN AMPLIFIER? NEW RADIO? SPEAKERS ALONE ARE NOT CONNECTED TO BATTERY ,UNLESS THEY ARE POWERED SPEAKERS,USALLY SUB-WOOFERS HAVE THEIR OWN AMP.iF YOU ARE CONNECTING A AMPLIFIER START WITH A FUSE SAME SIZE AS THE AMP,CONECT 1ST TO THE BATTERYTHE TO THE FUSE RUN A SIFICIANT GAUGE POWER CABLE TO THE AMP.GET THE GOUND FROM A PART OF THE CHASSIS CLOSE TO THE AMP,ALSO SAME SIZE OR LAGER GAUGE WIRE.THEN YOU HAVE TO RUN A REMOTE SWICH WIRE FROM THE BACK OF THE RADIO TO THE AMP.iF RADIO DONT HAVE REMOTE ,CUT INTO THE POWER ANTENNA WIRE .RUIN YOU RCA CABLES TO THE AMP AND WIRE YOU R SPEAKERSMbUT FIRST DISCONNECT YOUR GROUND FROM THE BATERY MOST IMPORTANT.ANY '?'S.WRITE BACK RATING PLEAse.

Oct 26, 2007 | JC Whitney - Dual Blue Led Speakers Car...

2 Answers

Amplifier does not turn on anymore.


look fix of conection line blak of cabel ithes+

Apr 20, 2007 | Power Acoustik TS980-2 2 Channel 980W...

Not finding what you are looking for?
Dual 2-Channel Bridgeable MOSFET Amplifier (XPA4100) Car Audio Amplifier Logo

Related Topics:

947 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dual Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Neville Ward

Level 1 Expert

6 Answers

Are you a Dual Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...