Question about Harley Davidson Harley-Davidson Motorcycle Desktop Telephone

1 Answer

2002 FLTR Radio Problem

My battery on my 2002 Harley Davidson Road Glide went dead over the winter. I jump started it at 40 amps and when it started the radio/cassette player does not work and the speakers have a hum in them. I replaced the battery with a new one, but the radio still only turns on and lights up but it will not play, and still the hum in the speakers. Any suggestions?

Posted by on

  • fltri Feb 24, 2009

    I did the same thing and got the same result,a hum in my speakers. What was the cure? Mine is a 2000 road glide.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

Sounds like you may have blown one of the radio fuses. Don't know about that radio but usually there is one fuse red wire for the key hot and one fuse for the radio memory yellow wire and one of em is blown. I don't know if there are security codes for those radios or not if both of the fuses are good. Dont know if it will be a main radio fuse just in the main fusebox or block or if there is another or other fused in the fairing.

Posted on Jun 11, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Put new battery in ran good went to start again and battery dead


Check your charging system. Check for electrical drains if the lights don't even come on.

Mar 21, 2012 | Harley Davidson Harley-Davidson Motorcycle...

1 Answer

I went to start my 1997 HD FLSTC. It turned over


ignition switch common for your bike less expensive aftermarket but do make sure to solder in new connector at the same time

Sep 20, 2009 | Harley Davidson Harley-Davidson Motorcycle...

1 Answer

I start my sporty every few weeks in the winter just to make sure all is well with the bike, but the last time i started the bike i let it idle for a while and get good and warm i shut it off so that i...


Start by checking the battery. Turning on yer bike and letting it idle is gonna drain the battery over time. Check the charge with a voltmeter. Should be at 12.5 Amps at least. If it is, I'd check the battery cables next for good tight clean connections ( if u dont have one - get a charger)
If that dont do it - get back with me - I got more

Feb 18, 2009 | Harley Davidson Harley-Davidson Motorcycle...

1 Answer

Radio & horn 04 Road Glide


Generally these aren't on the same circuit. There is an inline fuse for the radio, it's located in the power wire for the radio. The horn shouldn't have a fuse, so I'm going to say check the button on the controls.

Aug 18, 2008 | Harley Davidson Harley-Davidson Motorcycle...

1 Answer

Axil torque for a 2007 roadglide


On the front, 35-40 ft lbs, be sure to use a blue lock tight or lock washer. On the rear, tighten the rear axle nut snug to where the cotter pin can easily go through the axle and slots on the nut.

Aug 12, 2008 | Harley Davidson Harley-Davidson Motorcycle...

1 Answer

Motorcycle wont start


Check the battery connections, especially if you hear a click just before it goes dead. I know that on my bike, when this happens, the screws that hold the battery cables in place have backed out and not getting a good contact. You would think that with a bad contact that it would stay dead when you turn the key off then back on, but oddly, everything comes back on normally until I hit the starter button. Check the cables.

Aug 05, 2008 | Harley Davidson Harley-Davidson Motorcycle...

1 Answer

1200 Sportstart won't start, just clicks.


Sounds like something is hanging or froze up or the starter/solenoid contacts need to be cleaned or the battery cable connections at the frame ground and starter are either loose or corroded and need to be cleaned or maybe a wiring harness plug has corroded over the winter and needs to be cleaned.

Jun 11, 2008 | Harley Davidson Harley-Davidson Motorcycle...

2 Answers

2000 harley heritage classic electical problem


sounds like no voltage from the charging system. check for poor connections especially ground check output from alternator and check regulator thats all there is to it

Apr 26, 2008 | Harley Davidson Harley-Davidson Motorcycle...

Not finding what you are looking for?
Phones Logo

269 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Phones Experts

kakima

Level 3 Expert

96417 Answers

Brian Mathews

Level 1 Expert

20 Answers

Brudog1

Level 1 Expert

35 Answers

Are you a Harley Davidson Phone Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...