Question about Logitech Z-2300 Computer Speakers

3 Answers

No power in the system

Hi everybody,
suddenly I get no power inside my speaker system; the light in the remote control unit is off, and I can't hear any sound from the satellites or the subwoofer.
Tried to replace the fuse (it says 2A 250V), but no changes.
Any idea?
Thanks!

Posted by on

  • 1 more comment 
  • Anonymous Jun 14, 2008

    checked:
    all plugs inserted and secured - OK
    all power to the unit - OK
    did not checked fuse




  • Anonymous Oct 14, 2008

    I had the same problem. The control pod failed. Called Logitech and they issued an RMA. I returned the failed control wiring and they sent me a new one.

    Problem solved, but I was without my speakers for 2 weeks and I had to pay for return shipping.


  • Anonymous Dec 15, 2008

    Worked great, then all of a sudden, no power or blue light from the control box.



×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had the same problem. The control pod failed. Called Logitech and they issued an RMA. I returned the failed control wiring and they sent me a new one.

Problem solved, but I was without my speakers for 2 weeks and I had to pay for return shipping.

Posted on Oct 14, 2008

There is a power switch on the back of the woofer. The manual doesn't identify the switch nor which position is on.

Posted on Aug 29, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 291 Answers

Did you have to replace the fuse? Was it opened? Sometimes there is a THERMOfuse INSIDE the transformer [xfmr].Before it blows because of too much heat ,it may blow the 2a 250v external fuse.You must check the power supply [the circut attached to the fuse] input should be 120 a/c in and around [+] or [-] 12 v thru 15 v DC output. Look for filter capacitors & resistors that look like tiny cement blocks(they are thermo type fuse resistors) BE KILEFULL !!! (CAREFUL) the voltages are low but the current could be high. Could stop your heart!!

Posted on Jun 11, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

DAIKIN Aircon Multi Unit - One head unit not working, others are fine. No lights or response


Check for power at unit . If there is power to unit check for blown fuse on circuit board or bad board .

Nov 11, 2014 | Heating & Cooling

1 Answer

Kenwood VR 605 power light flashes


CHECK FOR CLEARED COOLING VENTS & FOR PROPERLY WORKING COOLING FANS. THIS WILL CAUSE SHUTDOWN OF THE UNIT. IF ITS ALL CLEAR, YOU PROBABLY HAVE A POWER SUPPLY ISSUE.

Dec 10, 2013 | Kenwood VR-605 Receiver

2 Answers

Denon receiver problems


Check sound from headphones. These models have been known to have bad headphone jacks that make the unit think there are headphones plugged in even when there isn't. Sometimes just plugging in headphones and unplugging them will fix it for a while.

Apr 26, 2013 | Denon AVR-689 7.1 Channel Home Theater AV...

1 Answer

Logitech Z5500 5.1 speaker system Hi, Any suggestions on how to troubleshoot this problem? there is no sound coming from the subwoofer or the speakers, but when I connect my mp3 player to the pod...


Try pulling the power from the unit for a few minutes, the reconnect. Make sure you've got the surround settings correct. If that doesn't do it, you've likely popped the amp or the amp's power supply in the sub box.

Jun 16, 2011 | Logitech Z-5500 Computer Speakers

1 Answer

No sound from creative t3030 2.1 speakers


the circuit board and amplifacation supply inside the sub are blow or shorted out.thus preventing any sound. the head phone jack works only because it is a bypass feature supported by the actual computer not the surround sound unit

Jul 23, 2009 | GE Ultrasonic 2.1 Subwoofer Computer...

1 Answer

My volume control was working perfectly fine and i could hear the sound perfectly then the green light on my "logitech" volume control turned off so sudden.I checked the cable's seems like everythings in...


inside the sub theres a small computer chip board. unfortunately with jbl this board shorts out very frequently. short of a disassibly process and seeing a burnt spot on the board, the only other chance may be the power pack wich can be replaced with a 20.00 one from walmart

Jul 12, 2009 | JBL CREATUREIIWHITE Computer Speakers

1 Answer

I lost my remot control and the manual


you can purchase this items thru phone calling jvc directly 1-800-252-5722 or on there website jvc.com. the remote will cost $27.01 and the manual $6.18 plus tax and shipping. you can pay with visa or mastercard. if you hear sound thru 2 speakers there's a surround button on remote that can get the rest of speakers working. or you will need to check speaker connection and set unit to right surround setting by pressing surround button.

Nov 17, 2008 | JVC THD-50 System

1 Answer

Won't power up


Hi, The owners manual says that if the red light is flashing, it is an indicator that it is ready to be turned on (use remote or onboard on button); flashing red & green - too high temperature inside, the unit is overheated. Check and clean the air filters; If the red light is steady, abnormal condition and you have to call for service. A copy of your manual is available at http://www.eiki.com/resources/resourcedownload.ashx?filename=/ownersmanuals/om_xb25_20_sb20.pdf Hope this be of some help. Pls post again how things turn up. good luck and kind regards.

Jul 31, 2007 | Eiki LC-SB20 Projector Multimedia...

2 Answers

Speakers


Hello Norticbeat, Here are some simple steps to diagnose the problem. Disconnect the subwoofer from the main unit. You will have those wires in your hands. Now connect a 1.5V battery (like ones in remote controls) to these wires. Polarity doesn't count. You should hear some sounds from your subwoofer. This will indicate that the speaker inside is working and isn't burned out or something. If it works the problem is either with your main unit or with the connection with it. Check the connector to see if it is in good form, connect only the left subwoofer and try to close your ear to it to see if you hear anything when you power on the unit, play music, power off or these kind of operations. If you hear some distorded noise or something you could have a burned out left power amplifier inside the main unit. First of all try to do those 2 checks and please post back your results. I will guide you through the next part. Good luck

Apr 03, 2007 | JVC HXZ10 480 Watt 5 CD Shelf System MP3...

Not finding what you are looking for?
Logitech Z-2300 Computer Speakers Logo

293 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

sonic boom...
sonic boom...

Level 3 Expert

1557 Answers

Paul

Level 2 Expert

223 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...