Question about Car Audio & Video

2 Answers

Sony car amp

The overcurrent light has come on no sound is it an internal short? what is overcurrent

Posted by on

2 Answers

Trash it

Posted on Jul 13, 2008


  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,550 Answers

Everytime the overcurrent light is on,the audio amplifiers IC's are in bad conditions

Posted on Jun 05, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My phoenix gold x200.4 amp turns on but the protect light keep on flashing


  • What does it mean when the LEDs flash on my amplifier?
    With most recently produced Phoenix Gold amplifiers, a flashing/blinking LED is an indication that the unit is in protect mode, usually due to an overcurrent condition caused by an internal short, external short (speakers), or low impedance. Overheating will also cause the amplifier to shut down temporarily.

    If amplifier remains in protect mode, power down the amplifier, disconnect the speakers, and power up again. If LEDs continue to flash, there is probably an internal problem with the amplifier that will require service attention to fix.
  • Sep 23, 2010 | Phoenix Gold ZX600ti Car Audio Amplifier

    1 Answer

    Overcurrent lights comes on whenever my amp is on


    this can only mean 2 things, either your over working the amp, which means your amp is trying to push power that it don't have, and it's getting hot which is known as thermal mode. and the other reason can be that make sure amp rms. matches the rms. of your subs.

    Mar 13, 2010 | Sony XM-2150GSX Car Audio Amplifier

    1 Answer

    Its on over current


    when the overcurrent light lights up, this means the amp is being run too hard or too loud. try cutting the gain back a little. i always hated putting in the sony amps that had those lights on it. it seems that when you turn it up and get it sounding good the light comes on.... if the overcurrent light is on all the time and it doesnt make sund....the amp could be bad. good luck.

    Dec 17, 2009 | Sony XM-754SX Car Audio Amplifier

    1 Answer

    Amplifier keeps running overcurrent


    sounds to me like you are overheating the amp, try down tuning the peak level of the amp, and also if there is anything around the amp clear it away, check if the fan is turning on, you may need to replace it,

    May 20, 2009 | Sony XM-2150GSX Car Audio Amplifier

    1 Answer

    Sony Xplod Amp


    well you might want to try using 30 amp atc fuses instead of 10 amp fuses on your amp, because you are getting an overcurrent from your alternator then from your battery. I have the same amp and you will find that your subbs will hit better too. also check on your ground wire from your amp as this also will cause the RED light to come on. :)

    Mar 24, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

    3 Answers

    Overcurrent protector


    The woofer or the wiring may be shorted. Remove the speaker wires from the terminals of the amp and power up the amp. If it powers up, check the wiring and the speaker. If it still goes into protect, the amp may be defective. A short in the wiring or speaker can damage a brand new amp.

    Dec 17, 2007 | Sony XM-1600GSD Car Audio Amplifier

    1 Answer

    My amp


    It sounds like the amplifier has shorted output transistors. The clip indicator may be on because the output is equal to the rail voltage. The amp is probably going into overcurrent protection when the drive circuit engages. The amp will have to be repaired. If I'm not mistaken, this amp uses the dlogixs modules. Since the modules are not readily available, you may have to send it to an authorized service center or back to LA sound.

    Nov 15, 2007 | L.A. Sound T475 Car Audio Amplifier

    2 Answers

    Amp overcurrent problem


    Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down (overcurrent), the amp likely has blown output transistors.

    Sep 20, 2006 | Sony XM-2150GSX Car Audio Amplifier

    Not finding what you are looking for?
    Car Audio & Video Logo

    Related Topics:

    418 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Car Audio & Video Experts

    xxxxxx xxx

    Level 3 Expert

    4807 Answers

    yadayada
    yadayada

    Level 3 Expert

    70387 Answers

    The Knight
    The Knight

    Level 3 Expert

    72670 Answers

    Are you a Car Audio and Video Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...