Question about Jl Audio 1000/1 Car Audio Amplifier

1 Answer

Low ohm p/l

How can i fix this it`s sounds good but it cut off after of to much bass help! and the low ohm light is flashing ...

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 71 Answers

Quick primer here... Impedance drops with frequency,
you might have the amp loaded at what seems a rated spec.
However if your bassing too hard the voice coil can leave the gap (magnetic Field) and drop your impedance far enough to activate the protect circuit. This usually occurs in a bridged amp.
You can always give JL ( John and Larry actually) a call.They are a outstanding Company to deal with.
Is Maynard still with them ???
Sumthin

Posted on Jun 11, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Low ohms light flashes and bass distorts at high volume


Sounds like you need to invest in a capacitor. Those are used when subs receive a bass spike. You just a need a 1 Farat Capacitor (1,000 watts) ran between the head unit and the amplfiier to fix your issue. Also, try reducing the volume gain to half gain and low pass frequency to half gain; this will increase your clarity and make your amp less hot. This may fix it without a capacitor. Also find out what amprage your alternator is. Your alternator may not be designed to run the amplifier. Most alternators are 200 amps now if they are gold plated.

Hope this helps

http://www.onlinecarstereo.com/CarAudio/ProductDetail.aspx?ProductID=20378

Feb 10, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

When the bass cut on the speakers cut off


220 watts RMS x 1 at 4 ohms (400 watts RMS x 1 at 2 ohms)
the amplifier may be over-driven. are there red protection lights coming on the front panel? Or a loose wire - power, ground, or speaker.

Dec 18, 2008 | Alpine MRP-M450 Car Audio Amplifier

1 Answer

500/1 amp turns on, but small ugly bass comes out speakers


Heat sink is jacked!!! Burned it out. Replace it or send it away to get fixed.... check the pricin on it sometimes cost alot almost as much as new amp....

Nov 04, 2008 | Jl Audio 500/1 Car Audio Amplifier

2 Answers

JL 300/2 v2 Power Light Blinks, No sound out of Sub. Works in friends Car HELP


Are you sure you don't have any shorted wiring or defective speakers?


Sep 30, 2008 | Jl Audio 300/2 Car Audio Amplifier

1 Answer

V12 MRV-1507 or Xplod? Amplifier - XM-ZR1252 good quality sound


Alpine is just a better brand in general. I have the older MRV-1507, sounds GREAT, i have had friends who has had the Explode line, but it was always a temporary system until they got something better, like the alpine or kenwood.

Aug 14, 2008 | Car Audio & Video

1 Answer

Protection Circuit


Yes, always a good idea to use a wire wheel and drill to get a super clean place for your ground. That was going to be the first thing I suggest. I would use a meter and see how many ohms the subs are at right now. It may be two low and there is too much current demanded form the amp at once. for a good sub wiring guide, go to
http://www.crutchfield.com/learningcenter/car/subwoofers_wiring.html
Don't forget to leave feedback.

Jan 23, 2008 | Kenwood KAC-8103D Car Audio Amplifier

1 Answer

Crate BT50 Bass amp cutting out with high input.


Sometimes an amplifier's preamp can't handle certain signals/frequencies at a high gain, so they cut out. Bass guitars are especially prone to giving such a strong signal.
I bought an older, nonworking bass amp recently and fixed it just to find it had the same problem. Best solution is to put a low ohm resistor at the amps input, but if you turn your guitar down to half volume it'll have the same effect: should prevent it from cutting out.

Nov 01, 2007 | Crate SPA1600 Power Amplifier - SPA Series...

2 Answers

Protection light


You cannot parallel two subs AND run them on the Bridge. You must have at LEAST a 4 ohm load on the bridge, and 2 4 ohm subs in parallel equals TWO OHMS. BAD!!! Move each sub to it's own channel or your amp will soon fry.

Sep 10, 2007 | Sony XM-2002GTR Car Audio Amplifier

1 Answer

Amp on but no bass


1st make sure the speakers are not bad, check th eimpedance with a multimeter, the voice ciols should read 3.9 to 4.3 ohm's. if any of your subs are below this most likly the subs are bad. if they are ok make sure the ground for the amp is good. now the last thing is the amp. try another pair of speakers, even if it's smaller ones, just make sure they are 4 ohm speakers, keep the vol. very low during your test. if the other speakers do not work then have your amp serviced or replaced. good luck

Dec 19, 2006 | Kenwood KAC-8101D Car Audio Amplifier

Not finding what you are looking for?
Jl Audio 1000/1 Car Audio Amplifier Logo

Related Topics:

145 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Alan Desotell
Alan Desotell

Level 1 Expert

17 Answers

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...