Question about Digital Cameras

1 Answer

RE-350 Visualizer lights will not turn on. Lights are good. This is the second unit to have this problem. What is the problem? Can I correct it locally?

Posted by on

  • Anonymous Sep 25, 2008

    The white balance light is flashing, and when I push the light on button, or the back light button there is no response. The camera is working but will not let me change the focus on the wide or tele. None of the buttons will respond, but the camera is putting out a picture on a TV. What can I do to fix this issue.

    THANK YOU GEORGE

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have an Canon RE350 visualizer, and the camera will put out a nice picture to a TV but I can not get any other response from the light, or back light. Can not adjust an of the settings, white balance stays flashing. What to do to fix this error??

THANKX puddingeorge

Posted on Sep 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi, I droped my SP-320 yesterday and now i can't turn it on. The red and green light is flashing. What does the flashing lights means? Joe


I have the same problem with flashing red and green light when I tried to turn on my Olympus SP-350.

I don't know what's wrong, so please let me know if you have any clue. I personally did not drop the cam, but someone else might and did not tell me :(

May 25, 2011 | Olympus SP-350 Digital Camera

1 Answer

After getting an update for my camera the only thing that turns on are the red and green lights next to the power button whats wrong with it? it's a olympus sp 350


No I did not fix my camera problems.
I haven't got the extra cash to pay for an answer for the problem, so I guess it'll just sit and collect dust.
I'm in shock that I came to Olympus for help and they want to charge us for help when their products go wrong.
Vicky Wunner

Jan 07, 2010 | Olympus SP-350 Digital Camera

1 Answer

Hi my D90 viewfinder problems


I believe what you want to do is drop the unit from the same height but on the opposite side. This will equalize the damagednessotometer rating on your cameras bios drop detector settings review for imfullofshit sectors 123 &445.

Sep 24, 2009 | Nikon DSLR D90 Digital Camera

1 Answer

Harging problems


use canned air to blow out connections on camera and dock.
this problem is due to bad connection

Apr 23, 2009 | Kodak EasyShare Z760 Digital Camera

1 Answer

Place my camera on the charging unit and it starts to charge by indication of the green lights and then in second the lights turn red and it stops charging. I have purchsed a new battery and the same thing...


Hi,

Run the battery all the way down until completely dead and then try recharging. Nickel metal hydride (NiMH) batteries don't develop a "memory" quite like the old nickel cadmium (Ni Cad) batteries

OR

Try taking out the memory card. I had the same problem, but for some reason I had the memory card out and the green lights returned and my camera charges correctly now

OR

Had the same problem, and like mahav said, it was an issue with how my battery was arranged in the camera itself. Adjust the battery, and hopefullyy that will work.

OR

This happened to me. The cause was the battery did not fit into the case, This led to poor connection of the battery. After I fixed the loose battery , it worked perfectly till today.

Thanks

Have a nice day.

Apr 23, 2009 | Kodak EasyShare Z760 Digital Camera

1 Answer

Problems with camera


Hi everyone,

I found you because 10 minutes ago, my camera exhibited the same behavior as all yours. All of a sudden, the red and green lights started blinking on and off and nothing worked. I just tried switching batteries and the camera is working! I am using a couple of RCR-V3 Li-ion rechargeable batteries, which I purchased on Ebay three months ago. Thought I'd pass it on.

Take care,

Rosane.

Jul 17, 2008 | Olympus SP-350 Digital Camera

1 Answer

Problems turning on OlympusSP-350


Hi. Mine did the same thing one day. I took the memory card and batteries out and let it sit for a few minutes. I then replaced the batteries, but it said, "batteries empty." I then replaced the batteries with silver and blue energizers. It powered right up. I was afraid it was a gonner, but it's been fine since.

Mar 15, 2008 | Olympus SP-350 Digital Camera

1 Answer

Olympus sp 350


Are you sure you finalized the firmware upgrade procedure according to the instructions? This sounds a little like you pulled the plug a little too soon... Have you done it according to these instructions: http://www.olympusamerica.com/cpg_section/OMfirm.asp And kept the camera connected until the update was 100 % complete? If you did everything right, try reseting the camera - take the batteries out for the day, and see if it helps. if you're back to step one(the reason you did the upgrade), try the firmware upgrade again. If still it doesn't work contact olympus, and I hope you have a valid warranty. Good luck

Jun 22, 2006 | Olympus SP-350 Digital Camera

Not finding what you are looking for?
Digital Cameras Logo

Related Topics:

64 people viewed this question

Ask a Question

Usually answered in minutes!

Top Digital Cameras Experts

kakima

Level 3 Expert

96396 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Steve

Level 3 Expert

3287 Answers

Are you a Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...