Question about Crate SPA1600 Power Amplifier - SPA Series Car Audio Amplifier

1 Answer

Crate Guitar Amp G120 cxl not outputting sound ... What troubleshooting steps should i take before purchasing new module?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had a Crate G120C XL COmbo amp that was only outputting very quietly. I checked all pots. They were operating as they should be. I checked the speakers outs, the footswitch and its connections and both guitar inputs ..all operational. Problem: turns out when you plug an effect into the effects loop, there is an internal switch that lets the rest of the circuitry know an effect is there and routs the correct internal signal to it. As soon as I plugged in a pedal, Voila!!!! Full volume was completely resorted, no problem at all. So at this point I can either limp along with a pedal in the loop that isn't even doing anything, or I can go inside and repair the switch OR bypass it (short it out) so the loop is no longer functional.
There are other situations that can cause the same symptoms, but this is what was happening in this particular case. Amp cost me $50, sold it for $225. Nice. Got me another one-- almost same low price.

Posted on Feb 15, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Crate g120 cxl guitar amp. it is switching between channels on it's own. (no footswitch)


Hello Jamie.
Your right, it is not rocket science, this is way bigger and funnier!
Now, that you took apart the chasis fron the cabinet, you may try testing if the channel switching occurs when you hit the Printed Circuit board with some tool like the handle of a screwdriver. you can try with light hits and different places of the PCB while watching what happens in the front panel light. also you can try bending the PCB with your hand to see what happens, if the switching occurs, maybe you have a cracked solder on the pedal jack or in any component related to the switching circuit, in this case, you will have to pull out the pcb, and re-solder those points that can be cracked. Using a magnifiying glass is very helpful in looking for those cracked solders.
Good luck and best wishes.

Nov 21, 2014 | Crate Music

1 Answer

The input that must be replaced on the crate gx140c guitar amp is integrated as far as I know there are no visible wires from the input to the board, thanks joe patch


I was afraid of that, for one thing, now it doesn't sound like that is the problem unless you see physical signs of it being broken. The problem is more than likely somewhere in you output power amp. I will look for a schematic and see if I can help you troubleshoot further. If you don't here from me soon, remind me. (just in case I forget)

Mar 03, 2013 | Music

1 Answer

I have a Fender Telecaster guitar and a Crate amp that cuts out i


The next time it stops, unplug the cable from the guitar and touch the tip of the connector with your finger. If the amp hums, then the amp is still working and the problem is in the guitar. If there is no hum from doing this, then the amp has am intermittent.

Try this before it fails to see what to expect in the way of the hum from this test.

Common problems with the amp are OFTEN with a broken input connector or bad switch on the preamp output jack if it has one.

There are MANY other things and without troubleshooting it is hard to steer you to a fix.

Mar 26, 2010 | Fender '72 Tele Deluxe Electric Guitar

1 Answer

I have a Crate GT 15, not getting anything to the speaker when I plug in.


Do you have electronics experience? Inspect the amp for broken or cold solder joints and any burned components. Check to see if the fuse blew and that the output IC's or transistors (not sure what Crate used in these) are not bad. Check your speaker wire as well.

Jan 15, 2010 | Crate FlexWave FW15 Guitar Amp Combo, 15...

1 Answer

Buzzes and feedback


Make sure the "ground lift" option is used on the direct box.

DO NOT UNDER ANY CIRCUMSTANCES use a headphone output jack as the output of this unit. The headphone jack is for HEADPHONES that have no return to ground. Use of this as drive to a sound board is sure to cause problems and in some cases can fry these amps due to the circuitry.

The cable used to go to the direct box should be very short and high quality.

You should source the power for this unit from the SAME source and receptacle as your sound board if at all possible.

Nov 08, 2009 | Crate FlexWave FW15 Guitar Amp Combo, 15...

1 Answer

NO sound through the AMP even though the power light comes on


Not a fuse. First thing, to check your speaker (amp unplugged, of course), touch the + and - speaker connections to a 9V battery. If you don't hear a pop sound then your speaker is blown. Thus, no output sound. If speaker is OK, then the output IC is your problem.

Jul 12, 2009 | Music

1 Answer

Crate 100 head. Reverb doesn't work.


Check the input RCA plug going into the reverb tank (silver box with two wires connected to it). Make sure the amp is off when you do this. Sounds like the output is working fine if hitting the amp does it.

Jun 19, 2009 | Crate Music

2 Answers

Crate gtx 65 guitar amp mains hum


I had the same problem on my VTX65. I noticed it would oscillate with different effects so I removed the effects module. Problem solved. Now it's dead quiet. I use a Digitech RP500 so removing the effects module was a non issue.

May 19, 2009 | Lexicon LX-7 7-Channel Amplifier

Not finding what you are looking for?

Open Questions:

Crate SPA1600 Power Amplifier - SPA Series Car Audio Amplifier Logo

362 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crate Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4869 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76649 Answers

Are you a Crate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...