Question about Pyle PT1200 Amplifier

1 Answer

My new Pyle Pro PT-1201X amp has a continuous protect(fault light after just 2 uses. The amp will still pass a signal, but it has to be turned almost all the way up. I checked the audio circuit for shorts but no joy!! The protect light remains when removed from the circuit. Does anyone know where to find schematics for this amp, or has experience with fixing this issue? I need to fix this pronto. Unfortunately there is no return policy or warranty for this amp. Any help would be appreciated.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 387 Answers

Its possible that the (((amps the components on the main circuit)) is short this is why you need to turn all the way up, or the pre amp unit.
you need to be more experienced to find this problem
if you want to fix the amp let me know

ecrdn@yahoo.com

Jack

Posted on Oct 21, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Amp on but no sound


Double check all of your fuses and make sure they are the corrects AMP. Other than that it sounds like the speaker wires came loose somewhere along the line. check on the subs and behind the deck. hope this helps

Apr 22, 2013 | Pyle PLA2678 POWER SERIES BRIDGED MOSFET...

1 Answer

Hello, What is the proper way to connect an Ashly XR1000 Crossover and a Pyle Pro PTA1400 power amp to my Peavey XR8600 so I can use 2 subs? The subs are not powered, but do have a passive crossover...


Here is a link to the manual:http://www.peavey.com/assets/literature/manuals/00513220_7.pdf I didn't look at the manual for the crossover but this is probably the way I would do it. Look at page 13 in the manual : Come out of the Main out (31 in the diagram) into the main in of your crossover. Go out of your crossover Hi and Mid out setting back into Power amp In 1 (labelled 32 in the diagram). Hook your speakers that you normally use to the output jacks on the back of the Peavey. Make sure you match the output impedances. Go out of your crossover low output into the Pyle power amp and out of the Pyle into your subs. Make sure the impedance ratings of all your speakers match the output impedances of your amps. You will only be running in Mono mode as that is the signal output of the Peavey mixer. You can run faux stereo by using the Main monitor Out as 1/2 the pair and the Main Out as the other 1/2 to both channels of the crossover but you won't be getting a true stereo pan mode.

Aug 22, 2010 | Peavey Xr 8600 8 Channel Powered Mixer

2 Answers

Pyle Academy 2300 watt amp not working =(


wrap a striped speaker wire around the back of the rca out put on your cd player and for the record that aint a 2300 watt amp its like a 300 watt amp

Mar 30, 2010 | Pyle PLAM2300 Car Amp

1 Answer

I got a pyle 1800w amp and a 1500w kenwood subs but as i increase the volume in the headunit it goes on protect mode why the other problem i got is as increase the volume in the headunit the bass of the...


The protection modes in these units ****. Most new units have them. What I do is turn down settings on deck and turn up amp as much as possible. Then the protection won't turn on because you won't have to turn it up as high.

Sep 30, 2009 | Pyle PLA1200 Car Audio Amplifier

1 Answer

PyLE PT2000 Power Amplifier' { is it worth it??}


People talk alot of **** about Pyle amps, all I can say is that,
I have two PT-2000 & PT-1800 power amps that I have set in bridge mode, one for each speaker and they are powering two Altec-Lansing 18" inch subs, one amp per speaker, no hiss, line noise or anything and the system kicks. I tried the Pyles on a whim because I got tired the trouble I was having with the QSC and Crown power amps, could not go a year without having something go wrong always sending back to dealer for some kind of fix! So now I have 2, QSCs, 2 Crowns & 4 Pyles driving my system

Apr 27, 2009 | Pyle PT-2000 Amplifier

1 Answer

Replacement parts for Pyle power amp PT-2000


VU meters are generally illuminated by small bulbs at the back of them. It's unlikely to be a powerfull bulb perhaps 12 volts perhaps around 200ma at the most. Most electrical shops should sell something that should suffice. It could be an LED though!

Apr 15, 2009 | Pyle PT-2000 Amplifier

1 Answer

Amp goes into protect mode after volume is turned up


Not enough juice, check the power and ground connections, another possibility is to have dc in the input, try to use in line filter available from radio shack to cut the dc, also test the with one speaker at the time, you could have a bad speaker (shorted) too.

Apr 08, 2009 | Pyle PLA4240 Car Audio Amplifier

1 Answer

Amp Issues


1800W peak output at 2 ohms
975W peak output at 4 ohms
600W RMS (continuous) at 2 ohms
325W RMS (continuous) at 4 ohms
Variable LP crossover adjustable 35-250Hz
4 AWG power/ground inputs and RCA pass through
Low-pass filter
Bass boost 0-18dB adjustable remote punch bass EQ
Signal-to-noise ratio: >80dB
Line-level input


It is going into protect mode for a reason.
Disconnect the subs and turn everything on again. If the light comes on, the problem is internal and will need servicing by a technician.

Dec 22, 2008 | Ultra Linear UL-2200D Car Audio Amplifier

1 Answer

Protection light stays on no output


i have the same amp and have that same issue before. yes you are correct that if you take off the RCA cables on the input there will be no light. either you have plug the remote line on the 12v or a grounded sub. it should be 12v/remote/ground from the corner. good thing im just fixing my sub earlier. it is no problem if you have hooked the remote line on the 12v, it is the same supposed to be. to check if your amp is working, short the 12v/ and the remote line and play your stereo and see if your sub is working. by the way, what sub are you using? i just blew my sub and need a new one.

Feb 02, 2008 | Pyle 1800-Watt 2-Channel Bridgeable MOSFET...

1 Answer

Amp protection mode


Try swapping the "bad" fuses for the "good" ones and see if that helps. That will tell you if the fuses are the problem. I doubt that is the problem. You never said what kind of problem you were having with the left speaker. If your friend dropped a drink into the amp then I would discontinue using it until it was checked out and don't be surprised if you have one channel that has some parts that need replacing, like some of the output transistors/MOSFET's. That might explain why your fuses appear to be melted. Maybe they are. In any case, get someone who knows what they are looking at to have a look see at your amp.

Jan 17, 2007 | Pyle PT-3200 Amplifier Car Audio Amplifier

Not finding what you are looking for?
Pyle PT1200 Amplifier Logo

Related Topics:

154 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyle Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

yadayada
yadayada

Level 3 Expert

75130 Answers

Lawrence Oravetz

Level 3 Expert

9324 Answers

Are you a Pyle Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...