Question about Power Acoustik LT-980/2 Car Audio Amplifier

1 Answer

Xplore 2ch 200w amp model 4090 help

I have an Xplore 2ch 200w amp model 4090 and it cuts on but no sound when i hook up my wires. I opened up the amp to see whats wrong there were some parts burnt out, could there be a way to fix this?

Posted by on

  • fried amp Mar 31, 2009

    i need to kown were to get parts

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 82 Answers

Yes there's a way to fix that. The best way to fix that is to bring it to your supplier (if it has warranty and in terms and conditions) or to a certified repairman in your area.

Posted on Jul 28, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where can I get a remote control.


I believe that you want the INSIGNIA KOR3551. You can find the remote using the following website.

http://ezremotefinder.com/results.php?mfg=INSIGNIA&mdl=KOR3551&keywords=&page=1

Good luck!

Jan 29, 2016 | Insignia Ns-r2000 200w 2ch Stereo Receiver

1 Answer

Getting no sound hooked up to pre-amp and 2 rotel 200w amps with snell speakers


You didn't say whether the player is connected by 2 RCA cables (analog) or by digital cable. If by RCA, does the player have a headphone jack? I had a player once with a piece of a headphone that broke off inside the jack, muting the analog outputs.

May 16, 2014 | Sony CDP-CX300 CD Player

1 Answer

No sound from my speakers


Make sure your source is properly assigned and switched to respected input. Your speakers should also be engaged.

Mar 11, 2014 | Insignia Ns-r2000 200w 2ch Stereo Receiver

1 Answer

It was laying on the workbench in my kids stole the fusesWhat size fuses go in a koiiler model 9696 1000watt Max amp? To bridge this 4ch to 2 on the high input side. do you have to tie the input side??...


NO dont tie the inputs. Inputs stay just as they are. Outputs are where the bridging happens.
You amp specs are:
XM-9696 C/W 4 CHANNEL POWER CHROME/WHITE AMPLIFIER
MAX OUTPUT POWER (2 OHM): 200W X 4 = 800W
POWER OUTPUT: 90W X 4 @2 OHM (360W) LESS THAN 0.5% THD
60W X 4 @4 OHM (240W) LESS THAN 0.3% THD
BRIDGED 180W X 2CH @4 OHM

So lets take 800 watts and divide by 13Volts DC = 61.54 Amps
So if there are 2 fuses start with 30 amp. To play it safe you could use 25 amps and if they blow try a 30. Now if the 30 blows you may need to take
another look at your wiring. I think 30 will be fine though.

Apr 02, 2011 | Car Audio & Video

1 Answer

Cant figure out where the thick red wire goes


buy the amplifier wiring kit from Walmart and let me know if you can not follow.

Jun 08, 2010 | Legacy 2CH 800W AMP Car Audio Amplifier

1 Answer

I don't have a sound card


in that case get yourself a USB sound "Card" these simply plug into a USB port, and you hook up the speakers to that. They work real great

Mar 18, 2010 | Xplore Technologies Xplore iX104C2 Tablet...

1 Answer

Loss of sound to passangers side speakers


?s amp ?cap r using?brigd 2ch 4ch hook w/ fused sep. mainly chk grd! amp on carpet over heats. vent it!

Mar 22, 2009 | Car Audio & Video

1 Answer

Hits intemittently


ive had problems kinda like this ... normaly its a crossed or reversed speaker wire check the positive and negitive wire into the speakers "they move sometimes when there is more air moving around the speaker"

second make sure you have the impedence correct "possitive to positive negitive to negitive'

hope this helps

Dec 21, 2008 | Pioneer Car Amplifier GM-5100T - 2CH 760...

Not finding what you are looking for?
Power Acoustik LT-980/2 Car Audio Amplifier Logo

Related Topics:

396 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

yadayada
yadayada

Level 3 Expert

70365 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...