Question about SPL DK-2600D Car Audio Amplifier

1 Answer

No power to my amp

I ground out the amp and hook up the power to the battery but the power light will not come on at all so i dont know what to do.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

I'll assume that you've checked the amplifier's on-board fuses.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Posted on Jun 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just bought two ten inch JL Audios and i hooked them up and they work great.... i installed them two days ago, and since then my battery has died on me twice.... i dont know what the problem is... i...


Hi there, check when you have switched off the power in the car to see if the amp power lights are still on, if so there could be a problem with your remote wire. Check the cables to he rear of your stereo and with a test meter, determine which one loses power when the ignition key is removed. When you have found this cable, splice your remote lead to this one, and your amp should switch off when you switch the car off, thus saving your battery. You could wire it to a permanent live feed and install a switch to allow you to run the amp without the key in the ignition but dont forget your battery will run down fast because Amps use a LOT of power.

May 06, 2011 | Pioneer Car Amplifier GM-5100T - 2CH 760...

1 Answer

Tryin to hook up a mtx electronic crossover rt-01a. i dont know how to hook it up


Your basic crossover is going to have a power (+) and ground (-). Your power wire goes to the battery, and your ground goes to the frame. You will need to hook up your RCA or speaker wires to the input side. Then hook the other two RCA connections to your amp.

Apr 13, 2011 | MTX Car Audio & Video

1 Answer

Kicker impulse 254 amp red light on top?


1st check all of your wiring, make sure the remote wire is hooked up, check to see it the RCA's are hooked up. I know this sounds stupid, but i've done it a thousand times, check to see if you hooked up the speakers. If you checked all of those and still nothing, double check your ground. Make sure where you have it grounded, you have all the paint sanded away and its a good grounding point. The red light on the top of the amp, its not a protection light is it??

Apr 03, 2010 | Car Audio & Video

2 Answers

I have checked all connections to my amp battery,head unit,remote or trigger wire,fuses,power cable,rca leads,ground wire,amp has a green led light on it indicating if it works ok,red if it`s not,light...


Your amp could be in protection mode! Sometimes turning up to high or wires touching will put in protection mode! It will have to be unplugged for a day or two to drain all power out of the memory. Leave accessorie/ignition wire hooked up, just not power and ground wiring. It should reset itself.

Jan 22, 2010 | Lightning Audio B4.250.2 Car Amp

1 Answer

I just dont know how to plug everything with it...Power button comes on if you move the amp...sparks if touches with a a screw....dont know which connections to put where


Black is ground(hook to a bolt going into metal on vehicle). Red is switched power(only on with ignition on). Yellow is power(power even if ignition is off). Blue is amp turn-on(located at radio and sends signal for amp to turn on). It is sparking because you do not have it grounded properly. You can damage your amp and or you car's electrical system....be careful. Always pull a main fuse or disconnect the battery when wiring a car audio system.

Sep 16, 2009 | Boss Car Audio & Video

1 Answer

When I hook power to my amp the protect light comes on.


when connecting or disconnecting 12v power dont let the screwdriver touch the screw in terminal and side of amp at same time it causes a short in amp send it in to the factory or it could be the internal battery is burnt out from crankin it to loud

Apr 13, 2009 | Car Audio & Video

1 Answer

My kenwood amp wont turn on


What kind of "Clips" did you put on? They may be causing too much resistance and preventing the amp from getting the current it needs. Double-check with a voltmeter that you are getting at least 12 volts at the amp power connections and make sure your ground lead is as short as possible and connected to solid metal of the vehicle's chassis.

Aug 10, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Directed audio 800a amp the protection light keeps blinking


1. Check your grounds. (including grounds for your stereo)

2. Check to make sure the power cable you connected to your car battery is properly connected, and not coming into contact with anything metal.

3. Make sure you are using proper fuses.

4. Check your connection from your stereo to your amp, and your amp to your subs.

Jul 18, 2008 | Earthquake Sound XTREME 900W.5 Car Audio...

1 Answer

My amp is not working


For the visonik, you should check your speakers. You can use a D-cell battery. Remove the speaker wires from the amp and connect each speaker across the battery (for no longer than a few seconds). The speaker should pop each time the wires are touched to the battery. If they don't, the speaker is defective (assuming the battery isn't dead).

If the speakers are OK, you need to confirm that you have a good signal feeding the amp. You can use the RCA cables from another working amp in the vehicle. Do this with the amp that had the power light lit.

If you have signal going to the amp and the speakers are OK, the only two things left are the power supply feeding the amp (from the battery) and the amp. If you have B+ and remote voltage AND a good ground, the amp is defective.







For the pyramid, the amplifier probably has shorted output transistors. The amplifier will have to be repaired.

Nov 16, 2007 | Visonik V117SX Car Audio Amplifier

Not finding what you are looking for?
SPL DK-2600D Car Audio Amplifier Logo

Related Topics:

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top SPL Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

The Knight
The Knight

Level 3 Expert

72670 Answers

Are you a SPL Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...