Question about Crown Audio Players & Recorders

Open Question

Crown XTi 2000 No power on light Fuse is Good

Posted by on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 4234 Answers

SOURCE: i need the schematic for the crown amplifier

These are available for purchase from Crown. Generally they are not available on the web. Is there a specific problem that you are having?

Dan

Posted on Jun 29, 2009

Ad
  • 1525 Answers

SOURCE: fan don't work when power is turn on

hello try and get another fan strip the wires and where the fan is connected place there. and turn if the fan spins the you need a new fan if it don't spin then the fan fuse may have blown

regards
shaun

Posted on Mar 27, 2010

  • 2 Answers

SOURCE: Crown Xti 2000, signal to both channels, no sound

common problem with xti series... all the amp needs is a soft ware update contact crown and they can sort it for you... you dont have to send the amp back to them. it was a verry common fault with all the early xti amps..

Posted on Sep 23, 2010

  • 140 Answers

SOURCE: Where are the fuse located

The fuses are on the inside

Posted on Dec 14, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I use the crown xti 6000 for 2 double 18s pd186 for bass per channel


Send a signal from the mixer to the amp directly, seems as if you have a distorted signal from your crossover

Dec 23, 2013 | Crown XTi 2000 2-Channel Amplifier

1 Answer

My amp was blinking while it was working then it went off.Now it doesn't power up..Crown Xti 4000


Power supply likely failed. Electrolytics are the primary culprit.
It should have a switchmode power supply, so it is lmost likely the 5 volt section failed.

Sep 17, 2012 | Crown XTi 4000 Amplifier

3 Answers

Fan don't work when power is turn on crown xti 4000


the fans on these amps are heat sensitive, only when the amp heats up, then they come on

Mar 27, 2010 | Crown XTi 4000 Amplifier

1 Answer

How do I unlock my XTi 2000 amp?


Pressing & holding the prev/up & next/down buttons at the same time will toggle the lock on or off.

Mar 12, 2010 | Crown XTi 2000 2-Channel Amplifier

2 Answers

Crown Xti 2000, signal to both channels, no sound out of one, swapped speakers, connectors, etc. , still no sound out of one channel


common problem with xti series... all the amp needs is a soft ware update contact crown and they can sort it for you... you dont have to send the amp back to them. it was a verry common fault with all the early xti amps..

Aug 24, 2009 | Crown Audio Players & Recorders

1 Answer

My XTi 2000 is very distorted intermintently. Sometimes the volume drops by at least half. I tap gently on he top of the amp and it comes back up to normal. I heard Crown has had some issues. What's the...


From your description, I would suspect some poor solder connections inside. If you know how to work on these, check for bad connections near the voltage regulators. That is the mode common area.

Dan

Jun 30, 2009 | Crown XTi 2000 2-Channel Amplifier

1 Answer

I need the schematic for the crown amplifier xti 1000 crown xti 1000 2-channel amplifier


These are available for purchase from Crown. Generally they are not available on the web. Is there a specific problem that you are having?

Dan

Jun 28, 2009 | Crown XTi 2000 2-Channel Amplifier

1 Answer

Keep blowing speakers


It sounds more like you are overdriving the speakers not clipping the amp. If the output rating for the amp is 1000W into 4 ohms, this is approximately 500W into an 8 ohm load. Your speakers are rated for 400W. If you are running the amp at full output, that is too much power for the speakers and either the speakers are warming up too much and failing or are being extruded too far and failing. Your best bet is to better match the amp/speaker setup. Crown amps have built in clipping indicators and I believe that the xti series also has a compression circuit that would prevent distortion on the output side.

To confirm my suspicions, in what manner are the speakers failing? Are they completely open or do they sound distorted?

Thanks,
Dan

Apr 22, 2009 | Crown XTi 2000 2-Channel Amplifier

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

138 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crown Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5113 Answers

The Knight
The Knight

Level 3 Expert

74185 Answers

Paul Bade

Level 3 Expert

1536 Answers

Are you a Crown Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...