Question about Frigidaire GLGR341AS Gas Dryer

1 Answer

No heat but it turns on. I don't see any flame light.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Expert
  • 87 Answers

U need a new ignitor

Posted on Oct 14, 2010

  • Anonymous Oct 14, 2010

    ignitor

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I turn the thermerstat up but does not alter the flame


You're not giving us info. on heater, but in GENERAL, the thermostat only CALLS for heat,and doesn't increase flame or heat OUTPUT in BTUs. don-ohio (:^)

Jan 27, 2017 | Heating & Cooling

1 Answer

The pilot lights are shooting out flame. How donI fix?


Don't understand......pilot light IS a flame. What is the problem? Is the flame lazy and big? Then the pilot hole is dirty. don-ohio

Jan 04, 2017 | Heating & Cooling

2 Answers

I have a VC Wonderfire model 2610. The pilot flame is perfect blue on both sides... however, when I hit the switch for the main burner to come on...the pilot goes out... any ideas ???


You may have moved the safety sensor or pilot flame tip. The pilot light heats a wire. The wire is the safety sensor. The wire has to be clean and in the pilot flame near the flame tip.

Jan 10, 2015 | Heating & Cooling

1 Answer

Kenmore 90 series gas dryer no heat


The gas ignitor most likley is not functioning. They do not have a pilot light like appliances in the oold days. They must ignite a new flame each use. if you don't smell gas when you try and use, then it is the ignitor and the computerized sensor tells the gas not to turn on because the initial flame has not been created.

Oct 08, 2012 | Kenmore 63942 Dryer

1 Answer

Pilot readily lights but even after depressing pilot button for the recommended 60 seconds, it goes off before you can turn to the heating portion


How big is the pilot? Is it a pretty blue flame 2 inchs long or a yellow flame. If yelow flush the pilot with rust buster and let it dry. This will clear the pilot of dust or cobwebs that accumulate in warmer months without harming the inner workings of the safety pilot. If this still don't fix it then your thermocouple might be bad or the connection between the thermocoupler and the magnet might be corroded.

Dec 02, 2011 | Mr. Heater (F274825)

1 Answer

Fan is blowing in furnace, thermostat raised 10 degrees over ambient temperature and not heating home. Red and green lights blinking intermittently on control board.


Cycle the power first & see if the furnace goes through the normal sequence of order. On a call for heat, the vent inducer motor should turn on and the pressure switch should prove negative draft in the heat exchanger. the board then should power the ignition phase whenter it is hot surface ignition, or spark, you should hear a spark or see the orange glow of the ignitor & the gas valve is timed to turn on. If you have proper gas to the furnace, it should allow the gas to flow through the gas valve & ignite the flame. Once the flame is ignited, the romote or local sensor should sense the flame & the blower then kicks on from the time delay in the board. If you don't have any ignition, then something is wrong with either the ignitor, ignition module, pressure switch, or you have a manual limit that is tripped(this looks like a small 1/2 inch disc with a reset button on it) If you have ignition & the flame lights, but drops out, then your flame sensor is dirty & needs a touch of sand paper to clean it up(this looks like a 3 inch metal rod opposite of the ignitor) Make sure your power is off when you clean the sensor if you need to. Also if there is no ignition & the vent inducer motor is running... if it is hot surface igniton, there is a molex plug on the leead wires to it- disconnect & check continuity- should be under 110 ohms.

Sep 03, 2011 | Goodman GMS90703BXA Heater

1 Answer

My pool heater doesn't come on. The pilot is lit, and the valve to the ON position. I turn the front knub to heat but when I turn the switch on the front panel to ON it doesn't fire on (...


If your pilot light is lit, then you do have some gas flow, so it is probably the thermocoupler (the part heated by the pilot light) that is not telling the gas valve to open the main line. Sometimes it is just a case of residue on the thermocoupler that is not letting it get up to temperature and sometimes it has been knocked out of alignment and the pilot light is not putting direct heat on it.

A cleaning with steel wool (don't overdo it) would take care of the residue, and you can GENTLY move the thermocoupler back over the pilot flame. If neither of that helps then replace the thermocoupler.

Jul 01, 2011 | Hayward 250 1 Millivolt Propane Pool...

1 Answer

My weber grill (silver) does not get very hot after I open the top to do anything on the grill. What is the problem and how do I fix it? Dave Hendron


First, consider how long you preheat the grill and to what temperature are you preheating? If it's not long enough to reach at least 350 degrees, before you open the hood to start grilling. You're not allowing the grill to preheat long enough.

Second: Have you looked at the flame height on each burner when they're turned to the highest setting? It may be that the burners need to be removed and properly cleaned. In addition, the venturi valve on each burner may be partially clogged with spiders or spider webs. When that happens, the burners do get the right air to gas mixture/ratio and the burners don't fully light and heat up.

If the burner flames remain lower than they should, the grills regulator may be locked up. In which case, turn the tank valve OFF, disconnect the hose from the tank and wait 5 minutes. Reconnect the hose to the tank and turn the tank valve ON VERY, VERY SLOWLY (Slow motion, slow). Once the valve is fully open, light the burner farthest from the tank first and turn it to high. Does the flame height now, appear to be normal? If so, light the remaining burner(s) the same way. The flame height on all should be the same on the highest setting. If they don't you'll need to replace the grills regulator/hose assembly. You can purchase one at just about any home center or hardware store that sells grills and grill accessories. Just take your old one with you for comparison purposes.

Any or all of the above should solve your problem. Please let me know and if you have any questions, don't fail to ask.

Apr 15, 2011 | Weber Genesis Silver B Grill

1 Answer

The furnace will light up and the fan will blow but the flames cut out before my house reaches temp. i have the thermostat set at 70 and the house will not get above 55. i have tried turning the propane...


First, for those of you who might not know, "What is a flame sensor?" A flame sensor is a safety device. When your furnace's main burners ignite (light Up) the flame sensor picks up the heat from the furnace's main burning and says, "YES," and sends a signal back to the main furnace control board saying that it is OK to let the main burner stay on. Or if the main burners do not ignite, the flame sensor does not pick up the heat and says, "NO" to the main control board, Shut That Gas Valve and Main Burners Down! Thank God we have safety controls like the flame sensor. Most of the time, after turning your furnace's power off, you may clean the flame sensors with light sand cloth, emery cloth or steel wool. Reinstall the flame sensor and you are back in business! Over the years flame sensors can build up a light coating of burned-in dust and dirt. This insulates the flame sensor so that it doesn't sense the heat of the flame well enough, so by cleaning it you have almost restored it to its new condition. Seldom, but sometimes they do go out completely.

Dec 08, 2010 | Coleman Heating & Cooling

1 Answer

No heat


It can be both the heat fuse that gone or your pilot light has gone out, check to see if you see a flame while it is functioning, to do this turn on your dryer and watch in the dark so that you can actually see the flame coming on and off or check behind the little door that houses the pilot light to see if you see a flame if no flame relight, this should start your dryer producing heat again

Jun 22, 2008 | Sharp R-353 Microwave Oven

Not finding what you are looking for?
Frigidaire GLGR341AS Gas Dryer Logo

Related Topics:

38 people viewed this question

Ask a Question

Usually answered in minutes!

Top Frigidaire Dryers Experts

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Tim Whalen

Level 3 Expert

3072 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

Are you a Frigidaire Dryer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...