Question about Planet Audio TQ1601D Car Amp

1 Answer

My amp wont power down as soon as you connect the ground and power it comes on the car isnt on

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 82 Answers

Make sure your remote wire is functioning and powering up and down with the radio that could be what the problem is.

Posted on Oct 13, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a pioneer GM-X524 amp connected to a TS-W253C subwoofer and it isn't working. It has 12v power to it and a solid ground, but the power light wont come on and the sub isnt working


there should be 3 power related cables connected to the amplifier:

1-From battery to amp via fuse (positive)
2-From chassis of car to amplifier (negative)
3-From head units (power continuous) (blue or blue/white cable) to the amplifiers remote connection.
this connection enables the amplifier to switch on when the head unit is switched on and off when the headunit is switched off.
I hope this helps and let me know if I can further assist you.
....andy....

Jan 06, 2014 | Pioneer Car Audio & Video

1 Answer

My 2003 dodge grand caravan wont start. All dash board lights work, radio works, and windows rolls down. Starter has been replaced and still nothing.


Is there power at the cable at the starter? Check for grounds by putting clamp from your test light to the negative side of battery & probe the cable at the starter, starter & solenoid, sounds like the solenoid isnt engaging, but if the starter motor isnt cranking either bring the starter to the auto parts store & have it bench tested.

Sep 23, 2010 | 2003 Dodge Grand Caravan AWD

1 Answer

JL Amp isn't powering subs and speakers


just go through ur connections man one by one ull find the prob soon.....check teminals on battery...power line to amp ....all fuses within prob area and obviously make sure u have a good ground.....really impotant.....ground is the most neglected thing people do from my experience bein a audio tech oh and if that isnt it check ur subs....stick a 9v batt on the back pos n neg of each sub n c if they pop in r out this will determine if ur subz r blown

May 14, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My (TC4004) mtx amp wont turn on. My fuses isnt blown.I think my amp is fried. Any suggestions?. I was told by a friend that i may have to relace the the two yellow connectors that are on my amp..is this...


If your talking about the speaker connections on the amp than no,make sure the amp is grounded to the vehicle,and make sure your power and rca are connected,if so check all fuses again,your amp may have a fuse,if its not blown your amp is probably fried.

Oct 12, 2009 | MTX (TC4004) Car Audio Amplifier

1 Answer

Amp is not putting out, shuts down


you have a bad ground recheck your ground and make sure you have a good one
or the guage of your power wire isnt big enough

May 01, 2009 | Power Acoustik GOTHIC OV2-1800 Car Amp

1 Answer

I have been having trouble with my car stereo system


First reinspect your power and ground connections, vibration may have loosened them.

Then be sure that amp location has proper ventilation, (overheating will cause shout down)
A 2400 in a closed space will definitely need exhaust fans to help circulate cool air around the amp.

The cap should be mounted close to the amp and properly charged before use. It is connected in-line with the main power lead paying close attention to the power in and power out terminals.

Power in = from the battery
Power out = to the amp

Good luck
Aduz

Mar 15, 2009 | Rockford Fosgate Punch 801S Car Audio...

1 Answer

My kicker 10'' L7 sub works when the volume is low, when the volume is turned up the sub. stops working. Why?


Check wires that go into the speaker.Try turning the bass down than turn the volume up.If it sounds good when volumes down and as you turn it up it gets worse your amp isnt putting out enough power.whats the amp? power wire gauge should be same as ground.what gauge are they? Check ground to make shure you are getting a good connection & power wire isn't loose at any of the connection what size fuse are you running under the hood?

Mar 01, 2009 | Car Audio & Video

2 Answers

Power


Have you checked the on-board fuses?

Did you confirm (with a multimeter) that you have voltage on the B+ and remote terminals of the amplifier?

Did you have the black meter lead on the ground terminal of the amp when you checked the voltage?

Jul 18, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

5 Answers

LED turns on, but power light doesnt and there is no sound coming out of it.


it sounds to me like you have a bad ground or a short in the ground wire. try checking the ground cable as well as theremote wire (blue), and make sure the ground is connected to an unpainted,clean surface such as the frame of your car.

Sep 04, 2007 | Jensen PS2130 Car Audio Amplifier

1 Answer

Amp wont work jxp340


hi if you got a voltmeter TEST IT ALL ON A LOW LEVEL OF VOLUME!! check the outlets of the amp if there is a signal at all... no? - the amp isnt hooked properly! yes? - check if the volt level on the outlets is higher then the level on the inlets of the amp (the amp is amplifying) no? - the amp isnt hooked properly! or its bad... yes? - connect a speaker to see if its working wont put out a lousy spark? check your system, the problem if probably there... check all the connections, fuses, wires begin from battery and go FWD antill the next device isnt working good luck

Feb 21, 2006 | Jensen JXP340 Car Audio Amplifier

Not finding what you are looking for?
Planet Audio TQ1601D Car Amp Logo

Related Topics:

43 people viewed this question

Ask a Question

Usually answered in minutes!

Top Planet Audio Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

michael galang

Level 2 Expert

138 Answers

Brad Brown

Level 3 Expert

16010 Answers

Are you a Planet Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...