Question about Kenmore 25512/ 25513 Progressive Canister Vacuum

1 Answer

Hose is clear and suction is fime. Icleaned the threads off the rotor brushes but it wont spin

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 377 Answers

Two things you can do. First, remove the brush and you will find a small plastic clip at each end that holds it in place. Spray a bit of WD40 between the brush and each of these clips then turn each of the clips by hand while holding the brush. They should turn freely with the WD40. As long as you have the brush off, put on a new drive belt. That should rectify the situation unless the motor is burned out. Paul

Posted on Oct 12, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can't get the roller to spin


i suggest taking hose off and declogging it by using a water hose to make sure its free of debris. Plus check your belt first take off bottom plate the you'll be able to tell if belt is broken which it sounds like it is.
if belt is good and hose is clear and still brush wont spin then your brush motor needs replacing. hope this helps.

Mar 05, 2013 | Eureka Whirlwind Litespeed 5740 Bagless...

1 Answer

Hi my dc07 has lost suction on the roller, but not on the hose there are no blockages cyclone still strong any ideas thanks


Are the brushes in the base of the vacuum spinning? You wont get much suction from the base of the hoover if the brush bar isn't working?

Lie the vacuum on it's side and turn it on. If the brushes aren't spinning then your belt has either come off or broken. I suspect this is the cause of your problem.

Nov 04, 2010 | Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

No Suction/Brush not spinning on Bissell Powersteamer Pro Deluxeb


make sure hoses are clear and check belt

Oct 08, 2009 | Vacuums

3 Answers

The machine will not suction - it will spray and spin the brushes but will not suction - the power is going to the machine, but it will not suction.


Disconnect the suction hose. While running, check the suction port if it works, by putting a piece of paper. If the paper is taken in, then it is oK. Now, check the suction Hose for breaks or opening before the suction head. Breaks or opening breaks the suction power at the suction head. Loose connection between the suction pipe and the suction port also must be check as this will also cause the same
problem. You may need to replace the suction hose
to correct this problem,
Send us the e-mail and your vote if this solves your problem.

Sep 27, 2009 | Eureka Atlantis 2590A Wet/Dry Vacuum

1 Answer

My Bissell TurboForce Bagless Turbo Brush doesn't work


clean the filters..on atop the dustbin, inside the dustbin bottom..and over the fan below..if not sqeaky clean you loose suction

Sep 07, 2009 | Vacuums

1 Answer

Brush spin,good suction at hose, no suction at


Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Jul 11, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

3 Answers

Dyson Brush Bar Always Spins


Take off the brush cover and check that the suction orifice is clear. Also check the rubber flaps at the bottom of the hose/handle holder is correctly positioned.

Feb 06, 2008 | Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

Lost suction


Hi.

Remove the sole plate turn the 3 plastic screws to unlock & lift off.

Now remove the blockages that have accumilated from the oppening of short clear hose.
Check you can turn brush roller & check belt.

Now reassemble switch on pull handle back & look under machine is brush spinning ?

If not check the knob on side of machine is in drive (D) position.

http://dysonmanuals.llc.nu

Chris..

Dec 27, 2007 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

Help


as the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage, you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of screws to undo, the roller not rotating will effect the power of suction dramatically, start from there and see how you go if i have helped please rate me

Sep 15, 2007 | Hoover U8171-900 / U8172-900 / U8173-900 /...

Not finding what you are looking for?
Kenmore 25512/ 25513 Progressive Canister Vacuum Logo

Related Topics:

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76682 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...