Question about Audio Players & Recorders

1 Answer

After 10 years of function a problem appears with the technics se-a900s power amplifier: When the power output reaches or aprox the 10wrms the protection circuit enabled,and the unit goes off! (no sound) I have to turned off power,and start again (power on) The unit is not overheating. The built in cooling fan working fine. I dont want to think that the problem caused from the 15y.old,speakers,they playing music fine as the first time! (tested with other type of amplifiers at high levels of power with the same cables) I think something going wrong with the thermal detector or low impedance speaker detector - i couldn't found any adjastments for this inside the unit!

Posted by on

  • qluser Oct 12, 2010

    After a close look at the schematic diagram of the amplifier, i saw there is no thermal protection circuits with discrette componets.
    However the problem i think caused from bad voltage,combined with poor current from power supply unit. Special from the capacitors. They are aged...
    I will try to replace them,and i will post a comment,with test results.

    Somehow ,if i run the amplifier from the first at high level output, the unit working fine!
    If i run the amplifier at low power output for several hours,and then want to hear at high level,the problem appear especially at night! (diefrent and higher ac voltage)
    Also important is this: I don't hear music verry often from this system. The amplifier is in st.by function for 2-3 months,and sometimes more for the last 5 years! Before this period the amplifier working fine day by day for a several hours per day.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,175 Answers

I would have the power supply capacitors replaced. After several years ( from heat and age) they dry out and dont put out proper DC voltages to run the amp.

Posted on Oct 12, 2010

  • 2 more comments 
  • qluser Oct 12, 2010

    I thought that too... Thanks any way!

  • fastbladerun Jan 18, 2011

    Can you let me know if that was the solution please?
    I have the same problem en where did you buy these capacitors.
    Thanks Paul

  • fastbladerun Apr 05, 2011

    Please can you tel me if the capacitors where the problem or something else

  • Scott Frye
    Scott Frye Apr 05, 2011

    Digikey (dot) com or
    mouser (dot) com

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ok, i interested in the technics se a900s amplifier, just for vu meter use, not amplifier,and...


Pre-amp only needed for phono. Otherwise, line in is just fine.

10 to 20 ohm load resisters to substitute for speakers. get 50 watt rated ones at least, they can get hot....

May 12, 2016 | RCA Car Audio & Video

1 Answer

I will buy a Technics se a900s amplifier, but


I think you are saying you want to connect the amp and use it's vu meters but not connect it to speakers?
Presumably you are already well catered for in the matter of amplification but lacking good vu meters?

There is a fair amount of information about this premium amp online including operating and service manuals that can provide a better answer than I can.

One note of caution; it is generally bad practice to operate a power amplifier without a load at the output and it might damage the amplifier. If it is desired to operate it without speakers providing the load, dummy loads are available.

I suggest you have a look through ebay or Amazon where you might find digital or analogue vu meters at a reasonable cost or alternatively I believe computer software could turn your laptop into vu meters.

May 11, 2016 | Technics Audio Players & Recorders

1 Answer

Technics 1080 pre amp volume control is not functioning correctly


Technics SE CA1080 Service Manual

there is a chip called an operational amplifier under a heat sink on the pcb,that fails when it get top volumed for two long theres regulators with heatsinks.
it is listed as,

Technics SE -CA1080 amplifier F61 fault,

May 13, 2015 | Technics Audio Players & Recorders

1 Answer

What is the speaker output per channel for technic se-350?


seems to be 22 watts rms, 35 watts peak at a 4 ohm load. with 8 ohm speakers, the power would be reduced 50%, but the distortion levels would also be drastically reduces

Jan 02, 2015 | Audio Players & Recorders

2 Answers

My technics intergrated amplifier says over load


overload is protection from very big signal input-or high current output.
1-keep your input signal between -10db-----to 0db.
2-confirm that amplifier power is greater than total power of loudspeakers by 20%(if loudspeaker total power is 8 watt-amp watt must be 10 watt at least.

Nov 30, 2009 | Technics SUV500 2-Channel Amplifier

1 Answer

My aplifier Denon UDRA F-10 says "protect"


Blingking Light or Protect usually means that there is DC appearing in output stage and is protecting Connected Speakers.
It can be faulty Output Stage (Bad ICs/Transistors/Resistors/Capacitors) or Faulty Power Supply.

Working on These types of Problem is not user friendly at all.

Advising to take local Authorized Shop.

Jan 30, 2009 | Denon PMA-100M Amplifier

1 Answer

Parts for Technics SE A900S Audio Power Amplifier


Here ya go.
http://www.vancebaldwin.com/products/?MSCAN7062

Mar 13, 2008 | Audio Players & Recorders

1 Answer

Technics SH-AC300 Connection to Power Amp & Pre-Amp


Hi!
The problem is, that your SH-AC300 needs an amp with 5.1 input (but no decoder). For this purpose technics delivered SA-AX710.
So if you'd like to use your current equipment it would be impossible.
The only option is for you to buy 2 more Power Amps (SE-A900S), so that each of 3 amps would take care for one part of music. (one for FL, FR; one for RL, RR; and one for sub and center).
Another option is for you to buy SA-AX710. Then all the problems would be solved with it.

Jan 15, 2008 | Technics SA-DX950 Receiver

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

482 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5056 Answers

The Knight
The Knight

Level 3 Expert

74136 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...