Question about Hoover Vacuums

1 Answer

HOOVER WINDTUNNEL VACUUM MODEL U6454-900 BELT KEEPS COMING OFF

Posted by on

  • hinrg2353 Jun 02, 2008

    this has happened from day one of purchase....I have replaced it many times and put on new ones...it does seem to come off when doing edges of rugs....am trying to change the settings so that it won't work so hard...had it set on carpet but low setting all the time now I am setting it on medium carpet and change to floor setting for my hardwood...I hope this minor adjustment keeps it on. seems like there should be a lip on it so it won't come off so readily.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Have you put on a new belt or just keep using the old one. If you haven't replaced it in the last 6 months, then it has stretched to the point where it won't stay on. Another cause is catching throw rugs, towels or something that gets in there and knocks the belt off.

Posted on Jun 01, 2008

  • Lauren Junge
    Lauren Junge Jun 02, 2008

    Changing your setting should help, try not to catch things, the belt coming off when you do helps protects the motor from burning up.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to stop main belt from comming off motor shaft on a windtunnel model u6634-900


Need to replace both drive and roller brush belt. Can't just replace one even if the other is fairly new.

Jun 21, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Hoover U6439: Belt keeps slipping off


The belt is stretched and you simply just need to replace it. You can get the belts you need for this model here:

http://www.vacbelts.com/hoover-self-propelled-windtunnel-belt.htm

Sep 28, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Hi I have model u64330-900 hoover windtunnel. It


Hello,
It sounds like your vacuums belt is stretched and worn. You'll need to replace it. Below is a link to a website that gives instructions with pictures on how to change the belt. You should be able to get a replacement belt at any department store or vacuum retailer.
I hope this helps you.

http://www.info-vacuum-cleaner.com/hoover-vac-belt.php

Sep 24, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Burning smell coming from vacuum


use a penny to turn the 2 screws on top a quater turn then fold down the vacuum and lift up the cover and you will have access to the belt. Clean the small hepa filter with soapy water. their may be 2 of them. The cannnister filters need to be shaken but not washed. Good luck.

Apr 09, 2009 | Hoover U5753-900 WindTunnel Bagless...

2 Answers

Hoover Windtunnel - the belt keeps coming off & it is the correct


One compatible belt that I use and works (at least while its new) is Royal 104425001. Try that.

Mar 01, 2009 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

Had a problem with the brushroll now its burning up the flat belt


When you put the flat belt on, is the print on the outside of the belt? Is the brush correctly positioned?

Dec 21, 2008 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover U5399-900 WindTunnel Vacuum


38528033 is the belt number or just 033.
40201160 is the part number for a 2 pk
sometimes they are referred to style 160 as well

All these are the same belt. Hoover makes things so simple don't they? LOL

Dec 02, 2008 | Hoover U5399-900 WindTunnel Lite Upright...

1 Answer

Belt keeps coming off


Great. Glad to help.

If you would, take a moment to rate this solution. Thank you. Happy vacuuming. :-)

Oct 25, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Belt keeps coming off even though I replaced it with a new one. It will not stay on keeps throwing them off.


http://geeksquad.fixya.com/ThreadView.aspx?prdid=40485&thid=739734
Belt (by 2 users)
Posted by lynndian on Jul 04, 2008Belt keeps coming off even though I replaced it with a new one. It will not stay on keeps throwing them off.
I have a fathom vacuum and replaced with new brush roller and belt
but it keeps kicking belt off the spindle there is nothing to hold it on
Is there suppose to be didn’t see any broken pieces inside it. Anita
Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. Hoover U6437-900 / U6439-900 WindTunnel. On the Hoover and probable on the Fantom it sounds to me like you have a broken motor mount and it needs replacing on both machines. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Thanks, Don the Vac Man
Go Ahead. Use Us.



Jul 04, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...