Question about Televison & Video

1 Answer

Why does my brand new amp go into protect mode everything is hooked up right

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 998 Answers

Your speakers might be the problem or check the impedance of your amp.

Posted on Oct 11, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What does my protection light come on after hooking everything up


There is something shorting out the amp. What you will need to do is disconect all wires and hook up one at a time. Connect ground, !2 volt and remote see if amp turns on ok. If it does try connecting each speaker seperately to see if either one sends the amp into protect mode. Then connect the rca. See what causes the amp to go into protect mode.

May 08, 2013 | Car Audio & Video

1 Answer

Well i was driving one day and my subs just whent out so i bought brand new wires and hooked everything up but the power protector light turns red whenever uu turn it up past volume 10 i really do not know...


It sounds like your amp is going into protection. I know it's frustrating, but this is actually a good thing. If you subs you have are drawing too much power and the amp can't keep up, it will shut off instead of melting the board. Usually, the protection mode only last a few seconds. The user normally turns the music down that the protection shuts off and the music plays again. I recommend looking at a larger amp for your subs, if you are going to play them that hard.

Aug 14, 2011 | Car Audio & Video

1 Answer

I have a brand new logic soundlab tx1002. it was hooked to a brand new radio and new speakers. When turned on, it is in protection mode. you get a popping sound from the speakers. we have checked all...


first disconnect one wire at a time, making sure the power is off. then connect power and check to see if your speakers are making the popping sound. when you do your speakers, make sure you disconnect both positive and negitive of each speaker at one time. when your amp goes out of protect mode you will have found your suspect wire. then trace to the issue. it could be as simple as crossed over possitive and negitive wires
cheers

Jan 11, 2011 | Logic Soundlab LSX2600 Car Audio Amplifier

1 Answer

As soon as I hook the amp up it goes into protection mode. But in about 10 seconds it flashes off protection mode but them goes right back into protection mode. And it keeps doing this as long as the amp...


If you disconnect your speakers and input and the problems remain it means you've blown your end-stage and the amp needs repair.

if the problem disappears when disconnecting the speakers you may want to check if the impedance of your speakers is within tolerance of the amp.

Dec 23, 2010 | Rockford Fosgate Punch P5002 Car Audio...

1 Answer

Got a problem with my car amp.Everything was working fine until 2day.Amp goes in to protection mode.Jumps from power to protection indicator every i would say 3 seconds and each time it goes in to...


Ok check the remote wire running from the headunit to the amp should be giving v12 feed whiles headunit is on.

check or change grounding position.

take cover off the amp as the circuit may be over heating.

Sep 22, 2010 | Car Audio & Video

1 Answer

Protection mode on my amp


YEA CHECK THE OHMS ON THE SUB TO MAKE SURE THEY MATCH UP TO THE AMP JUS SOUNDS LIKE THE WIRING IS OUT OF PHASE.

Jun 15, 2009 | Pioneer GM-7200M Car Audio Amplifier

1 Answer

Trubleshooting


you might nee a new speaker sounds like your amp is going into protect mode your voice coil might be going out try it with a diffrent speaket

Mar 01, 2009 | Car Audio & Video

1 Answer

My amp goes in protect mode


Maybe the audio amplifier IC´s are damaged

Feb 06, 2009 | Power Acoustik GOTHIC OV2-1200 Car Audio...

1 Answer

Stuck in protect mode


Speakers shorted out, blew a fuse. Replace the unit or (cross your fingers and) open up the box and find the blown fuse.

Nov 23, 2007 | Sony STR-DE425 Receiver

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

15 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74383 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...