Question about Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum

1 Answer

No suction and noisy when cleaner is turned on. Cleaned filters and hoses to no avial.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 377 Answers

Since this unit is direct drive, there is no belt to deal with.
There are manuals at this URL: http://www.managemylife.com/mmh/lis_pdf/OWNM/L0403208.pdf they show the parts and have messages on dealing with clogs. Sounds like there might be something caught up in the impeller. If you removed the hose from the bottom back of the vacuum, you might be able to check for debris that is caught in there. While you are at it, a good cleaning of the beater brush might help as well. Paul

Posted on Oct 11, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Miele S3141 canister began acting strange this morning. No suction...so I took off the hose and checked for blockage, (nothing). Now I can't get the hose back on the canister. It just slips ar


see this causes and fix it. God bless you
Air filter:
If the vacuum cleaner won't pick up dirt and has no suction the air filter might be clogged. Remove the filter and either clean or replace it as needed.
Exhaust Filter If the vacuum cleaner won't pick up and has no suction the exhaust filter might be clogged. Remove and clean the filter, replace it if its torn or damaged.


Vacuum Hose If the vacuum cleaner won't pick up and has no suction the vacuum hose might be clogged. Remove the hose from the vacuum cleaner, stretch it out straight, shine a bright flashlight in one end and try to see light through it. If no light can be seen, use something to run through the hose and free up the obstruction.
Vacuum Bag If the vacuum cleaner won't pick up and has no suction the vacuum bag might be full. Clean or replace the bag as recommended by the manufacturer.

Dust Cup AssemblyIf the vacuum cleaner won't pick up and has no suction the dust cup assembly might not be installed tightly, or it might be cracked or broken. The dust cup must seal tightly in order to produce the right amount of suction. If it is cracked or broken, replace it. Most glues and adhesives will not successfully seal the crack.
Blower Wheel If the vacuum cleaner won't pick up and there is no suction, the blower wheel might be jammed or broken. Check the blower wheel to be certain it turns freely. If it doesn't, check to see if there is anything rubbing against it. If not, but it's hard to turn, the motor is most likely the problem.
9_28_2012_11_32_31_am.jpeg9_28_2012_11_32_53_am.jpg

Sep 27, 2012 | Vacuums

1 Answer

Loss of suction o=with hose tool


Hose or tool is probably clogged. Is this an upright? Bagged or bagless? Have you changed the bag and filters? Cleaned out the brush and hose that goes from the brush area to the collection bag/cup? The only reason for a vacuum cleaner to lose suction but still work is a clog or dirty filter which blocks the air flow. Follow the air flow from the brushes to the bag/dirt cup. If the machine is bagged, change the bag. I use another vacuum cleaner to do this.While your at it, might as well change the belt.

Nov 15, 2011 | Hoover Vacuums

1 Answer

I have a Dyson DC07 and it has lost suction. I have checked the belt, cleaned the circular filter and emptied the dirt chamber. The hose still has plenty of suction but I can't use the hose the vacuum...


Here are some things you can check.First you need to see if the problem is with the suction or agitation.If the suction on the hose for using the attachments is low you either need new filters a new cyclone(they are not cleanable) or it is clogged.To check for a clogg remove the cyclone and turn on the vacuum cleaner.you can put your hand over the suction side of the handle tub and feel if it has suction there.Reinstall the cyclone and again check the hose.If it is the same you don't likley have a suction problem you have an agitation problem.The 2 belts on the DC07 are part of the clutch and when they are strectched to a certain point (3-5years) the clutch needs to be replaced.you can check the clutch by turning on the vacuum cleaner and applying slight pressure downward on the front of the vacuum head.If the vacuum makes a loud ratcheting noise or you can stop the brush from turning the problem is most likely the clutch.One last thing is to make sure the bottom plate is on correctly I often see a misaligned bottom plate and the brush dosen't hit the carpet so it dosen't pick up.  www.sewvac.com

Jan 28, 2011 | Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

Hello,We have an Hoover Mach 5 Cyclonic vacuum that has no suction. We have cleaned and checked all hoses, belts & filters. Please help us.


With this model, remove the dust tank, and turn it on, check for suction at the lower intake. If you have suction, install the tank and remove hose, and check for suction there. keep following until youn lose it. Then you problem will be between those 2 areas

Mar 27, 2010 | Hoover U5194-900 Mach5 Multi-Chamber...

1 Answer

I don't get much suction from the hose on my DC17 All Floors. I don't see any obtacles in the hose. The suction when upright is fine.


Hello,

The way your Dyson DC17 is designed, there is a suction divert mechanism that diverts the suction to floor when the vacuum cleaner head is pushed down, and then back to the hose when the vacuum is in the upright position. If you are getting suction from the hose when the vacuum is upright, but no suction after the handle is reclined, this is actually the normal function for the Dyson DC17.

You can check to see if the filter is dirty. The washable filter on your Dyson DC17 is located directly underneath of the dust bin of the vacuum cleaner. After removing the dust bin, lift straight up on the part the bottom of the dust bin rests on. This is where the pre-motor filter is located for the DC17 models. If this filter is not cleaned on a regular basis, then it can start getting clogged, and you'll notice a loss of suction on the vacuum cleaner.

If you have further questions, please visit the link below where you may download the instruction manual. There are some trouble shooting guides at the back of the manual that you may do to try and diagnosis this further.

Dyson DC17 All Floors Instruction Manual:
http://media.dyson.com/downloads/us/floorcare/manuals/dc17_opmanual_usa.pdf

If this was helpful, please be sure to rate the repair as helpful by clicking on the thumbs up icons on the top of the repair.

Thank you very much,

Chris Jones
GoVacuum

Mar 23, 2010 | Vacuums

4 Answers

My VAX Vacuum has lost ALL suction power. I've


vax power pet 1 filter keeps getting clogged up so dirt not going into cylinder

Jul 05, 2009 | VAX Appliances Vax X5 Bagless Upright...

1 Answer

Panasonic MC-E468 vacuum cleaner loss of suction


HI If the cleaner is loosing suction make sure to check all inspection tubes and the dirt channel hoses after the spinning brush. Also check the main hose for any clogging. One of the worst faults of this model is clogging hoses. Hope that helps you.

Feb 27, 2009 | Panasonic MC-E583 Bagged Upright Vacuum

1 Answer

NO SUCTION


If you have no suction, there are only a couple of things that could cause it. As you have checked for blockage, and changed your filters, you may have a vacuum motor with bad bearings, or broken fan blades (inside/on the vacuum motor). Either symptom points towards a vacuum motor being bad and needing replaced.

Jan 21, 2009 | Electrolux Central Vacuum

1 Answer

Bissel Pro Heat Turbo attachment does not work.


Something is probably clogging up the suction.
Try to snake it out with a coat hanger or similar tool.
Often, especially with shedding pets hair will clog the suction pipes
Hope this is helpful.

Good Luck!

Jan 02, 2009 | Bissell 9500 ProHeat 2X CleanShot Upright...

Not finding what you are looking for?
Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum Logo

88 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...