Question about Galaxy Radios DX-959 40-Channels Base CB Radio

1 Answer

Unit will not power up. no lights at all and power souce and cable has been tested with another radio.

Posted by on

  • Don Reiman Oct 11, 2010

    Is it blowing fuses?

    It may be the polarity protection diode. Should be D93 near the back right of the radio.

    its hard to say without some more information. When did it start doing this. What did you do with it when it stopped working?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

  • Expert
  • 500 Answers

The board may have loose connection on the voltage regulator.. if not may have blown the protection diode. IF you need help let me know.

Posted on Jan 03, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My philips htl4110b soundstage speaker doesn't power on at al..i bought it just yesterday.i have checked all my connections but it doesn't seem to work


if your source is a pc the setting might not be sending sould to the speakers, to test the speakers disconnect the audio in cable and connect it to a known souce of sound such as mp3 player smart phone etc and test that the speakers work that way. if that doesnt work take them back.

Oct 22, 2014 | Audio Players & Recorders

2 Answers

I have a 1993 Mercedes 300 SE and after I got the radio unlock code from mercedes the radio worked all day just fine. I started the car the next day and the radio had a E 3 message on the display when I...


I dont remember if that year had a theft lock system or not, but I am looking into it. disconnect the negative battery cable for ten minutes and that should get you back to where you can enter the unlock code again and use the radio.

Nov 01, 2013 | 2004 Mercedes-Benz Mercedes Benz S Class

1 Answer

1999 subaru legacy b4 radio color code


Hi Caleb, There is a way of identifying the cables without the colour codes. Make up a test lamp and get an almost flat AA or AAA battery cell. The music system has an earth connection which you can identify by looking at where it is connected (onto the chassis of the set). It has a constant power supply and another which is controlled by the ignition switch. If the set you're fitting has automatic night and day illumination, there will be a connection operating from the panel lights. The constant power supplies power for the memory. First identify the connection which when connected is controlled by the ignition key. Once tested identify the cable which remains 'live' even with ignition off and mark it. With the AA or AAA battery cell, test each pair of cables by connecting one cable of the pair to the + and swiping the other cable of the pair across the - side. The speaker being tested will be identified by a 'thumping' sound. Mark each as to its physical location in the vehicle. Connect each to the correct output. and when done you will be left with the antenna connection, which only fits one place. Identify the memory power cable, the illumination power (becoming live with the park lights) and the power output from the set to the power antenna (if fitted.) Make the final connections. Record the access code somewhere safe and fit the set into the consul and happy listening. Regards John

Oct 13, 2013 | Cars & Trucks

1 Answer

What type of power souce do I need for the power plug or can I get an adapter for it for regular power supply


Hi there.
Voltage and ampere or current rating can be verified on unit's nameplate and or Owner's Manual so better check these first before using or connecting the unit to a power source.

Regards.

Jul 14, 2011 | Anvil FFA7020 Deep Fryer

1 Answer

RCA inputs not working on LZ-1100


Push the input souce select buttons on the front of th unit to select the proper input.
Twist the jacks into the amp to remove any corrosion on the terminals or the cables.
Good luck

Jun 21, 2011 | Technical Pro LZ-1100 Amplifier

1 Answer

I have a 2001 oldsmobile aurora and hooking up a pioneer 3200 model doubledin, I got a plug and connected all my wires mute, reverse gear signal, blue white, and green I can't even get the unit to turn on


You can test the unit by connecting the POWER cable from the radio to the positive terminal of battery and the ground cable of the radio to chassis, to test the pioneer.

If it works then the problem is on your cable settings.

Make sure to find the power cable from the car with a DC tester. Turn the keys off and test all the cables.

Then turn the key to accessories and test for acc cable, usually red cable.

God Bless You!

Feb 05, 2011 | Car Audio & Video

1 Answer

The scanner light on my epson 1670 fluctuates in intensity during scans which produce darker bands across printouts


check the power souce is conected properly it may be the bulb or pwer converter inside cheapest fix is to replace the whole unit.

Oct 06, 2010 | Epson Perfection 1670 Flatbed Scanner

1 Answer

Broken pin on wire


I am not familiar with this model ... I must ask ... Are these standard electronic plugs? RCA, Mini or micro phone? Mon or Stereo?

Two souces that pop into mind are Altec Lansing or Radio Shack.

Thanks for your interest in FixYa.com

May 14, 2010 | Altec Lansing ADA 885 Computer Speakers

2 Answers

I am not getting any power in my amp even though its connected to the battery in a ford escort 1998


Hi are you tasting the big red cable whit a test light ,if yes you may have problems whit the cable that says remote that should have power to it when your radio is on test it whit a test light

Sep 23, 2009 | 1998 Ford Escort

1 Answer

Changed battery cable now radio will not even come on.


When you said inline fuse I get the idea that this is not the original radio. Do you have power on the inline fuse? The 50 amp fuse you checked is a bit much for a radio. There may be a smaller fuse in another fuse area of what car type you have. If you do not have power at the inline fuse find some where you do have power (12vdc) and connect to it. If you have power at the in line fuse check the ground wire. If you have a test light or someway of checking for power test all fuses everywhere. If you have a fuse location guide for this vehicle look for the fuse for radio. If it was a add on or after market radio they probably caught power from the original source That is fused under the dash.

Jan 13, 2009 | Alpine CDM-9821 CD Player

Not finding what you are looking for?
Galaxy Radios DX-959 40-Channels Base CB Radio Logo

Related Topics:

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top Galaxy Radios Radio Communications Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Brad Brown

Level 3 Expert

15681 Answers

Steve
Steve

Level 3 Expert

693 Answers

Are you a Galaxy Radios Radio Communication Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...